Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - AMD Radeon Catalyst Drivers Section
Videocards - AMD Radeon Catalyst Drivers Section In this section you can discuss everything AMD Catalyst related. Catalyst drivers are for all AMD based graphics cards and APUs.



Reply
 
Thread Tools Display Modes
Old
  (#101)
Sasquatch_04
Member Guru
 
Videocard: R9 Fury Nitro
Processor: Intel Xeon E3-1231v3
Mainboard: ASRock H97M ITX
Memory: Kingston HyperX DDR3 8GB
Soundcard:
PSU: OCZ 600W
Default 01-12-2013, 23:21 | posts: 94

Quote:
Originally Posted by raj7095 View Post
hey sasquatch can you explain to me how you got it working for tf2? i made a profile for hl2.exe, but no matter what settings i force, nothing happens to tf2. now i can force everything else globally, but not AO.
add this line to the AO.xml file in <USERNAME>\AppData\Roaming\RadeonPro

Code:
  <File name="Half-Life 2" exe="hl2.exe" flags="d3d9:0:0xA0138040" params="farZ=5000,firstI=1,lastI=2" />
   
Reply With Quote
 
Old
  (#102)
japamd
Maha Guru
 
Videocard: AMD Radeon HD 7970Ghz
Processor: Intel
Mainboard: EVGA
Memory: Kingston 4x4 GB
Soundcard:
PSU: XFX 850W BE
Default 01-13-2013, 00:42 | posts: 2,450 | Location: Brazil

Quote:
Originally Posted by Sasquatch_04 View Post
add this line to the AO.xml file in <USERNAME>\AppData\Roaming\RadeonPro

Code:
  <File name="Half-Life 2" exe="hl2.exe" flags="d3d9:0:0xA0138040" params="farZ=5000,firstI=1,lastI=2" />
This works for TF2 too?

If TF2 uses the same executable (hl2.exe), you may use the subdirectory name as prefix to let you set custom settings for TF2 ambient occlusion profile.

For exemple, Portal, HL2 and HL2:Lost Coast use hl2.exe and HL2 needs different parameters which breaks Lost Coast.

Code:
  <File name="Half Life 2: Lost Coast" exe="half-life 2 lostcoast\hl2.exe" flags="d3d9:0:0xA0138041" params="farZ=3000,firstI=0,lastI=1" />
  <File name="Half-Life 2" exe="hl2.exe" flags="d3d9:0:0xA0138040" params="farZ=3000,firstI=1,lastI=2" />
  <File name="Portal" exe="portal\hl2.exe" flags="d3d9:0:0xA0138041" params="farZ=5000,firstI=1,lastI=2" />
The solution is put the prefix in exe parameter as shown above in code section

half-life 2 lostcoast\hl2.exe for Lost Coast
portal\hl2.exe for Portal
   
Reply With Quote
Old
  (#103)
Endymion FRS
Newbie
 
Videocard: Gigabyte HD7950 WF3
Processor: Intel Core i5 3570K
Mainboard: ASRock Z77 Extreme4
Memory: 8GB DDR3 1600
Soundcard:
PSU: Silencer MK2 650W
Default 01-13-2013, 02:55 | posts: 37 | Location: Ohio

Quote:
Originally Posted by zerowalker View Post
I donīt know which one, not to familiar, i am using well, version 1.6 i think?
Itīs saying something with "skyrim backport blabla".

And well, that doesnīt work for me with radeonpro atleast;S
You need to use the .exe created in the Fallout New Vegas/exes folder.
   
Reply With Quote
Old
  (#104)
raj7095
Member Guru
 
Videocard: Reference R9 290 4gb
Processor: Intel i7 2600k
Mainboard: Asus P8Z68-v Pro
Memory: 4gb ddr3 2133mhz 9cl
Soundcard:
PSU: 650W CoolerMaster GX
Default 01-13-2013, 03:44 | posts: 47

Quote:
Originally Posted by Sasquatch_04 View Post
add this line to the AO.xml file in <USERNAME>\AppData\Roaming\RadeonPro

Code:
  <File name="Half-Life 2" exe="hl2.exe" flags="d3d9:0:0xA0138040" params="farZ=5000,firstI=1,lastI=2" />
you still need to force ao through a radeonpro profile tho. how did you make a profile for tf2? usually if i want to change stuff like antialiasing and af for tf2, i just force it in the global profile because forcing it through a profile for hl2.exe does nothing. but since ao can't be forced globally tho, i don't have a clue how to force it in tf2. i tried toggling through key combination aswell, but it didnt work.
   
Reply With Quote
 
Old
  (#105)
Sasquatch_04
Member Guru
 
Videocard: R9 Fury Nitro
Processor: Intel Xeon E3-1231v3
Mainboard: ASRock H97M ITX
Memory: Kingston HyperX DDR3 8GB
Soundcard:
PSU: OCZ 600W
Default 01-13-2013, 04:12 | posts: 94

Quote:
Originally Posted by japamd View Post
This works for TF2 too?

If TF2 uses the same executable (hl2.exe), you may use the subdirectory name as prefix to let you set custom settings for TF2 ambient occlusion profile.

For exemple, Portal, HL2 and HL2:Lost Coast use hl2.exe and HL2 needs different parameters which breaks Lost Coast.

Code:
  <File name="Half Life 2: Lost Coast" exe="half-life 2 lostcoast\hl2.exe" flags="d3d9:0:0xA0138041" params="farZ=3000,firstI=0,lastI=1" />
  <File name="Half-Life 2" exe="hl2.exe" flags="d3d9:0:0xA0138040" params="farZ=3000,firstI=1,lastI=2" />
  <File name="Portal" exe="portal\hl2.exe" flags="d3d9:0:0xA0138041" params="farZ=5000,firstI=1,lastI=2" />
The solution is put the prefix in exe parameter as shown above in code section

half-life 2 lostcoast\hl2.exe for Lost Coast
portal\hl2.exe for Portal
To get TF2 to work i added & modified the HL2 Profile in the AO.xml because they both use the same executable name.

I'll modify the file to include the prefixes as you suggested, that way i can still keep AO settings for Half Life 2.

Quote:
Originally Posted by raj7095 View Post
you still need to force ao through a radeonpro profile tho. how did you make a profile for tf2? usually if i want to change stuff like antialiasing and af for tf2, i just force it in the global profile because forcing it through a profile for hl2.exe does nothing. but since ao can't be forced globally tho, i don't have a clue how to force it in tf2. i tried toggling through key combination aswell, but it didnt work.
Keep forcing AA/AF globally and only set AO to the TF2 profile?

Last edited by Sasquatch_04; 01-13-2013 at 04:19.
   
Reply With Quote
Old
  (#106)
raj7095
Member Guru
 
Videocard: Reference R9 290 4gb
Processor: Intel i7 2600k
Mainboard: Asus P8Z68-v Pro
Memory: 4gb ddr3 2133mhz 9cl
Soundcard:
PSU: 650W CoolerMaster GX
Default 01-13-2013, 04:24 | posts: 47

Quote:
Originally Posted by Sasquatch_04 View Post
To get TF2 to work i added & modified the HL2 Profile in the AO.xml because they both use the same executable name.

I'll modify the file to include the prefixes as you suggested, that way i can still keep AO settings for Half Life 2.



Keep forcing AA/AF globally and only set AO to the TF2 profile?
i made a profile for tf2's hl2.exe but it doesn't matter what i force on it, nothing will happen. i can't force any settings in tf2, unless they are in radeonpro's global profile. that includes everything from vsync and triple buffering, to sweetfx, to ambient occlusion. so i wanna know how you set up the profile for tf2.
   
Reply With Quote
Old
  (#107)
Sasquatch_04
Member Guru
 
Videocard: R9 Fury Nitro
Processor: Intel Xeon E3-1231v3
Mainboard: ASRock H97M ITX
Memory: Kingston HyperX DDR3 8GB
Soundcard:
PSU: OCZ 600W
Default 01-13-2013, 04:44 | posts: 94

Quote:
Originally Posted by raj7095 View Post
i made a profile for tf2's hl2.exe but it doesn't matter what i force on it, nothing will happen. i can't force any settings in tf2, unless they are in radeonpro's global profile. that includes everything from vsync and triple buffering, to sweetfx, to ambient occlusion. so i wanna know how you set up the profile for tf2.
I got it working by just adding a profile honestly. That should be it.

I don't think TF2 works by forcing any AA or Vsync settings, i have tried in the past and it does not work. You can force Triple buffering (and i think also AF) but only if you use it with the Advanced triple buffering code.
I use both SweetFX and AO and they work fine with Team Fortress 2.

i am using the gamma fix build of RP if it helps but i think your issue could be driver related.

EDIT: No scratch that, i remember you said it does work if you set it globally. Interesting, i never got any AA/Vsync settings forced globally to work with TF2 though, using CCC or RP. Something must not be working properly with RP then, because once your SweetFX folder is set correctly it should easily work.

Last edited by Sasquatch_04; 01-13-2013 at 04:52.
   
Reply With Quote
Old
  (#108)
totya
Member Guru
 
Videocard: Asus EAH4850 512MB
Processor: Core2 6400 @ 3,2Ghz
Mainboard: Gigabyte DS3
Memory: 2*2GB ADATA 800+
Soundcard: Creative Audigy 2 Value
PSU: Enermax 460W
Default 01-13-2013, 08:54 | posts: 117

Quote:
Originally Posted by japamd View Post
Quote:
Originally Posted by totya View Post
Hi!

Neverwinter Nights 1 - no OSD with RP.

This is OpenGL game, and must be running with XP compatibility mode and admin rights.

With Fraps or MSI afterburner OSD is working, with RP is not.

Thanks.
I think the XP compatibility is preventing it to work.

Disable UAC is not an option for you?
Hi!

I try this:

UAC turned off. Reboot is required, okay, reboot.

Under game icon, I switched to compatibility mode turned off. Game is started without admin rights. But nothing change, OSD is not working. (I think API monitoring is not working.) But true, this is "old" game.

Last edited by totya; 01-13-2013 at 09:02.
   
Reply With Quote
Old
  (#109)
fleggy
Member Guru
 
Videocard: 1080ti hybrid cooling
Processor: i7 6700K
Mainboard: Asus MAXIMUS VIII Ranger
Memory: 32 GB
Soundcard: SoundBlaster Zx
PSU: Corsair HX850
Default 01-13-2013, 10:54 | posts: 84

Hello Japamd,
do you think that forcing TB ON will work better in some future build? Now I have to use RTSS to force TB ON because RP does not work very well as for TB. Thank you very much
   
Reply With Quote
Old
  (#110)
japamd
Maha Guru
 
Videocard: AMD Radeon HD 7970Ghz
Processor: Intel
Mainboard: EVGA
Memory: Kingston 4x4 GB
Soundcard:
PSU: XFX 850W BE
Default 01-13-2013, 13:37 | posts: 2,450 | Location: Brazil

Quote:
Originally Posted by totya View Post
Hi!

I try this:

UAC turned off. Reboot is required, okay, reboot.

Under game icon, I switched to compatibility mode turned off. Game is started without admin rights. But nothing change, OSD is not working. (I think API monitoring is not working.) But true, this is "old" game.
Does RP create a debug log file for that game?

Quote:
Originally Posted by fleggy View Post
Hello Japamd,
do you think that forcing TB ON will work better in some future build? Now I have to use RTSS to force TB ON because RP does not work very well as for TB. Thank you very much
Which games aren't working for you?

I've heard of games that work on RP but doesn't work on D3Doverrider and vice-versa.
   
Reply With Quote
Old
  (#111)
Flisan
Member Guru
 
Videocard: 980Ti SLI
Processor: Intel i7-3770K @ 4.6GHz
Mainboard: ASUS P8Z77-V PRO
Memory: Corsair 16GB CL10 2400MHz
Soundcard: Xonar Essence STX
PSU: Corsair 850w
Default 01-13-2013, 13:56 | posts: 54 | Location: Sweden

Quote:
Originally Posted by japamd View Post
SweetFX is not an asset of RadeonPro, it's a standalone shader suite that can be used through RadeonPro. If you not familiar how SweetFX works, learn how it works before trying to use it with RP.
Thanks. Got it to work and done alot of reading. Seems to be a cool feature and i can't understand why i never used it before

Two question though.
*Is it possible that online games see this injection as a cheat? For an example. Realmware BF3 Colour Tweaker can't promise that you won't be banned.
*The keys PRINTSCRN, SCROLL_LOCK and PAUSE dosn't work for me, and i have not change any settings. Any ideas? SweetFX are running though.
   
Reply With Quote
Old
  (#112)
totya
Member Guru
 
Videocard: Asus EAH4850 512MB
Processor: Core2 6400 @ 3,2Ghz
Mainboard: Gigabyte DS3
Memory: 2*2GB ADATA 800+
Soundcard: Creative Audigy 2 Value
PSU: Enermax 460W
Default 01-13-2013, 14:23 | posts: 117

Quote:
Originally Posted by japamd View Post
Quote:
Originally Posted by totya View Post
Hi!

I try this:

UAC turned off. Reboot is required, okay, reboot.

Under game icon, I switched to compatibility mode turned off. Game is started without admin rights. But nothing change, OSD is not working. (I think API monitoring is not working.) But true, this is "old" game.
Does RP create a debug log file for that game?
If create debug log file is checked in settings, then yes. Game is started, after quit (no compatibility mode, no admin rights):

Code:
[PID: 2784-3232] 01/13/2013 15:09:35.736: Starting log for [nwmain.exe]
[PID: 2784-3232] 01/13/2013 15:09:35.737: Setup API hooking
[PID: 2784-3232] 01/13/2013 15:09:35.738: API hooking startup done
[PID: 2784-3232] 01/13/2013 15:09:35.740: Listing loaded modules at memory
[PID: 2784-3232] 01/13/2013 15:09:35.741: PID 3380 DTLite.exe
[PID: 2784-3232] 01/13/2013 15:09:35.742: PID 3760 jusched.exe
[PID: 2784-3232] 01/13/2013 15:09:35.743: PID 3780 avgnt.exe
[PID: 2784-3232] 01/13/2013 15:09:35.745: PID 4400 RadeonPro.exe
[PID: 2784-3232] 01/13/2013 15:09:35.745: PID 4520 thunderbird.exe
[PID: 2784-3232] 01/13/2013 15:09:35.746: PID 5796 firefox.exe
[PID: 2784-3232] 01/13/2013 15:09:35.748: PID 2784 nwmain.exe
[PID: 2784-3232] 01/13/2013 15:09:35.748: Listing modules loaded by target application
[PID: 2784-3232] 01/13/2013 15:09:35.749: (0x00400000) C:\Programok\Jatek\NeverwinterNights\nwmain.exe
[PID: 2784-3232] 01/13/2013 15:09:35.750: (0x771C0000) C:\Windows\SysWOW64\ntdll.dll
[PID: 2784-3232] 01/13/2013 15:09:35.750: (0x74910000) C:\Windows\syswow64\kernel32.dll
[PID: 2784-3232] 01/13/2013 15:09:35.751: (0x74B40000) C:\Windows\syswow64\KERNELBASE.dll
[PID: 2784-3232] 01/13/2013 15:09:35.752: (0x74E60000) C:\Windows\syswow64\USER32.dll
[PID: 2784-3232] 01/13/2013 15:09:35.753: (0x759F0000) C:\Windows\syswow64\GDI32.dll
[PID: 2784-3232] 01/13/2013 15:09:35.753: (0x759B0000) C:\Windows\syswow64\LPK.dll
[PID: 2784-3232] 01/13/2013 15:09:35.754: (0x755F0000) C:\Windows\syswow64\USP10.dll
[PID: 2784-3232] 01/13/2013 15:09:35.754: (0x76850000) C:\Windows\syswow64\msvcrt.dll
[PID: 2784-3232] 01/13/2013 15:09:35.755: (0x76730000) C:\Windows\syswow64\ADVAPI32.dll
[PID: 2784-3232] 01/13/2013 15:09:35.756: (0x74D50000) C:\Windows\SysWOW64\sechost.dll
[PID: 2784-3232] 01/13/2013 15:09:35.756: (0x74D70000) C:\Windows\syswow64\RPCRT4.dll
[PID: 2784-3232] 01/13/2013 15:09:35.757: (0x748A0000) C:\Windows\syswow64\SspiCli.dll
[PID: 2784-3232] 01/13/2013 15:09:35.758: (0x74890000) C:\Windows\syswow64\CRYPTBASE.dll
[PID: 2784-3232] 01/13/2013 15:09:35.758: (0x753D0000) C:\Windows\syswow64\ole32.dll
[PID: 2784-3232] 01/13/2013 15:09:35.759: (0x69220000) C:\Windows\system32\OPENGL32.dll
[PID: 2784-3232] 01/13/2013 15:09:35.760: (0x6CA90000) C:\Windows\system32\GLU32.dll
[PID: 2784-3232] 01/13/2013 15:09:35.760: (0x69BC0000) C:\Windows\system32\DDRAW.dll
[PID: 2784-3232] 01/13/2013 15:09:35.761: (0x6CDC0000) C:\Windows\system32\DCIMAN32.dll
[PID: 2784-3232] 01/13/2013 15:09:35.762: (0x75810000) C:\Windows\syswow64\SETUPAPI.dll
[PID: 2784-3232] 01/13/2013 15:09:35.762: (0x75530000) C:\Windows\syswow64\CFGMGR32.dll
[PID: 2784-3232] 01/13/2013 15:09:35.763: (0x75120000) C:\Windows\syswow64\OLEAUT32.dll
[PID: 2784-3232] 01/13/2013 15:09:35.763: (0x74A80000) C:\Windows\syswow64\DEVOBJ.dll
[PID: 2784-3232] 01/13/2013 15:09:35.764: (0x706D0000) C:\Windows\system32\dwmapi.dll
[PID: 2784-3232] 01/13/2013 15:09:35.765: (0x6CDB0000) C:\Programok\Jatek\NeverwinterNights\binkw32.dll
[PID: 2784-3232] 01/13/2013 15:09:35.765: (0x30000000) C:\Programok\Jatek\NeverwinterNights\binkw32_ati.dll
[PID: 2784-3232] 01/13/2013 15:09:35.766: (0x70B70000) C:\Windows\system32\WINMM.dll
[PID: 2784-3232] 01/13/2013 15:09:35.767: (0x6C840000) C:\Windows\system32\DINPUT.dll
[PID: 2784-3232] 01/13/2013 15:09:35.768: (0x21100000) C:\Programok\Jatek\NeverwinterNights\mss32.dll
[PID: 2784-3232] 01/13/2013 15:09:35.768: (0x70B00000) C:\Windows\system32\WSOCK32.dll
[PID: 2784-3232] 01/13/2013 15:09:35.781: (0x74BF0000) C:\Windows\syswow64\WS2_32.dll
[PID: 2784-3232] 01/13/2013 15:09:35.782: (0x74BE0000) C:\Windows\syswow64\NSI.dll
[PID: 2784-3232] 01/13/2013 15:09:35.783: (0x73180000) C:\Windows\system32\VERSION.dll
[PID: 2784-3232] 01/13/2013 15:09:35.784: (0x75690000) C:\Windows\syswow64\IMM32.dll
[PID: 2784-3232] 01/13/2013 15:09:35.784: (0x75300000) C:\Windows\syswow64\MSCTF.dll
[PID: 2784-3232] 01/13/2013 15:09:35.785: (0x70880000) C:\Windows\system32\apphelp.dll
[PID: 2784-3232] 01/13/2013 15:09:35.786: (0x69190000) C:\Windows\AppPatch\AcLayers.DLL
[PID: 2784-3232] 01/13/2013 15:09:35.787: (0x75AE0000) C:\Windows\syswow64\SHELL32.dll
[PID: 2784-3232] 01/13/2013 15:09:35.787: (0x74A20000) C:\Windows\syswow64\SHLWAPI.dll
[PID: 2784-3232] 01/13/2013 15:09:35.788: (0x716D0000) C:\Windows\system32\USERENV.dll
[PID: 2784-3232] 01/13/2013 15:09:35.789: (0x72D80000) C:\Windows\system32\profapi.dll
[PID: 2784-3232] 01/13/2013 15:09:35.789: (0x70B10000) C:\Windows\system32\WINSPOOL.DRV
[PID: 2784-3232] 01/13/2013 15:09:35.790: (0x73230000) C:\Windows\system32\MPR.dll
[PID: 2784-3232] 01/13/2013 15:09:35.791: (0x66090000) C:\Windows\AppPatch\AcGenral.DLL
[PID: 2784-3232] 01/13/2013 15:09:35.791: (0x706F0000) C:\Windows\system32\UxTheme.dll
[PID: 2784-3232] 01/13/2013 15:09:35.792: (0x742A0000) C:\Windows\system32\samcli.dll
[PID: 2784-3232] 01/13/2013 15:09:35.793: (0x6D380000) C:\Windows\system32\MSACM32.dll
[PID: 2784-3232] 01/13/2013 15:09:35.794: (0x6CDA0000) C:\Windows\system32\sfc.dll
[PID: 2784-3232] 01/13/2013 15:09:35.794: (0x6CD90000) C:\Windows\system32\sfc_os.DLL
[PID: 2784-3232] 01/13/2013 15:09:35.795: (0x751B0000) C:\Windows\syswow64\urlmon.dll
[PID: 2784-3232] 01/13/2013 15:09:35.796: (0x74F60000) C:\Windows\syswow64\iertutil.dll
[PID: 2784-3232] 01/13/2013 15:09:35.796: (0x74C30000) C:\Windows\syswow64\WININET.dll
[PID: 2784-3232] 01/13/2013 15:09:35.797: (0x77190000) C:\Windows\syswow64\Normaliz.dll
[PID: 2784-3232] 01/13/2013 15:09:35.798: (0x10000000) C:\Windows\SysWOW64\guard32.dll
[PID: 2784-3232] 01/13/2013 15:09:35.798: (0x72FA0000) C:\Windows\system32\fltlib.dll
[PID: 2784-3232] 01/13/2013 15:09:35.799: (0x664D0000) C:\Program Files (x86)\RadeonPro\AppProfiles.dll
[PID: 2784-3232] 01/13/2013 15:09:35.801: (0x74900000) C:\Windows\syswow64\PSAPI.DLL
[PID: 2784-3232] 01/13/2013 15:09:35.802: (0x6D880000) C:\Windows\system32\AVRT.dll
[PID: 2784-3232] 01/13/2013 15:09:35.803: HookStartup end
[PID: 2784-3232] 01/13/2013 15:09:35.804: API hooking ok (Watchdog timeout waiting)
[PID: 2784-3232] 01/13/2013 15:09:53.646: SystemHooks::ResetHooks enter
[PID: 2784-3232] 01/13/2013 15:09:53.647: SystemHooks::ResetHooks leave (4)
[PID: 2784-3232] 01/13/2013 15:09:53.647: StealthWrapper::RemoveHooks enter
[PID: 2784-3232] 01/13/2013 15:09:53.648: Remove 110034944
[PID: 2784-3232] 01/13/2013 15:09:53.648: StealthWrapper::RemoveHooks leave
No app profile attached of this game (now), but OSD is enbaled globally, and settings/advanced "disable API monitoring for programs not listed on my profiles list" is unchecked.

This game is crashed after game is closed, because running without XP compatibility, and UAC is ON.

Thanks.
   
Reply With Quote
The Witcher 2
Old
  (#113)
goma
Newbie
 
Videocard: AMD Sapphire 7970 VaporX
Processor: Intel i5 750
Mainboard: Gigabyte P55 UD3
Memory: 8GB DDR3 Corsair
Soundcard: Logitech
PSU: Corsair 550W
Default The Witcher 2 - 01-13-2013, 16:26 | posts: 19 | Location: Italy

Hello to all,
I downloaded the latest version 1.1.1.0 and I configured the profile for The Witcher 2
I try to launch the game directly from RP, but all the options that I selected doesn't work.
I selected SMAA ultra. SweetFx, and thr OSD display for the info
I have the Steam version, so I try to manage the option in the launcher section (Steam and custom) of RP but nothing good...
Please, anybody can help me with the Witcher 2?
   
Reply With Quote
Old
  (#114)
Derko1
Master Guru
 
Derko1's Avatar
 
Videocard: 2x HD7970 1270/1800
Processor: i7 3770k @ 4.8Ghz 1.42v
Mainboard:
Memory:
Soundcard:
PSU: Fatal1ty 1000w
Default 01-13-2013, 18:13 | posts: 398

Quote:
Originally Posted by goma View Post
Hello to all,
I downloaded the latest version 1.1.1.0 and I configured the profile for The Witcher 2
I try to launch the game directly from RP, but all the options that I selected doesn't work.
I selected SMAA ultra. SweetFx, and thr OSD display for the info
I have the Steam version, so I try to manage the option in the launcher section (Steam and custom) of RP but nothing good...
Please, anybody can help me with the Witcher 2?
Same issue here.
   
Reply With Quote
Old
  (#115)
Razor 116
Newbie
 
Videocard: nVidia GTX 980 Ti
Processor: i7 5820K 4.5GHz
Mainboard: Asus X99-Deluxe
Memory: 16GB G.Skill Ripjaws
Soundcard: Asus
PSU: EVGA Supernova G2 850W
Default 01-13-2013, 18:22 | posts: 18 | Location: UK

Sorry if this has been asked before but is it safe to use RadeonPro (Specifically SweetFX) in multiplayer steam games or will I be banned?
   
Reply With Quote
Old
  (#116)
goma
Newbie
 
Videocard: AMD Sapphire 7970 VaporX
Processor: Intel i5 750
Mainboard: Gigabyte P55 UD3
Memory: 8GB DDR3 Corsair
Soundcard: Logitech
PSU: Corsair 550W
Default 01-13-2013, 18:56 | posts: 19 | Location: Italy

Quote:
Originally Posted by Derko1 View Post
Same issue here.
I solved by myself, reinstalling RP. Try to remove the program (with the profile) and install again RP. Now is working fine
   
Reply With Quote
Old
  (#117)
zerowalker
Master Guru
 
Videocard: AMD R9 380
Processor: i5 760 4ghz
Mainboard: P7P55D-E PRO
Memory: DDR3 8gb
Soundcard: Soundblaster ZxR
PSU: 750 Watt
Default 01-13-2013, 20:33 | posts: 350

Quote:
Originally Posted by The Mac View Post
There are several patch programs.

Didnt Bethesda update the game for 4gig anyway?

Why are you trying to patch it?

this is the one i use, ive not had any problems with it.

http://www.techpowerup.com/forums/sh...d.php?t=112556
Is this compatible with Steam, can i still get achievements?


Thanks!
   
Reply With Quote
Old
  (#118)
The Mac
Ancient Guru
 
Videocard: Sapphire R9-290 Vapor-X
Processor: i7-4970K
Mainboard: MSI Z97 Gaming 5
Memory: Corsair Vengence Pro 16GB
Soundcard:
PSU: Corasir AX750
Default 01-13-2013, 21:48 | posts: 4,407 | Location: USA

Quote:
Originally Posted by zerowalker View Post
Is this compatible with Steam, can i still get achievements?


Thanks!
yes.
   
Reply With Quote
Old
  (#119)
The Mac
Ancient Guru
 
Videocard: Sapphire R9-290 Vapor-X
Processor: i7-4970K
Mainboard: MSI Z97 Gaming 5
Memory: Corsair Vengence Pro 16GB
Soundcard:
PSU: Corasir AX750
Default 01-13-2013, 21:49 | posts: 4,407 | Location: USA

Quote:
Originally Posted by Derko1 View Post
Same issue here.
i have no problems launching it.

what is your full path and .exe?

I do not have steam selected in the launcher options.

Last edited by The Mac; 01-13-2013 at 21:51.
   
Reply With Quote
Old
  (#120)
zerowalker
Master Guru
 
Videocard: AMD R9 380
Processor: i5 760 4ghz
Mainboard: P7P55D-E PRO
Memory: DDR3 8gb
Soundcard: Soundblaster ZxR
PSU: 750 Watt
Default 01-13-2013, 21:49 | posts: 350

Nice;D

But why is there a special 4gb launcher for Fallout then?
   
Reply With Quote
Old
  (#121)
The Mac
Ancient Guru
 
Videocard: Sapphire R9-290 Vapor-X
Processor: i7-4970K
Mainboard: MSI Z97 Gaming 5
Memory: Corsair Vengence Pro 16GB
Soundcard:
PSU: Corasir AX750
Default 01-13-2013, 21:53 | posts: 4,407 | Location: USA

fallout? who knows. Fallout is pretty old. Perhaps there werent a lot of tools back then. Bethesda loves that ancient Gambyro engine.

Skyrim was already patched by bethesda, if you use the program i linked above, is should tell you if its already patched or not.

Last edited by The Mac; 01-13-2013 at 21:56.
   
Reply With Quote
Old
  (#122)
evertjr
Newbie
 
Videocard: GeForce GTX 460
Processor: Intel Q6600 @3.0
Mainboard: Gigabyte G41MT-S2P
Memory: 8Gb DDR3
Soundcard:
PSU: Corsair CX600
Default 01-13-2013, 23:51 | posts: 11

There's any way to make it work with Far Cry 3 without disabling Uplay overlay? I only want dynamic vsync but it make the game crash at start. Works if I disable Uplay overlay but I'm afraid it disables achievements unlocking.

Windows 8 here.

Here's the log

Code:
[PID: 2644-5316] 01/13/2013 22:10:07.275: Starting log for [farcry3_d3d11.exe]
[PID: 2644-5316] 01/13/2013 22:10:07.276: Setup API hooking
[PID: 2644-5316] 01/13/2013 22:10:07.277: API hooking startup done
[PID: 2644-5316] 01/13/2013 22:10:07.280: Listing loaded modules at memory
[PID: 2644-5316] 01/13/2013 22:10:07.282: PID 6076 Origin.exe
[PID: 2644-5316] 01/13/2013 22:10:07.283: PID 1400 Steam.exe
[PID: 2644-5316] 01/13/2013 22:10:07.285: PID 5424 SkyDrive.exe
[PID: 2644-5316] 01/13/2013 22:10:07.287: PID 5172 RadeonPro.exe
[PID: 2644-5316] 01/13/2013 22:10:07.289: PID 3656 RaUI.exe
[PID: 2644-5316] 01/13/2013 22:10:07.291: PID 5880 raptr_im.exe
[PID: 2644-5316] 01/13/2013 22:10:07.293: PID 1752 CSISYN~1.EXE
[PID: 2644-5316] 01/13/2013 22:10:07.295: PID 356 Uplay.exe
[PID: 2644-5316] 01/13/2013 22:10:07.297: PID 6264 chrome.exe
[PID: 2644-5316] 01/13/2013 22:10:07.300: PID 6196 chrome.exe
[PID: 2644-5316] 01/13/2013 22:10:07.302: PID 5140 chrome.exe
[PID: 2644-5316] 01/13/2013 22:10:07.304: PID 5604 chrome.exe
[PID: 2644-5316] 01/13/2013 22:10:07.307: PID 3296 chrome.exe
[PID: 2644-5316] 01/13/2013 22:10:07.309: PID 1304 chrome.exe
[PID: 2644-5316] 01/13/2013 22:10:07.312: PID 740 chrome.exe
[PID: 2644-5316] 01/13/2013 22:10:07.315: PID 5396 chrome.exe
[PID: 2644-5316] 01/13/2013 22:10:07.318: PID 2644 farcry3_d3d11.exe
[PID: 2644-5316] 01/13/2013 22:10:07.321: Listing modules loaded by target application
[PID: 2644-5316] 01/13/2013 22:10:07.324: (0x00930000) D:\Steam\steamapps\common\Far Cry 3\bin\farcry3_d3d11.exe
[PID: 2644-5316] 01/13/2013 22:10:07.327: (0x77160000) C:\WINDOWS\SYSTEM32\ntdll.dll
[PID: 2644-5316] 01/13/2013 22:10:07.330: (0x76B60000) C:\WINDOWS\SYSTEM32\KERNEL32.DLL
[PID: 2644-5316] 01/13/2013 22:10:07.332: (0x74EF0000) C:\WINDOWS\SYSTEM32\KERNELBASE.dll
[PID: 2644-5316] 01/13/2013 22:10:07.335: Warning: DX stub file loaded at (0x0F270000) D:\Steam\steamapps\common\Far Cry 3\bin\FC3_d3d11.dll
[PID: 2644-5316] 01/13/2013 22:10:07.338: (0x742B0000) C:\WINDOWS\SYSTEM32\MSVCR100.dll
[PID: 2644-5316] 01/13/2013 22:10:07.340: (0x00400000) C:\WINDOWS\SYSTEM32\XINPUT1_3.dll
[PID: 2644-5316] 01/13/2013 22:10:07.343: (0x749D0000) C:\WINDOWS\SYSTEM32\WS2_32.dll
[PID: 2644-5316] 01/13/2013 22:10:07.345: (0x59DC0000) D:\Steam\steamapps\common\Far Cry 3\bin\ubiorbitapi_r2_loader.dll
[PID: 2644-5316] 01/13/2013 22:10:07.348: (0x76710000) C:\WINDOWS\SYSTEM32\USER32.dll
[PID: 2644-5316] 01/13/2013 22:10:07.350: (0x74CE0000) C:\WINDOWS\SYSTEM32\GDI32.dll
[PID: 2644-5316] 01/13/2013 22:10:07.353: (0x76F80000) C:\WINDOWS\SYSTEM32\ole32.dll
[PID: 2644-5316] 01/13/2013 22:10:07.356: (0x74B60000) C:\WINDOWS\SYSTEM32\OLEAUT32.dll
[PID: 2644-5316] 01/13/2013 22:10:07.359: (0x74370000) C:\WINDOWS\SYSTEM32\MSVCP100.dll
[PID: 2644-5316] 01/13/2013 22:10:07.362: (0x75480000) C:\WINDOWS\WinSxS\x86_microsoft.windows.gdiplus_6595b64144ccf1df_1.1.9200.16384_none_ba245425e0986353\gdiplus.dll
[PID: 2644-5316] 01/13/2013 22:10:07.365: (0x74710000) C:\WINDOWS\SYSTEM32\VERSION.dll
[PID: 2644-5316] 01/13/2013 22:10:07.368: (0x65000000) C:\WINDOWS\SYSTEM32\DINPUT8.dll
[PID: 2644-5316] 01/13/2013 22:10:07.371: (0x74CD0000) C:\WINDOWS\SYSTEM32\PSAPI.DLL
[PID: 2644-5316] 01/13/2013 22:10:07.373: (0x73D90000) C:\WINDOWS\SYSTEM32\IPHLPAPI.DLL
[PID: 2644-5316] 01/13/2013 22:10:07.376: (0x74BF0000) C:\WINDOWS\SYSTEM32\SHLWAPI.dll
[PID: 2644-5316] 01/13/2013 22:10:07.379: (0x573C0000) C:\WINDOWS\SYSTEM32\d3d11.dll
[PID: 2644-5316] 01/13/2013 22:10:07.383: (0x5D7B0000) C:\WINDOWS\SYSTEM32\d3dx11_43.dll
[PID: 2644-5316] 01/13/2013 22:10:07.386: (0x57340000) C:\WINDOWS\SYSTEM32\d3dx10_43.dll
[PID: 2644-5316] 01/13/2013 22:10:07.389: (0x65650000) C:\WINDOWS\SYSTEM32\dxgi.dll
[PID: 2644-5316] 01/13/2013 22:10:07.392: (0x572F0000) D:\Steam\steamapps\common\Far Cry 3\bin\uplay_r1_loader.dll
[PID: 2644-5316] 01/13/2013 22:10:07.395: (0x00C50000) D:\Steam\steamapps\common\Far Cry 3\bin\binkw32.dll
[PID: 2644-5316] 01/13/2013 22:10:07.398: (0x76A30000) C:\WINDOWS\SYSTEM32\ADVAPI32.dll
[PID: 2644-5316] 01/13/2013 22:10:07.401: (0x75640000) C:\WINDOWS\SYSTEM32\SHELL32.dll
[PID: 2644-5316] 01/13/2013 22:10:07.405: (0x74720000) C:\WINDOWS\SYSTEM32\WSOCK32.dll
[PID: 2644-5316] 01/13/2013 22:10:07.408: (0x76830000) C:\WINDOWS\SYSTEM32\WININET.dll
[PID: 2644-5316] 01/13/2013 22:10:07.411: (0x64D70000) C:\WINDOWS\SYSTEM32\D3DCOMPILER_43.dll
[PID: 2644-5316] 01/13/2013 22:10:07.414: (0x712F0000) C:\WINDOWS\SYSTEM32\WINMM.dll
[PID: 2644-5316] 01/13/2013 22:10:07.417: (0x751C0000) C:\WINDOWS\SYSTEM32\SETUPAPI.dll
[PID: 2644-5316] 01/13/2013 22:10:07.420: (0x74E40000) C:\WINDOWS\SYSTEM32\RPCRT4.dll
[PID: 2644-5316] 01/13/2013 22:10:07.423: (0x753E0000) C:\WINDOWS\SYSTEM32\NSI.dll
[PID: 2644-5316] 01/13/2013 22:10:07.426: (0x75080000) C:\WINDOWS\SYSTEM32\combase.dll
[PID: 2644-5316] 01/13/2013 22:10:07.429: (0x76EB0000) C:\WINDOWS\SYSTEM32\msvcrt.dll
[PID: 2644-5316] 01/13/2013 22:10:07.432: (0x769F0000) C:\WINDOWS\SYSTEM32\sechost.dll
[PID: 2644-5316] 01/13/2013 22:10:07.435: (0x73D80000) C:\WINDOWS\SYSTEM32\WINNSI.DLL
[PID: 2644-5316] 01/13/2013 22:10:07.438: (0x747F0000) C:\WINDOWS\SYSTEM32\iertutil.dll
[PID: 2644-5316] 01/13/2013 22:10:07.441: (0x71260000) C:\WINDOWS\SYSTEM32\WINMMBASE.dll
[PID: 2644-5316] 01/13/2013 22:10:07.444: (0x755F0000) C:\WINDOWS\SYSTEM32\CFGMGR32.dll
[PID: 2644-5316] 01/13/2013 22:10:07.447: (0x753C0000) C:\WINDOWS\SYSTEM32\DEVOBJ.dll
[PID: 2644-5316] 01/13/2013 22:10:07.450: (0x747D0000) C:\WINDOWS\SYSTEM32\SspiCli.dll
[PID: 2644-5316] 01/13/2013 22:10:07.454: (0x747C0000) C:\WINDOWS\SYSTEM32\CRYPTBASE.dll
[PID: 2644-5316] 01/13/2013 22:10:07.457: (0x74760000) C:\WINDOWS\SYSTEM32\bcryptPrimitives.dll
[PID: 2644-5316] 01/13/2013 22:10:07.460: (0x74990000) C:\WINDOWS\system32\IMM32.DLL
[PID: 2644-5316] 01/13/2013 22:10:07.463: (0x74FA0000) C:\WINDOWS\SYSTEM32\MSCTF.dll
[PID: 2644-5316] 01/13/2013 22:10:07.466: (0x5D420000) D:\Steam\gameoverlayrenderer.dll
[PID: 2644-5316] 01/13/2013 22:10:07.470: (0x570F0000) C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\overlay.dll
[PID: 2644-5316] 01/13/2013 22:10:07.473: (0x5A990000) C:\WINDOWS\SYSTEM32\D3D9.dll
[PID: 2644-5316] 01/13/2013 22:10:07.476: (0x71240000) C:\WINDOWS\SYSTEM32\dwmapi.dll
[PID: 2644-5316] 01/13/2013 22:10:07.479: (0x745A0000) C:\WINDOWS\SYSTEM32\shcore.dll
[PID: 2644-5316] 01/13/2013 22:10:07.482: (0x56F60000) C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\ubiorbitapi_r2.dll
[PID: 2644-5316] 01/13/2013 22:10:07.485: (0x74020000) C:\WINDOWS\system32\uxtheme.dll
[PID: 2644-5316] 01/13/2013 22:10:07.489: (0x65E90000) C:\Program Files (x86)\RadeonPro\AppProfiles.dll
[PID: 2644-5316] 01/13/2013 22:10:07.492: (0x6F910000) C:\WINDOWS\SYSTEM32\AVRT.dll
[PID: 2644-5316] 01/13/2013 22:10:07.495: HookStartup end
[PID: 2644-536] 01/13/2013 22:10:07.499: API hooking ok (Watchdog timeout waiting)
[Edit]
I found that if I disable Steam overlay it works with Uplay, so I can only use one of them. I hope it helps japamd figure out how to solve this thing.

Last edited by evertjr; 01-14-2013 at 00:43.
   
Reply With Quote
Old
  (#123)
zerowalker
Master Guru
 
Videocard: AMD R9 380
Processor: i5 760 4ghz
Mainboard: P7P55D-E PRO
Memory: DDR3 8gb
Soundcard: Soundblaster ZxR
PSU: 750 Watt
Default 01-14-2013, 05:03 | posts: 350

Okay, thanks

I think they just skipped to patch Fallout NV, Skyrim got patched as you said,
maybe the special launcher just, well, is there for no big reason.
   
Reply With Quote
Old
  (#124)
zerowalker
Master Guru
 
Videocard: AMD R9 380
Processor: i5 760 4ghz
Mainboard: P7P55D-E PRO
Memory: DDR3 8gb
Soundcard: Soundblaster ZxR
PSU: 750 Watt
Default 01-14-2013, 05:20 | posts: 350

I canīt use LAA and patch Fallout NV, steam canīt start the game, i can launch the launcher, but not the game, some error from steam:S
   
Reply With Quote
Old
  (#125)
xacid0
Master Guru
 
Videocard: Zotac GTX980Ti AMP! Omega
Processor: Intel i7-3770@4.4Ghz
Mainboard: Asus P8Z77-V LX
Memory: G.Skill RipjawX 8GB@1866
Soundcard: FiiO E07K USB AMP+DAC
PSU: Enermax 650W 82+ Bronze
Default 01-14-2013, 06:18 | posts: 438 | Location: Malaysia

I can't seem to properly enable FXAA and AO in Dota 2. Anyone know what i did wrong?

Currently using latest preview build.
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.