Guru3D.com Forums

Go Back   Guru3D.com Forums > General > General Software and Applications
General Software and Applications Trouble with software/DirectX or other programs like Detonator Destroyer.



Reply
 
Thread Tools Display Modes
Steelseries engine issue.
Old
  (#1)
Bendy52
Newbie
 
Videocard: MSI GTX 1070 AERO OC
Processor: I7 6700k
Mainboard: MSI Z170A
Memory: DDR 4 16GB 3000
Soundcard: Realtek ALC1150
PSU: Corsair CX650m
Default Steelseries engine issue. - 06-10-2017, 22:35 | posts: 22 | Location: Norway

Hi folks:

I've been having a nasty issue with Steelseries Arctis 3 headset.

I got them few days ago, the Steelseries engine install a update to the headset to enable the 7,1 audio and other stuff.

The update is basically is a software called SS Audio.
and when it start in the background CSGO conflict with it, and I cant use the steam overly until I close the task in task manager for SS Audio.

its not an issue with Steam overly cause its running in other games even when SS Audio is open in the back ground.

closing the software makes the mic abit choppy.

I have Realtek 1150 alc and Nahimic 2 + Nahimic vr as drivers for my board.

any idea ?
   
Reply With Quote
 
Old
  (#2)
Watcher
Maha Guru
 
Watcher's Avatar
 
Videocard: Gigabyte Windforce R9 380
Processor: FX-8350@4.8 H80iV2 Corsai
Mainboard: ASUS M5A99FX PRO R2.0
Memory: G.SKILL RIPJAWS 8GB @1866
Soundcard: On board Realtek
PSU: OCZ StealthXStream 2 600W
Default 06-11-2017, 02:08 | posts: 2,332 | Location: Canada

I would go to the source and ask.

https://steelseries.com/login?next=/dashboard/support

Quote:
Sign up for a SteelSeries account and have access to benefits no one else can.

Enter exclusive contests and giveaways.
Sync your settings across multiple computers using CloudSync in SteelSeries Engine.
Access support for technical issues or questions.
   
Reply With Quote
Old
  (#3)
Bendy52
Newbie
 
Videocard: MSI GTX 1070 AERO OC
Processor: I7 6700k
Mainboard: MSI Z170A
Memory: DDR 4 16GB 3000
Soundcard: Realtek ALC1150
PSU: Corsair CX650m
Default 06-15-2017, 17:44 | posts: 22 | Location: Norway

I already tried, they gave me the usual stupid support stuff like update driver and reinstall a clean version.
   
Reply With Quote
Old
  (#4)
Watcher
Maha Guru
 
Watcher's Avatar
 
Videocard: Gigabyte Windforce R9 380
Processor: FX-8350@4.8 H80iV2 Corsai
Mainboard: ASUS M5A99FX PRO R2.0
Memory: G.SKILL RIPJAWS 8GB @1866
Soundcard: On board Realtek
PSU: OCZ StealthXStream 2 600W
Default 06-16-2017, 00:42 | posts: 2,332 | Location: Canada

Quote:
Originally Posted by Bendy52 View Post
I already tried, they gave me the usual stupid support stuff like update driver and reinstall a clean version.
I sent the Link to this thread in their chat window and they indicated that they have the answer to your issue.

Contact them referring to this thread and see what happens.
   
Reply With Quote
 
Old
  (#5)
Bendy52
Newbie
 
Videocard: MSI GTX 1070 AERO OC
Processor: I7 6700k
Mainboard: MSI Z170A
Memory: DDR 4 16GB 3000
Soundcard: Realtek ALC1150
PSU: Corsair CX650m
Default 06-16-2017, 06:40 | posts: 22 | Location: Norway

I re opened a ticket, not expecting much but maybe they can check with MSI about the issue, as they must be working closely together, and maybe they can reproduce the issue with CS GO and Steamoverly in the office.
   
Reply With Quote
Old
  (#6)
Watcher
Maha Guru
 
Watcher's Avatar
 
Videocard: Gigabyte Windforce R9 380
Processor: FX-8350@4.8 H80iV2 Corsai
Mainboard: ASUS M5A99FX PRO R2.0
Memory: G.SKILL RIPJAWS 8GB @1866
Soundcard: On board Realtek
PSU: OCZ StealthXStream 2 600W
Default 06-17-2017, 17:26 | posts: 2,332 | Location: Canada

Quote:
Originally Posted by Bendy52 View Post
I re opened a ticket, not expecting much but maybe they can check with MSI about the issue, as they must be working closely together, and maybe they can reproduce the issue with CS GO and Steamoverly in the office.
Lets us know the outcome.

Last edited by Watcher; 06-20-2017 at 00:03.
   
Reply With Quote
Old
  (#7)
Bendy52
Newbie
 
Videocard: MSI GTX 1070 AERO OC
Processor: I7 6700k
Mainboard: MSI Z170A
Memory: DDR 4 16GB 3000
Soundcard: Realtek ALC1150
PSU: Corsair CX650m
Default 06-19-2017, 10:09 | posts: 22 | Location: Norway

Will do, no response yet as it was weekend.
   
Reply With Quote
Old
  (#8)
Watcher
Maha Guru
 
Watcher's Avatar
 
Videocard: Gigabyte Windforce R9 380
Processor: FX-8350@4.8 H80iV2 Corsai
Mainboard: ASUS M5A99FX PRO R2.0
Memory: G.SKILL RIPJAWS 8GB @1866
Soundcard: On board Realtek
PSU: OCZ StealthXStream 2 600W
Default Yesterday, 04:08 | posts: 2,332 | Location: Canada

What version software are you using?

SteelSeries Engine 3.10.7 is now available for download.

https://steelseries.com/engine
http://www.majorgeeks.com/files/deta...ectorrent.html
   
Reply With Quote
Old
  (#9)
Bendy52
Newbie
 
Videocard: MSI GTX 1070 AERO OC
Processor: I7 6700k
Mainboard: MSI Z170A
Memory: DDR 4 16GB 3000
Soundcard: Realtek ALC1150
PSU: Corsair CX650m
Default Today, 03:20 | posts: 22 | Location: Norway

The head set is working fine on a friend pc.

its an issue with MSI or Nahimic 2 audio driver as i can tell as seems like SSaudio and nahimic 2 driver both are conflicting. which makes the steelseries engine settings not working and cause the issue in steam overly in CS GO and some Source engine games mostly.

the funny thing is that MSI promoted this board as Steelseries ready and they didnt even test a **** on it.

my friends old laptop had the headset working great, while my 2000$ Steelseries ready pc is not.

this industry is going down hill, and im now on SSengine 3.10.8 with no change.
   
Reply With Quote
Old
  (#10)
Watcher
Maha Guru
 
Watcher's Avatar
 
Videocard: Gigabyte Windforce R9 380
Processor: FX-8350@4.8 H80iV2 Corsai
Mainboard: ASUS M5A99FX PRO R2.0
Memory: G.SKILL RIPJAWS 8GB @1866
Soundcard: On board Realtek
PSU: OCZ StealthXStream 2 600W
Default Today, 04:23 | posts: 2,332 | Location: Canada

Quote:
Originally Posted by Bendy52 View Post
The head set is working fine on a friend pc.

its an issue with MSI or Nahimic 2 audio driver as i can tell as seems like SSaudio and nahimic 2 driver both are conflicting. which makes the steelseries engine settings not working and cause the issue in steam overly in CS GO and some Source engine games mostly.

the funny thing is that MSI promoted this board as Steelseries ready and they didnt even test a **** on it.

my friends old laptop had the headset working great, while my 2000$ Steelseries ready pc is not.

this industry is going down hill, and im now on SSengine 3.10.8 with no change.
You have diagnosed the issue. You will need to work with the manufacture to resolve the issue. It may take some time and I can tell that you are getting frustrated but it will be resolved with your persistence.

Keep us updated.
   
Reply With Quote
Old
  (#11)
AsiJu
Ancient Guru
 
AsiJu's Avatar
 
Videocard: EVGA 980Ti SC+/Xtreme IV
Processor: Ryzen5 1600
Mainboard: ASRock X370 Killer SLI
Memory: G.Skill TridentZ 3000/C14
Soundcard: X-Fi Titanium + Z906
PSU: Tt. Toughpower XT 875 W
Default Today, 12:30 | posts: 3,450 | Location: Finland

Not the same issue but I only recently realized you can't assign multiple keystrokes to mouse buttons or record a macro that would keep the assigned keys pressed (as long as the mouse button is pressed) in Steelseries Engine.

Sent a ticket, got a response saying it's indeed not possible atm but they will forward the ticket to development as feature request.

Whether they really did and whether the feature will be added is anyone's guess but at least they responded and are now aware of the lacking feature.

Ofc I referred to their competition as reference to boost my case (Logitech has that functionality in SetPoint/Gaming Software AFAIK).
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.