Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - AMD Radeon Catalyst Drivers Section
Videocards - AMD Radeon Catalyst Drivers Section In this section you can discuss everything AMD Catalyst related. Catalyst drivers are for all AMD based graphics cards and APUs.



Reply
 
Thread Tools Display Modes
APU A10 drivers/Switchable Graphic 17.4.4
Old
  (#1)
freezerain
Newbie
 
Videocard: r7 m360 2gb
Processor: APU a10-8780p
Mainboard:
Memory:
Soundcard:
PSU: Laptop
Unhappy APU A10 drivers/Switchable Graphic 17.4.4 - 06-03-2017, 01:06 | posts: 3

Hello, Guru´s!
I have HP Pavilion 15-ab128no with APU A10 8780p + R7 and dedicated R7 m360 2 Gb. 16 gb DDR3, ssd.

First im installed 16.12 drivers from AMD site, last for that moment and its give me code 43, so i installed latest drivers from my manufacturer site 15.201 and i think it was working but im not sure, because i updated it to 16.9 and device manager show me that everything is cool and i forgot about it for almost half year until 17.4.4 is release. I was trying to update to 17.4.4 or 17.5 but its show me code 43, then i try to use microsoft update that instaled some drivers from 2015 year and on that moment i was cheking if my dedicated gpu is working or not and it seems that its not. After that i used 15.11 beta that i found on this site and its working but only for APU, not dedicated. So here what i have:

1) I reinstalled i think 30-50 times drivers with/without chipset drivers on different order, clean with AMDclean utility and DDU. For now im using fresh clean reinstaled windows 10 because i was thinkin that i broke someting.
2) I tryed drivers: Microsoft Update (outdated) / 15.201(manufactured) / 15.11 beta/ 16.9 / 16.12 / 17.4.4 / 17.5 versions and only Microsoft, 15.11 and 16.9 are not giving me code 43
3) On any version of driver my dedicated gpu is not using. Im tested in performance mode in CCC and Windows Power manager, powersave mode, GPU-Z sensors, Passmark Performance test, LoL game (40-70 fps on any configuration) and elite dangerous (10 fps on 1080p minimum settings). FPS in game not changing in any direction, GPU-Z and Passmark showing that only APU is working. CCC Monitor shows sometime powersave mode for .exe sometimes performance regardless of what global and local settings im setted up, but infact its always powersave.
4) When i activate dual-graphic mode my dedicated gpu is starting to worming up in GPU-Z, still its not loaded and even under load its rarely going to 1200mhz of maximum and stay on 300 mhz, and fps droped in LoL to 30 and in elite to 1 in menu. Atleast its alive
5)After fresh reinstal windows 10 that i maded today, my "realtek pcie fe family controler" goes crazy. its showing me code 10, if i try to update drivers - reboot, delete drivers - reboot, delete device - reboot. Two times i was on boot-loop, so i use safe mode to disable it.

There are somewhere two of my threads on amd forum but you know, nobody answer there

So what do you think, my motherboard is broken or something like that, or i did something wrong with soft, or anything i missed there.
Im used this laptop to render 2k archviz, coding for unreal, playing with my mate and all that time (8 month) without second gpu, so many times i was wondering why viewport in Maya 2017 is lagging and was thinking that all laptop GPU is like that. Once i was sculpted character in mudbox with near 6 mil polys, that was hard...
Please help me
   
Reply With Quote
 
Old
  (#2)
fez
Master Guru
 
Videocard: Club3D Radeon 7870 2gb
Processor: Intel Core 2 Duo E8500
Mainboard: Gigabyte P35-DS4
Memory: DDR 2 8gb
Soundcard: X-FI xtreme music
PSU: Chieftec 550w
Default 06-03-2017, 12:37 | posts: 208

Have you added applications to the list that use your faster graphics card? Default detection may not be accurate, so change them manually to high performance.
https://community.amd.com/docs/DOC-1581
   
Reply With Quote
Old
  (#3)
freezerain
Newbie
 
Videocard: r7 m360 2gb
Processor: APU a10-8780p
Mainboard:
Memory:
Soundcard:
PSU: Laptop
Default 06-03-2017, 19:21 | posts: 3

Quote:
Originally Posted by fez View Post
Have you added applications to the list that use your faster graphics card? Default detection may not be accurate, so change them manually to high performance.
Hey, Fez. Thx for reply. Ofcourse i add every possible .exe that i tested. For now all aplication in AMD Monitor in powersaving mode, even if i set those .exe in Performance
   
Reply With Quote
Old
  (#4)
fez
Master Guru
 
Videocard: Club3D Radeon 7870 2gb
Processor: Intel Core 2 Duo E8500
Mainboard: Gigabyte P35-DS4
Memory: DDR 2 8gb
Soundcard: X-FI xtreme music
PSU: Chieftec 550w
Default 06-03-2017, 19:40 | posts: 208

Do you have power adapter connected to your laptop? Because it goes into power saving mode if it is on battery. Check your power options over, maybe it is set manually low.
or
Read those posts there: http://forums.guru3d.com/showthread.php?t=411618
maybe you can get help. Similar problem only different cpu.

Last edited by fez; 06-03-2017 at 19:45.
   
Reply With Quote
 
Old
  (#5)
freezerain
Newbie
 
Videocard: r7 m360 2gb
Processor: APU a10-8780p
Mainboard:
Memory:
Soundcard:
PSU: Laptop
Default 06-04-2017, 10:19 | posts: 3

Quote:
Originally Posted by fez View Post
Do you have power adapter connected to your laptop? Because it goes into power saving mode if it is on battery. Check your power options over, maybe it is set manually low.
or
Read those posts there:
maybe you can get help. Similar problem only different cpu.
Ofcourse, Performance are setted both for battery and cabel in CCC and windows power settings. In this link i found UnifL drivers, i will create restore point and will check it, who knows, maybe it will work for me.
   
Reply With Quote
Reply

Tags
apu, drivers, hp pavilion, switchable graphics, windows 10

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.