Guru3D.com Forums

Go Back   Guru3D.com Forums > Hardware > Soundcards, Speakers HiFI & File formats
Soundcards, Speakers HiFI & File formats A cracking SoundBlaster ? Got new Speakers ? Be heard in here !



Reply
 
Thread Tools Display Modes
Sound Blaster Z + Logitech Z506
Old
  (#1)
Abilio_KID
Master Guru
 
Abilio_KID's Avatar
 
Videocard: Asus GTX 780 OC DCII 3GB
Processor: Intel Core i7 920 @ 4 Ghz
Mainboard: Asus P6T SE iX58
Memory: DDR3 / 3x2GB + 3x4GB
Soundcard: SoundBlaster Z
PSU: Corsair HX750 Modular
Default Sound Blaster Z + Logitech Z506 - 02-13-2017, 17:07 | posts: 628 | Location: Portugal

Sorry if a similar topic has been made already but I've looked everywhere and couldn't be 100% sure on the question.
Recently got a cheap Z506 to replace a very old FPS1600 (4.1) set on my PC. I never quite understood what settings in Z's control panel should I use for these speakers. I know they have some crossover that sends audio to the proper speaker or sub, but I need to know if:
- Should I enable the subwoofer in Z speakers settings?
- Should I also enable ""Full-Range Speakers"?
- Too much sound comes from the center speakers so I loose the "4 speakers 3D" feeling I'm used to. If I set the volume lower, will it affect movies and games?

Speakers are set to 5.1 in Windows and Z's control panel, plus I use SBX Pro.
Yes, I', being picky about it. I prefer to use the correct settings even if I can't hear a difference, lol...
   
Reply With Quote
 
Old
  (#2)
Tacoboy
Master Guru
 
Tacoboy's Avatar
 
Videocard: AMD 7800
Processor: Amd 6350 6-core
Mainboard: MSI 970 Gaming
Memory: 8GB DDR3
Soundcard: Xonar DS
PSU: Antec 750W
Default 02-15-2017, 06:16 | posts: 398 | Location: Calif.

Did you disable the motherboard's on-board audio, in the BIOS, when you installed the SB-Z card?
   
Reply With Quote
Old
  (#3)
Hammie
Master Guru
 
Hammie's Avatar
 
Videocard: 760 SMG 28" 1ms 3840x2160
Processor: 4930k Ivy-E 4.5Ghz 12HT
Mainboard: ASUS Sabertooth X79 64GB
Memory: Corsair Veng. 1890
Soundcard: Xonar D2 & KRK Rokit 10-3
PSU: Corsair AX860
Default 02-15-2017, 07:36 | posts: 561 | Location: Glendale, CA

Even if onboard audio is enabled, he needs drivers to make it work. SO thats not the problem. I think the problem is Creative sucks badly. You got good speakers tho. gl
   
Reply With Quote
Old
  (#4)
Hammie
Master Guru
 
Hammie's Avatar
 
Videocard: 760 SMG 28" 1ms 3840x2160
Processor: 4930k Ivy-E 4.5Ghz 12HT
Mainboard: ASUS Sabertooth X79 64GB
Memory: Corsair Veng. 1890
Soundcard: Xonar D2 & KRK Rokit 10-3
PSU: Corsair AX860
Default 02-15-2017, 07:37 | posts: 561 | Location: Glendale, CA

What OS are you using ? If your on 8.1 or 10 theres your problem. Creative has horrible driver support.

Also make sure your not using any sound effect in the creative panel.

And of course grab the latest drivers for your card. gl

Last edited by Hammie; 02-15-2017 at 07:41.
   
Reply With Quote
 
Old
  (#5)
Abilio_KID
Master Guru
 
Abilio_KID's Avatar
 
Videocard: Asus GTX 780 OC DCII 3GB
Processor: Intel Core i7 920 @ 4 Ghz
Mainboard: Asus P6T SE iX58
Memory: DDR3 / 3x2GB + 3x4GB
Soundcard: SoundBlaster Z
PSU: Corsair HX750 Modular
Default 02-15-2017, 16:23 | posts: 628 | Location: Portugal

Quote:
Originally Posted by Tacoboy View Post
Did you disable the motherboard's on-board audio, in the BIOS, when you installed the SB-Z card?
Of course I did, long time ago. What's it got to do with the topic?

Quote:
Originally Posted by Hammie
Even if onboard audio is enabled, he needs drivers to make it work. SO thats not the problem. I think the problem is Creative sucks badly. You got good speakers tho. gl
I never said drivers were not working as they should...

Quote:
Originally Posted by Hammie
What OS are you using ? If your on 8.1 or 10 theres your problem. Creative has horrible driver support.
Also make sure your not using any sound effect in the creative panel.
And of course grab the latest drivers for your card. gl
I'm on Windows 7 SP1 Ultimate x64. Anything after that is... well... not going into that! I'm using SBX Surround Pro.

Like I clearly (I thought it was clear) said in the topic, all is working fine. I just need to know, with my sound card and speakers, what should be the correct settings in Z's control panel.
   
Reply With Quote
Old
  (#6)
Hammie
Master Guru
 
Hammie's Avatar
 
Videocard: 760 SMG 28" 1ms 3840x2160
Processor: 4930k Ivy-E 4.5Ghz 12HT
Mainboard: ASUS Sabertooth X79 64GB
Memory: Corsair Veng. 1890
Soundcard: Xonar D2 & KRK Rokit 10-3
PSU: Corsair AX860
Default 02-15-2017, 16:50 | posts: 561 | Location: Glendale, CA

Ok sweet everything works for you thats great. Do a search on youtube unless someone here has a SB Z. gl
   
Reply With Quote
Old
  (#7)
Abilio_KID
Master Guru
 
Abilio_KID's Avatar
 
Videocard: Asus GTX 780 OC DCII 3GB
Processor: Intel Core i7 920 @ 4 Ghz
Mainboard: Asus P6T SE iX58
Memory: DDR3 / 3x2GB + 3x4GB
Soundcard: SoundBlaster Z
PSU: Corsair HX750 Modular
Default 02-15-2017, 17:00 | posts: 628 | Location: Portugal

Quote:
Originally Posted by Hammie View Post
Ok sweet everything works for you thats great. Do a search on youtube unless someone here has a SB Z. gl
Sorry if it looks like I'm being an a$$ (I guess it comes with age) but I did mention in the topic what I was looking for. Right?
Quote:
Originally Posted by Abilio_KID
Sorry if a similar topic has been made already but I've looked everywhere and couldn't be 100% sure on the question.
I asked here for someone, with the same combo (card and speakers), that could be sure about the correct settings for the control panel. I did look online but that led me to a mix of answears. So yeah, being picky on the matter, I decided to ask.
Anyway, thanks for the replies.
   
Reply With Quote
Old
  (#8)
Hammie
Master Guru
 
Hammie's Avatar
 
Videocard: 760 SMG 28" 1ms 3840x2160
Processor: 4930k Ivy-E 4.5Ghz 12HT
Mainboard: ASUS Sabertooth X79 64GB
Memory: Corsair Veng. 1890
Soundcard: Xonar D2 & KRK Rokit 10-3
PSU: Corsair AX860
Default 02-15-2017, 21:18 | posts: 561 | Location: Glendale, CA

Its not the speakers I can guarantee you that. Its the sound card and OS issue.

You must try your SB Z on a different computer and see if you get the crackling. Then get back to us.
   
Reply With Quote
Old
  (#9)
Abilio_KID
Master Guru
 
Abilio_KID's Avatar
 
Videocard: Asus GTX 780 OC DCII 3GB
Processor: Intel Core i7 920 @ 4 Ghz
Mainboard: Asus P6T SE iX58
Memory: DDR3 / 3x2GB + 3x4GB
Soundcard: SoundBlaster Z
PSU: Corsair HX750 Modular
Default 02-15-2017, 21:26 | posts: 628 | Location: Portugal

Huh? What crackling? Sorry Hammie, did you even read all that I typped here?
   
Reply With Quote
Old
  (#10)
CPC_RedDawn
Ancient Guru
 
CPC_RedDawn's Avatar
 
Videocard: MSI GTX1080 +110/+500 h20
Processor: i7 7700K @5.1GHz @ 1.325v
Mainboard: MSI Z270 Gaming M7
Memory: 16GB Vengence 3600MHz
Soundcard: HyperX Cloud II USB
PSU: 1200W
Default 02-15-2017, 21:40 | posts: 7,353 | Location: Wolverhampton/United Kingdom

try these drivers if you haven't already.

CREATIVE LATEST DRIVERS
http://www.hardwareheaven.com/commun...0-whql.236457/

or try the older but custom PAX drivers

PAX2016 WIN10 DRIVER
http://www.hardwareheaven.com/commun...ows-10.233987/
   
Reply With Quote
Old
  (#11)
Abilio_KID
Master Guru
 
Abilio_KID's Avatar
 
Videocard: Asus GTX 780 OC DCII 3GB
Processor: Intel Core i7 920 @ 4 Ghz
Mainboard: Asus P6T SE iX58
Memory: DDR3 / 3x2GB + 3x4GB
Soundcard: SoundBlaster Z
PSU: Corsair HX750 Modular
Default 02-15-2017, 21:50 | posts: 628 | Location: Portugal

But WTF are you people on??? I only need to know, inside sound blaster Z control panel, if I should enable the subwoofer and/or should I also enable ""Full-Range Speakers", considering the speakers I have. I'm asking because these seem to have some type of crossover inside the subwoofer that redirects frequencies as it needs to.
Why do you people keep telling me I have driver problems, if I specifically said I have none???
   
Reply With Quote
Old
  (#12)
Anarion
Ancient Guru
 
Anarion's Avatar
 
Videocard: EVGA GeForce GTX 1070 ACX
Processor: Intel Core i7 3770K
Mainboard: ASUS P8Z77-V
Memory: G.SKILL RipjawsX 16 GB
Soundcard: Sound Blaster Zx + HD 595
PSU: Corsair AX760
Default 02-15-2017, 23:51 | posts: 12,887 | Location: Finland

Pretty unreal replies... I'm on phone so I can't quite find out if those satelite speakers are full range or not. Probably not since it's a 5.1 system. So, I wouldn't tick the full range boxes for satelite speakers. Also make sure that windows' audio settings match the Creative control panel settings. And yes, enable subwoofer since you have it.

I wouldn't use SBX setting if I were you. It works best to simulate surround sound for headphones but when used with real 5.1 setup... It probably just messes up the sound.

Also try uninstalling the speaker setup thingy. I have had some serious problems with it (messing up headphone soundstage when using the lineout)

Last edited by Anarion; 02-15-2017 at 23:58.
   
Reply With Quote
Old
  (#13)
Abilio_KID
Master Guru
 
Abilio_KID's Avatar
 
Videocard: Asus GTX 780 OC DCII 3GB
Processor: Intel Core i7 920 @ 4 Ghz
Mainboard: Asus P6T SE iX58
Memory: DDR3 / 3x2GB + 3x4GB
Soundcard: SoundBlaster Z
PSU: Corsair HX750 Modular
Default 02-15-2017, 23:59 | posts: 628 | Location: Portugal

Quote:
Originally Posted by Anarion View Post
Pretty unreal replies... I'm on phone so I can't quite find out if those satelite speakers are full range or not. Probably not since it's a 5.1 system. So, I wouldn't tick the full range boxes for satelite speakers. Also make sure that windows' audio settings match the Creative control panel settings. And yes, enable subwoofer since you have it.

I wouldn't use SBX setting if I were you. It works best to simulate surround sound for headphones but when used with real 5.1 setup... It probably just messes up the sound.

Also try uninstalling the speaker setup thingy. I have had some serious problems with it.
Indeed...
Thank you very much. As a coincidence, I was already doing like you said except I use SBX to hear music on all speakers. I know it's not ideal in terms of quality but I'm used to it. For movies and games, I'll try with SBX off.
Thanks once more.
   
Reply With Quote
Old
  (#14)
Tacoboy
Master Guru
 
Tacoboy's Avatar
 
Videocard: AMD 7800
Processor: Amd 6350 6-core
Mainboard: MSI 970 Gaming
Memory: 8GB DDR3
Soundcard: Xonar DS
PSU: Antec 750W
Default 02-17-2017, 06:22 | posts: 398 | Location: Calif.

Quote:
Originally Posted by Abilio_KID View Post
Of course I did, long time ago. What's it got to do with the topic?
Just wanted to make sure on-board was disabled.
you said center channel was too loud and wanted to make sure there was no active on-board audio effecting the center channel.
   
Reply With Quote
Old
  (#15)
Tessiia92
Newbie
 
Tessiia92's Avatar
 
Videocard: EVGA GTX 770 Superclocked
Processor: AMD 8360
Mainboard: Gigabyte 990XA-UD3
Memory: 16GB Corsair Vengeance LP
Soundcard: Logitech z506 & SBz
PSU: 700W CoolerMaster ProM
Default 04-23-2017, 17:02 | posts: 6 | Location: England, UK

This page has made me laugh, the replies all look like they are from another post!

I have the same combo as you though I am not quite as fussy so I will tell you what I know.

Full Range: Yes, enable it, here is something from another site that may explain better:
"Actually they aren't full range. According to Logitech they fall off at 45Hz, I'm willing to bet it's more like in the low 50's though.
@OP: If you're talking about the settings on your computer then yes, you set them to full range. The electronics in the sub will include a crossover that will separate the lows from the mids and highs and send the low end to the sub."

Your centre speaker is louder: Go to the Speakers/Headphones tab, next to the drop down box where you select 5.1, click the wrench icon, now the bottom tab, speaker level. Here you can balance the speakers exactly as you need them and also, check your polarity, that can cause issues if not set correctly.

As far as enabling Subwoofer goes, yes, enable it. If you disable it and click the bass speaker icon then you will notice the test sound play in your other speakers, if you enable it and do the same, you will notice the test souns play from the sub.


Hope this helps. It is a great combo, I love the sound from them!

Oh and one more thing, there is no need whatsoever to disable on-board sound, I actually use the on-board to send sound to my TV when watching films and then switch back to the sound blaster for sitting at my desk, no problems at all, ever!
   
Reply With Quote
Old
  (#16)
Abilio_KID
Master Guru
 
Abilio_KID's Avatar
 
Videocard: Asus GTX 780 OC DCII 3GB
Processor: Intel Core i7 920 @ 4 Ghz
Mainboard: Asus P6T SE iX58
Memory: DDR3 / 3x2GB + 3x4GB
Soundcard: SoundBlaster Z
PSU: Corsair HX750 Modular
Default 04-23-2017, 18:42 | posts: 628 | Location: Portugal

Quote:
Originally Posted by Tessiia92 View Post
This page has made me laugh, the replies all look like they are from another post!

I have the same combo as you though I am not quite as fussy so I will tell you what I know.

Full Range: Yes, enable it, here is something from another site that may explain better:
"Actually they aren't full range. According to Logitech they fall off at 45Hz, I'm willing to bet it's more like in the low 50's though.
@OP: If you're talking about the settings on your computer then yes, you set them to full range. The electronics in the sub will include a crossover that will separate the lows from the mids and highs and send the low end to the sub."

Your centre speaker is louder: Go to the Speakers/Headphones tab, next to the drop down box where you select 5.1, click the wrench icon, now the bottom tab, speaker level. Here you can balance the speakers exactly as you need them and also, check your polarity, that can cause issues if not set correctly.

As far as enabling Subwoofer goes, yes, enable it. If you disable it and click the bass speaker icon then you will notice the test sound play in your other speakers, if you enable it and do the same, you will notice the test souns play from the sub.


Hope this helps. It is a great combo, I love the sound from them!

Oh and one more thing, there is no need whatsoever to disable on-board sound, I actually use the on-board to send sound to my TV when watching films and then switch back to the sound blaster for sitting at my desk, no problems at all, ever!
Thank you for your reply. Yes, indeed the replies... well... enough of that.
I had seen that topic before but, with so many other topics saying differently, it really got a bit confusing. My problem is whatever the speaker set does to the sound. How I see it is: no matter what goes from the soundcard to the speakers, the crossover will always make up his mind (+-). I just wondered how it would affect sounds in Windows itself.
About the center channel, it makes sense that it's louder because it has 2 satellites and not just 1. Does the crossover make any adjustments to it? Who knows...
I'll have to check the polarity though, never touched it.
   
Reply With Quote
Old
  (#17)
Tessiia92
Newbie
 
Tessiia92's Avatar
 
Videocard: EVGA GTX 770 Superclocked
Processor: AMD 8360
Mainboard: Gigabyte 990XA-UD3
Memory: 16GB Corsair Vengeance LP
Soundcard: Logitech z506 & SBz
PSU: 700W CoolerMaster ProM
Default 04-23-2017, 18:56 | posts: 6 | Location: England, UK

I don't think the crossover effects the loudness of the centre speaker but you can lower the volume of each speaker individually in SBX Pro Studio, just follow the instructions in my previous post to look at that.

The polarity could be why you are not getting the "3D effect" as if it is set wrong, the audio will sound as if it is coming from every direction rather then rear, front, centre etc.

Have you tried turning the Surround on and turning that up/down to see if it helps? I have both the surround and crystalizer turned on at default levels which sounds nice.

Last edited by Tessiia92; 04-23-2017 at 19:01.
   
Reply With Quote
Old
  (#18)
Tessiia92
Newbie
 
Tessiia92's Avatar
 
Videocard: EVGA GTX 770 Superclocked
Processor: AMD 8360
Mainboard: Gigabyte 990XA-UD3
Memory: 16GB Corsair Vengeance LP
Soundcard: Logitech z506 & SBz
PSU: 700W CoolerMaster ProM
Default 04-23-2017, 19:06 | posts: 6 | Location: England, UK

I have been playing with my speaker levels, they are all about the same distance from me and I have just managed to get much better "3D sound" then ever before, this is how I have them set:

Front Left: 0
Front Center: -2
Front Right: 0
Rear Left: 8
Rear Right: 8
Subwoofer: 0 (as it can be changed on the sub)

Let me know if that helps, you could turn the center down to maybe 4 but I like the vocals standing out a bit more in music so the slightly higher level is nice for me.
   
Reply With Quote
Old
  (#19)
Abilio_KID
Master Guru
 
Abilio_KID's Avatar
 
Videocard: Asus GTX 780 OC DCII 3GB
Processor: Intel Core i7 920 @ 4 Ghz
Mainboard: Asus P6T SE iX58
Memory: DDR3 / 3x2GB + 3x4GB
Soundcard: SoundBlaster Z
PSU: Corsair HX750 Modular
Default 04-23-2017, 19:35 | posts: 628 | Location: Portugal

Quote:
Originally Posted by Tessiia92 View Post
I have been playing with my speaker levels, they are all about the same distance from me and I have just managed to get much better "3D sound" then ever before, this is how I have them set:

Front Left: 0
Front Center: -2
Front Right: 0
Rear Left: 8
Rear Right: 8
Subwoofer: 0 (as it can be changed on the sub)

Let me know if that helps, you could turn the center down to maybe 4 but I like the vocals standing out a bit more in music so the slightly higher level is nice for me.
My main problem is the fact I come from an old 4.1 surround system with a Sound Blaster Audigy + Surround Stereo (that played music in all 4 speakers).
Since I got the Sound Blaster Z, the rear speakers seemed to play less than the front ones. Then I got the Logitech 5.1 and the center speaker seems louder... yeah, I'm too picky, I know.

The way you just described, you're reducing the center channel and adding a bit to the rear ones. The problem is it seems to affect the sound in games and 6 channels movies too (or it's placebo?).

If I set SBX at 100%, I get better sound in the rear channels but the center channel steals sound from the front ones (mostly voices). If I set SBX to 40%, the center becomes decent but there's almost no sound from the rear ones... sigh.

I can try to "fix" it by setting the music player to spread sound trough all speakers (trough any plugin/setting available) but then I'd have to turn SBX off, so it doesn't interfere, lol!

Anyway, I'll leave it like you first said and not bother too much anymore.
Thank you for your time on this
   
Reply With Quote
Old
  (#20)
Tessiia92
Newbie
 
Tessiia92's Avatar
 
Videocard: EVGA GTX 770 Superclocked
Processor: AMD 8360
Mainboard: Gigabyte 990XA-UD3
Memory: 16GB Corsair Vengeance LP
Soundcard: Logitech z506 & SBz
PSU: 700W CoolerMaster ProM
Default 04-24-2017, 00:06 | posts: 6 | Location: England, UK

The only other thing I can suggest is to use the profiles and set one for Music, one for gaming, one for films etc. I have one for music producing which is basic, nothing turned on and a few different ones for music depending on mood and time of day.

No thanks needed, I'm glad to have been some help
   
Reply With Quote
Old
  (#21)
Alessio1989
Master Guru
 
Videocard: Two different furnaces
Processor: It's getting old...
Mainboard: A voltage leaker...
Memory: Heap corruption
Soundcard: It's over 109db!!!!
PSU: Finally, a quite engine
Default 04-24-2017, 14:01 | posts: 677 | Location: Good-food-land

Quote:
Originally Posted by Abilio_KID View Post
Sorry if a similar topic has been made already but I've looked everywhere and couldn't be 100% sure on the question.
Recently got a cheap Z506 to replace a very old FPS1600 (4.1) set on my PC. I never quite understood what settings in Z's control panel should I use for these speakers. I know they have some crossover that sends audio to the proper speaker or sub, but I need to know if:
- Should I enable the subwoofer in Z speakers settings?
- Should I also enable ""Full-Range Speakers"?
- Too much sound comes from the center speakers so I loose the "4 speakers 3D" feeling I'm used to. If I set the volume lower, will it affect movies and games?

Speakers are set to 5.1 in Windows and Z's control panel, plus I use SBX Pro.
Yes, I', being picky about it. I prefer to use the correct settings even if I can't hear a difference, lol...
-yes
-no
-you can adjust the volume of the individual spakers in the windows control panel, it will apply @system level. Otherwise, if your sound blaster has the speaker calibration utility, you can use it.


Last edited by Alessio1989; 04-24-2017 at 14:04.
   
Reply With Quote
Old
  (#22)
Tessiia92
Newbie
 
Tessiia92's Avatar
 
Videocard: EVGA GTX 770 Superclocked
Processor: AMD 8360
Mainboard: Gigabyte 990XA-UD3
Memory: 16GB Corsair Vengeance LP
Soundcard: Logitech z506 & SBz
PSU: 700W CoolerMaster ProM
Default 04-24-2017, 18:04 | posts: 6 | Location: England, UK

Quote:
Originally Posted by Alessio1989 View Post
-yes
-no
-you can adjust the volume of the individual spakers in the windows control panel, it will apply @system level. Otherwise, if your sound blaster has the speaker calibration utility, you can use it.
Why no to full range? Do you have the same speakers? I do and after having looked into it for a while you can set full range on these speakers as they sort out the crossover themselves. I have had them on full range for months and they sound amazing. I think it's better to send full range to the sub electronics and let the speakers divide it out themselves, as they have a better idea of which speaker can handle what compared to the software.

The sound blaster software has it's own volume control for individual speakers as already pointed out.
   
Reply With Quote
Old
  (#23)
Alessio1989
Master Guru
 
Videocard: Two different furnaces
Processor: It's getting old...
Mainboard: A voltage leaker...
Memory: Heap corruption
Soundcard: It's over 109db!!!!
PSU: Finally, a quite engine
Default 04-24-2017, 19:41 | posts: 677 | Location: Good-food-land

Quote:
Originally Posted by Tessiia92 View Post
Why no to full range? Do you have the same speakers? I do and after having looked into it for a while you can set full range on these speakers as they sort out the crossover themselves. I have had them on full range for months and they sound amazing. I think it's better to send full range to the sub electronics and let the speakers divide it out themselves, as they have a better idea of which speaker can handle what compared to the software.

The sound blaster software has it's own volume control for individual speakers as already pointed out.
Logitech Z506 are not full range speakers.
   
Reply With Quote
Old
  (#24)
Tessiia92
Newbie
 
Tessiia92's Avatar
 
Videocard: EVGA GTX 770 Superclocked
Processor: AMD 8360
Mainboard: Gigabyte 990XA-UD3
Memory: 16GB Corsair Vengeance LP
Soundcard: Logitech z506 & SBz
PSU: 700W CoolerMaster ProM
Default 04-24-2017, 20:03 | posts: 6 | Location: England, UK

Quote:
Originally Posted by Alessio1989 View Post
Logitech Z506 are not full range speakers.
No, but like I quoted from elsewhere:
"Actually they aren't full range. According to Logitech they fall off at 45Hz, I'm willing to bet it's more like in the low 50's though.
If you're talking about the settings on your computer then yes, you set them to full range. The electronics in the sub will include a crossover that will separate the lows from the mids and highs and send the low end to the sub."

So though they are not full range, you set them as full range.
   
Reply With Quote
Old
  (#25)
starlance
Newbie
 
Videocard: GTX 1050
Processor: Quad Core
Mainboard:
Memory:
Soundcard:
PSU: 450W
Default 06-25-2017, 14:41 | posts: 1

I came here trying to find out why my new Soundblaster z wasnt working with my also new Logitec Z506. I had the same issue with crossover and sound muffling etc and i eventually found out the wires from the SB card to the Logictec were in wrong holes. No idea why they didnt put the correct colour indicators on the SB card or manual but the should be Green = Front L/R, Black = Rear L/R and Orange = Centre/Sub. After swapping them the sound works as intended I know you probably already worked that out but if anyone like me couldnt figure whats wrong at least google will take them here
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.