Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - AMD Radeon
Videocards - AMD Radeon AMD Radeon graphics cards. Do you have one or want to buy one? Use this forum to discuss anything concerning products using Radeon graphics cards, CrossFireX, from Radeon HD 7800 to R9 390X



Reply
 
Thread Tools Display Modes
Old
  (#26)
dudecat64
Ancient Guru
 
Videocard: POWERCOLOR PCS+ R9 380 4G
Processor: Intel Core i5 4460
Mainboard: GIGABYTE Z97X-GAMING 7
Memory: DDR3 4 x 4gigs
Soundcard: Onboard sound blaster
PSU: COOLER MASTER G750M
Default 03-10-2017, 18:19 | posts: 3,680 | Location: nystate

I know the feeling. Mine was tested bad. So know i have to wait 7-8 days for them to decide what they are sending me back. I was on the phone with them. Stupid powercolor just send me back a rx470 and i will be happy. Why wait another week for a answer lol.
   
Reply With Quote
 
Old
  (#27)
Chastity
Master Guru
 
Chastity's Avatar
 
Videocard: A dead Sapphire 390
Processor: Intel i7 950@4GHz
Mainboard: Rampage III Black X58
Memory: 6GB Dominators 1600
Soundcard: X-Fi USB HD
PSU: CM Silent Gold 1200
Default 03-10-2017, 21:25 | posts: 463

Quote:
Originally Posted by dudecat64 View Post
I know the feeling. Mine was tested bad. So know i have to wait 7-8 days for them to decide what they are sending me back. I was on the phone with them. Stupid powercolor just send me back a rx470 and i will be happy. Why wait another week for a answer lol.
Fortunately mine doesn't even POST, so testing is easy. They already shipped my replacement, tho I have no idea what it is.
   
Reply With Quote
Old
  (#28)
dudecat64
Ancient Guru
 
Videocard: POWERCOLOR PCS+ R9 380 4G
Processor: Intel Core i5 4460
Mainboard: GIGABYTE Z97X-GAMING 7
Memory: DDR3 4 x 4gigs
Soundcard: Onboard sound blaster
PSU: COOLER MASTER G750M
Default 03-10-2017, 21:38 | posts: 3,680 | Location: nystate

Yeah mine tested bad i talked to the who tested it. But he said that it would take that long to process. Ohwell my 5850 is working ok in windows 10 64bit. Drivers were tricky though.
   
Reply With Quote
Old
  (#29)
Chastity
Master Guru
 
Chastity's Avatar
 
Videocard: A dead Sapphire 390
Processor: Intel i7 950@4GHz
Mainboard: Rampage III Black X58
Memory: 6GB Dominators 1600
Soundcard: X-Fi USB HD
PSU: CM Silent Gold 1200
Default 03-13-2017, 16:49 | posts: 463

UPS reports it will be delivered today. Just in time to beat the nasty blizzard we are going to get tonight.
   
Reply With Quote
 
Old
  (#30)
Chastity
Master Guru
 
Chastity's Avatar
 
Videocard: A dead Sapphire 390
Processor: Intel i7 950@4GHz
Mainboard: Rampage III Black X58
Memory: 6GB Dominators 1600
Soundcard: X-Fi USB HD
PSU: CM Silent Gold 1200
Default 03-13-2017, 23:41 | posts: 463

Card finally arrived about 6:30 PM. I like the packaging it came in, better than my bubble wrap job.

DDU'd the NV crap, replaced, and installed 17.3.1. Remade my 75Hz display profiles. All is well thus far.

The card shipped is identical to the one I sent in, so no free upgrade for me. If 5xx comes out before March maybe I'll try again to get a 590.

Addendum: new card has Hynix memory vs Elpida memory

Last edited by Chastity; 03-14-2017 at 00:01.
   
Reply With Quote
Old
  (#31)
PrMinisterGR
Ancient Guru
 
PrMinisterGR's Avatar
 
Videocard: Sapphire 7970 Quadrobake
Processor: Core i7 2600k@4.5GHz
Mainboard: Sapphire Pure Black P67
Memory: Corsair Vengeance 16GB
Soundcard: ASUS Xonar D2X
PSU: EVGA SuperNova 750 G2
Default 03-14-2017, 02:06 | posts: 6,194

Hynix is for sure better.
   
Reply With Quote
Old
  (#32)
Chastity
Master Guru
 
Chastity's Avatar
 
Videocard: A dead Sapphire 390
Processor: Intel i7 950@4GHz
Mainboard: Rampage III Black X58
Memory: 6GB Dominators 1600
Soundcard: X-Fi USB HD
PSU: CM Silent Gold 1200
Default 03-14-2017, 13:40 | posts: 463

Quote:
Originally Posted by PrMinisterGR View Post
Hynix is for sure better.
My Elpida card could OC the memory to 1750 easily. I'll see how this one does later; I have to attend to the massive snowfest that Stella is dumping here.
   
Reply With Quote
Old
  (#33)
PrMinisterGR
Ancient Guru
 
PrMinisterGR's Avatar
 
Videocard: Sapphire 7970 Quadrobake
Processor: Core i7 2600k@4.5GHz
Mainboard: Sapphire Pure Black P67
Memory: Corsair Vengeance 16GB
Soundcard: ASUS Xonar D2X
PSU: EVGA SuperNova 750 G2
Default 03-14-2017, 15:16 | posts: 6,194

Quote:
Originally Posted by Chastity View Post
My Elpida card could OC the memory to 1750 easily. I'll see how this one does later; I have to attend to the massive snowfest that Stella is dumping here.
Regarding latencies and the 2D bug, it was Hynix memory all the way. That was on the 7970 days though.
   
Reply With Quote
Old
  (#34)
Chastity
Master Guru
 
Chastity's Avatar
 
Videocard: A dead Sapphire 390
Processor: Intel i7 950@4GHz
Mainboard: Rampage III Black X58
Memory: 6GB Dominators 1600
Soundcard: X-Fi USB HD
PSU: CM Silent Gold 1200
Default 03-17-2017, 21:11 | posts: 463

Card is not adequately cooling itself on Auto fan profile, AS IT SHOULD BE DOING, so I am going to request a 2nd replacement. Grrrr.

EDIT: Even with a more aggressive fan profile, she will still eventually pixellate. Probably something is not cooling properly, despite the temp readings. Probably memory related.

Last edited by Chastity; 03-17-2017 at 21:26.
   
Reply With Quote
Old
  (#35)
Chastity
Master Guru
 
Chastity's Avatar
 
Videocard: A dead Sapphire 390
Processor: Intel i7 950@4GHz
Mainboard: Rampage III Black X58
Memory: 6GB Dominators 1600
Soundcard: X-Fi USB HD
PSU: CM Silent Gold 1200
Default 03-21-2017, 01:25 | posts: 463

Finally dug up their phone number, and called their RMA dept, got transferred to a tech, who then agreed with my assessment, and had RMA Dept issue new RMA and supplied me with prepaid UPS shipping voucher.

RMA #2 begins...
   
Reply With Quote
Old
  (#36)
Only Intruder
Master Guru
 
Only Intruder's Avatar
 
Videocard: Sapphire R9 Fury Nitro
Processor: i5 4690K
Mainboard: Z97P-D3
Memory: 16GB HyperX Savage
Soundcard: Creative X-Fi FPS
PSU: EVGA 750 GQ
Default 03-21-2017, 12:43 | posts: 687 | Location: UK

Quote:
Originally Posted by Chastity View Post
Finally dug up their phone number, and called their RMA dept, got transferred to a tech, who then agreed with my assessment, and had RMA Dept issue new RMA and supplied me with prepaid UPS shipping voucher.

RMA #2 begins...
Reckon they''ll say "**** it" and give you a 480?
   
Reply With Quote
Old
  (#37)
MaNiAc4LIFE
Newbie
 
Videocard: R9 390 NITRO
Processor: i5-6600K @ 4.5GHz 1.2V
Mainboard: ASUS Z170-A
Memory: 32GB DDR4 @ 3300MHz
Soundcard: Logitech Z623
PSU: Corsair H1000i
Question 03-27-2017, 01:26 | posts: 2 | Location: FLORIDA

Quote:
Originally Posted by Chastity View Post
Finally dug up their phone number, and called their RMA dept, got transferred to a tech, who then agreed with my assessment, and had RMA Dept issue new RMA and supplied me with prepaid UPS shipping voucher.

RMA #2 begins...
I just sent my 390 that wouldnt post
any news on your second RMA yet?
   
Reply With Quote
Old
  (#38)
Chastity
Master Guru
 
Chastity's Avatar
 
Videocard: A dead Sapphire 390
Processor: Intel i7 950@4GHz
Mainboard: Rampage III Black X58
Memory: 6GB Dominators 1600
Soundcard: X-Fi USB HD
PSU: CM Silent Gold 1200
Default 03-27-2017, 16:45 | posts: 463

UPS Ground across the US is slow, package won't arrive until tomorrow. When I mailed it USPS Ground, it got there in 2 days. As far as what I'll be getting, I do not know. Depends how many refurbed 390's they have laying around.
   
Reply With Quote
Old
  (#39)
MaNiAc4LIFE
Newbie
 
Videocard: R9 390 NITRO
Processor: i5-6600K @ 4.5GHz 1.2V
Mainboard: ASUS Z170-A
Memory: 32GB DDR4 @ 3300MHz
Soundcard: Logitech Z623
PSU: Corsair H1000i
Default 03-27-2017, 22:42 | posts: 2 | Location: FLORIDA

IKR i wish my card waited just a few more months so that a VEGA replacement would be possible XD
   
Reply With Quote
Old
  (#40)
Chastity
Master Guru
 
Chastity's Avatar
 
Videocard: A dead Sapphire 390
Processor: Intel i7 950@4GHz
Mainboard: Rampage III Black X58
Memory: 6GB Dominators 1600
Soundcard: X-Fi USB HD
PSU: CM Silent Gold 1200
Default 03-28-2017, 16:35 | posts: 463

Quote:
Originally Posted by MaNiAc4LIFE View Post
IKR i wish my card waited just a few more months so that a VEGA replacement would be possible XD
My warranty is good until Mar 2018, so I may still have a chance at that.
   
Reply With Quote
Old
  (#41)
Chastity
Master Guru
 
Chastity's Avatar
 
Videocard: A dead Sapphire 390
Processor: Intel i7 950@4GHz
Mainboard: Rampage III Black X58
Memory: 6GB Dominators 1600
Soundcard: X-Fi USB HD
PSU: CM Silent Gold 1200
Default Yesterday, 01:30 | posts: 463

Delivered On:
Tuesday, 03/28/2017 at 11:55 A.M.

Left At:
Inside Delivery

Received By:
KEN VOONG
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.