Guru3D.com Forums

Go Back   Guru3D.com Forums > General Chat > Tablets and Smart Phones
Tablets and Smart Phones Got that new HTC or Samsung Galaxy ? Discuss mobile devices, pads and tabs here.



Reply
 
Thread Tools Display Modes
Xperia Z4 Tablet - CPU Issues
Old
  (#1)
dk_lightning
Maha Guru
 
dk_lightning's Avatar
 
Videocard: GTX 970 4GB
Processor: 3570K 4.5Ghz H100GTX
Mainboard: Asrock Z77 Extreme 4
Memory: 16GB DDR3 @ 1833Mhz
Soundcard:
PSU: Corsair CX750M
Default Xperia Z4 Tablet - CPU Issues - 05-08-2017, 20:45 | posts: 1,329 | Location: North Wales

Looking or some input on a odd issue I am having with my Z4. It is on contract with O2 UK and is well in warranty as I have only had it about 3 months.

Anyway. When I got it I ran the software update to get Android 7.0 installed.

When viewing system specs I noticed that CPUZ showed the Snapdragon 810 running at 1.56Ghz on both clusters and the last 4 cores showed as sleeping.

Benchmarks like geekbench confirmed that something was hinky. with those 4 cores. Sinlge threaded score matches the 810 scores I see online but the multicore score is taking a massive hit.

So, I decided to do a factory reset but this did not help. Next stop was to go back to an older version of Android so I went hunting for a firmware file that was Android 5 or 6. I found one and installed that and this time everything seemed as it should.

CPUZ was showing 4 cores at 1.5Ghz and another 4 at 2Ghz as it should and the last 4 cores where active. Geekbench confirmed all was fine with normal multicore scores.

So, Back to the latest Android 7.0 aaannnnd same issue as before. What on earth is going on here with 7.0? Something seems to be stopping 4 of the cores from working?

I would like to try and fix this my self if I can as it does seem to be a software issue vs hardware.

Its a pain having this problem as most things are a bit laggy and gaming is just not possible.
   
Reply With Quote
 
Old
  (#2)
Extraordinary
Ancient Guru
 
Extraordinary's Avatar
 
Videocard: GTX980 SLI
Processor: FX-8350 @ 4.8GHz / H100i
Mainboard: ASUS Crosshair V Formula
Memory: 12GB 2133 G.Skill
Soundcard: Creative SB1040 7.1
PSU: Corsair RM1000
Default 05-08-2017, 21:34 | posts: 17,732 | Location: 127.0.0.1

Check performance mode settings, pretty sure (Not 100% sure) this is Nougat 7.0 specific and not just Samsung, but there are different performance modes you can choose for power saving, maybe Nougat defaults to something that saves power by disabling cores?
   
Reply With Quote
Old
  (#3)
dk_lightning
Maha Guru
 
dk_lightning's Avatar
 
Videocard: GTX 970 4GB
Processor: 3570K 4.5Ghz H100GTX
Mainboard: Asrock Z77 Extreme 4
Memory: 16GB DDR3 @ 1833Mhz
Soundcard:
PSU: Corsair CX750M
Default 05-08-2017, 21:55 | posts: 1,329 | Location: North Wales

Only settings like that on Sony devices or at least mine is Stamina mode witch is off.

I did try turning it on to see what it do to cpu cores/speed and nothing.
   
Reply With Quote
Old
  (#4)
Extraordinary
Ancient Guru
 
Extraordinary's Avatar
 
Videocard: GTX980 SLI
Processor: FX-8350 @ 4.8GHz / H100i
Mainboard: ASUS Crosshair V Formula
Memory: 12GB 2133 G.Skill
Soundcard: Creative SB1040 7.1
PSU: Corsair RM1000
Default 05-08-2017, 22:27 | posts: 17,732 | Location: 127.0.0.1

Yea from further investigating it looks like Samsung only applied it to Nougat, I was under the impression it was a new Nougat power saving feature

Looks like quite a few people are having problems with Nougat on your device, might be a case of waiting for an update

https://forum.xda-developers.com/xpe...grade-t3572285
   
Reply With Quote
 
Old
  (#5)
dk_lightning
Maha Guru
 
dk_lightning's Avatar
 
Videocard: GTX 970 4GB
Processor: 3570K 4.5Ghz H100GTX
Mainboard: Asrock Z77 Extreme 4
Memory: 16GB DDR3 @ 1833Mhz
Soundcard:
PSU: Corsair CX750M
Default 05-08-2017, 23:40 | posts: 1,329 | Location: North Wales

Quote:
Originally Posted by Extraordinary View Post
Yea from further investigating it looks like Samsung only applied it to Nougat, I was under the impression it was a new Nougat power saving feature

Looks like quite a few people are having problems with Nougat on your device, might be a case of waiting for an update

https://forum.xda-developers.com/xpe...grade-t3572285
Thats for the Z4 phone but I am assuming they use the same firmware for all z4\810 devices just tweak some bits for tablet others for phone.

I hope there is a fix soon then!
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 2017, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.