Guru3D.com Forums

Go Back   Guru3D.com Forums > General Chat > Frontpage news
Frontpage news Perhaps you have some news to report or want to check out the latest Guru3D headlines and comment ? Check it in here.


Reply
 
Thread Tools Display Modes
Realtek High Definition Audio Driver R2.70
Old
  (#1)
DannyG
Member Guru
 
Videocard: SAPPHIRE HD6970
Processor: INTEL CORE i5 750
Mainboard: GIGABYTE GA-P55A-UD4
Memory: G.SKILL 4096MB DDR3 1600
Soundcard: Logitech Z-5500
PSU: SEASONIC S12EP 650W
Default Realtek High Definition Audio Driver R2.70 - 06-22-2012, 17:52 | posts: 55 | Location: IL

This download contains the latest audio drivers, software and utilities for the Realtek high definition audio controllers. It contains all driver files and the control center for Realtek HD-Audio devices for Windows 2000, XP, Vista and Windows 7. The downloads are fully compatible with 32 bit and 64 bit binaries.

http://www.realtek.com.tw/downloads/

Update: Gigabit/sec mirrors here ate Guru3D - download here
   
Reply With Quote
 
Old
  (#2)
thatguy91
Ancient Guru
 
Videocard: HIS R9-280x Iceq X2 Turbo
Processor: i5-3570K
Mainboard: Asrock Z77 Extreme6
Memory: DDR3-2400 2x8GB
Soundcard: ALC898 + Microlab FC-730
PSU: Enermax Platimax 750W
Default 06-22-2012, 18:27 | posts: 3,748 | Location: Australia

I've uploaded the new drivers here:
http://www.mediafire.com/?3g847ltnxyll2xc

This package included both the onboard (motherboard based) drivers, and the HDMI audio drivers for AMD cards (which is preferable to use over the one that is packaged with the Catalyst drivers).

Both of these are R2.70, and both x86 and x64 drivers are included. The size is only 39MB as it was compressed using high compression settings in 7zip, which is why its significantly smaller than downloading both of these directly from Realtek.
   
Reply With Quote
Old
  (#3)
The General
Ancient Guru
 
The General's Avatar
 
Videocard: PNYGTX 5501GB
Processor: Intel Q6600
Mainboard: HP Cheap
Memory: DDR2 4GB
Soundcard: Headphones
PSU: 550W
Default 06-22-2012, 18:34 | posts: 2,943 | Location: MD/CA

Thanks for the mediafire links. Realtek should be a shame to put links with that low speed.
   
Reply With Quote
Old
  (#4)
GPUCoder
Newbie
 
GPUCoder's Avatar
 
Videocard: ATI HD5870 CF @ 1GHz
Processor: Intel C2Q Q9450 @ 3.8GHz
Mainboard: DFI LanParty UT P45-T3RS
Memory: Corsair TW3X4G1333C9DHX
Soundcard: Realtek HD Audio
PSU: Chieftec CFT-750-14C
Default 06-23-2012, 17:12 | posts: 37 | Location: Greece

Thanks for the link thatguy91! Have you tested the drivers? I use right now 2.68 cause previews 2.69 ones had broken audio effects in my system. Can you check that for me? Thanks!
   
Reply With Quote
 
Old
  (#5)
Hilbert Hagedoorn
Don Vito Corleone
 
Hilbert Hagedoorn's Avatar
 
Videocard: AMD | NVIDIA
Processor: Core i7 4770K
Mainboard: Z77
Memory: 8GB
Soundcard: X-Fi - GigaWorks 7.1
PSU: 1200 Watt
Default 06-23-2012, 18:53 | posts: 20,517 | Location: Guru3D testlab

I've placed the Win XP AND Vista/7/8 binaried into one archive and 7zipped them. You can grab them at the Guru3D link in the 1st post.

Thanks OP for the notice


Follow Guru3D on twitter.
Follow Guru3D on facebook.
   
Reply With Quote
Old
  (#6)
ViperXtreme
Ancient Guru
 
ViperXtreme's Avatar
 
Videocard: Palit GTX 660 OC 2GB
Processor: Intel Core i5 3570K @4Ghz
Mainboard: ASRock Z68 Pro3-M
Memory: 8GB G.Skill RipJaws DDR3
Soundcard: Integrated Realtek 7.1 HD
PSU: OCZ StealthXStream 2 600W
Default 06-24-2012, 08:22 | posts: 2,919 | Location: Philippines

previous version broke the equalizer and effects as well, hope that this one does not
   
Reply With Quote
Old
  (#7)
GPUCoder
Newbie
 
GPUCoder's Avatar
 
Videocard: ATI HD5870 CF @ 1GHz
Processor: Intel C2Q Q9450 @ 3.8GHz
Mainboard: DFI LanParty UT P45-T3RS
Memory: Corsair TW3X4G1333C9DHX
Soundcard: Realtek HD Audio
PSU: Chieftec CFT-750-14C
Unhappy 06-24-2012, 17:16 | posts: 37 | Location: Greece

Quote:
Originally Posted by ViperXtreme View Post
previous version broke the equalizer and effects as well, hope that this one does not
Quote:
Originally Posted by GPUCoder View Post
Thanks for the link thatguy91! Have you tested the drivers? I use right now 2.68 cause previews 2.69 ones had broken audio effects in my system. Can you check that for me? Thanks!
Same here. Can anyone of the guru3d that uses these drivers tell us if this problem is there in these? If I got no answer I gonna check them myself sadly and update you dude. That community's members are not so usefull and informative to me and others like in the past...
   
Reply With Quote
Old
  (#8)
IcE
Ancient Guru
 
IcE's Avatar
 
Videocard: Zotac GTX 780
Processor: i5 3570K @4.2 GHz
Mainboard: Asus P8Z77-V LK
Memory: 8GB G.Skill Sniper 1866
Soundcard: Soundblaster Z + CAL
PSU: Enermax NAXN 82+ 750W
Default 06-24-2012, 22:29 | posts: 8,901 | Location: The Zone

Quote:
Originally Posted by GPUCoder View Post
Same here. Can anyone of the guru3d that uses these drivers tell us if this problem is there in these? If I got no answer I gonna check them myself sadly and update you dude. That community's members are not so usefull and informative to me and others like in the past...
So the community is not helpful simply because you're lazy and don't want to test them yourself? It's not like it even takes that long.

But yes, the broken audio effects are fixed.
   
Reply With Quote
Old
  (#9)
GPUCoder
Newbie
 
GPUCoder's Avatar
 
Videocard: ATI HD5870 CF @ 1GHz
Processor: Intel C2Q Q9450 @ 3.8GHz
Mainboard: DFI LanParty UT P45-T3RS
Memory: Corsair TW3X4G1333C9DHX
Soundcard: Realtek HD Audio
PSU: Chieftec CFT-750-14C
Wink 06-25-2012, 00:50 | posts: 37 | Location: Greece

Thanks for the info, gonna install then.

Nope, it's not about laziness. it's about the frustration and waste of time me and everyone's got when we try in a month interval several drivers from AMD plus Realtek just to realize that they're bugged and have to revert back. Realtek driver installation asks for 2 reboots as far as I know so I prefered to ask than sorry.

And yeap, when a group of people and not just one person like me ask same thing in a forum and noone cares to asnwer even a simple yes or no that takes a couple of seconds there is a big problem in that community. I think forums like this exist for people to share ideas AND help each other.


Last edited by GPUCoder; 06-25-2012 at 01:02.
   
Reply With Quote
Old
  (#10)
ViperXtreme
Ancient Guru
 
ViperXtreme's Avatar
 
Videocard: Palit GTX 660 OC 2GB
Processor: Intel Core i5 3570K @4Ghz
Mainboard: ASRock Z68 Pro3-M
Memory: 8GB G.Skill RipJaws DDR3
Soundcard: Integrated Realtek 7.1 HD
PSU: OCZ StealthXStream 2 600W
Default 06-25-2012, 00:56 | posts: 2,919 | Location: Philippines

lol should have posted yesterday, and yeah mixer works fine again.
   
Reply With Quote
 
Old
  (#11)
GPUCoder
Newbie
 
GPUCoder's Avatar
 
Videocard: ATI HD5870 CF @ 1GHz
Processor: Intel C2Q Q9450 @ 3.8GHz
Mainboard: DFI LanParty UT P45-T3RS
Memory: Corsair TW3X4G1333C9DHX
Soundcard: Realtek HD Audio
PSU: Chieftec CFT-750-14C
Default 06-25-2012, 01:01 | posts: 37 | Location: Greece

Quote:
Originally Posted by ViperXtreme View Post
lol should have posted yesterday, and yeah mixer works fine again.
Thanks, too Viper. Confirmed, gonna install for sure. That info will help others too
   
Reply With Quote
Old
  (#12)
sykozis
Ancient Guru
 
sykozis's Avatar
 
Videocard: Radeon R7 240
Processor: AMD Athlon 5350
Mainboard: Asus AM1M-A
Memory: 8gb G.Skill DDR3-1866
Soundcard: Realtek® ALC887-VD
PSU: Unk 300watt
Default 06-25-2012, 01:05 | posts: 16,132 | Location: US East Coast

Quote:
Originally Posted by GPUCoder View Post
Thanks for the info, gonna install then.

Nope, it's not about laziness. it's about the frustration and waste of time me and everyone's got when we try in a month interval several drivers from AMD plus Realtek just to realize that they're bugged and have to revert back. Realtek driver installation asks for 2 reboots as far as I know so I prefered to ask than sorry.

And yeap, when a group of people and not just one person like me ask same thing in a forum and noone cares to asnwer even a simple yes or no that takes a couple of seconds there is a big problem in that community. I think forums like this exist for people to share ideas AND help each other.

Others "testing" drivers doesn't necessarily give an indication as to how the drivers will work on your system....


   
Reply With Quote
Old
  (#13)
tsunami231
Ancient Guru
 
tsunami231's Avatar
 
Videocard: EVGA 660gtx sig2
Processor: i7 920 CNPS10X Quiet
Mainboard: Evga x58 SLI LE
Memory: 3x2gb Dominator@1600 6Gb
Soundcard: Realtek HD Audio
PSU: Antec Truepower 750
Default 06-25-2012, 03:31 | posts: 3,208 | Location: USA

Quote:
Originally Posted by IcE View Post
So the community is not helpful simply because you're lazy and don't want to test them yourself? It's not like it even takes that long.

But yes, the broken audio effects are fixed.
would be easier if realtek just told use what was fixed or changed etc. its why i still use the original drivers my mobo came with. if it anit broke dont mess with
   
Reply With Quote
Old
  (#14)
Titan29
Master Guru
 
Titan29's Avatar
 
Videocard: 2x 7950 @880/1250
Processor: i7-3930K C1 @3.2|NH-D14
Mainboard: Asus P9X79 Pro 4608
Memory: Ripjaws X 32GB 1600MHz
Soundcard: Realtek | Z-5500
PSU: Corsair HX850
Default 06-25-2012, 04:07 | posts: 208 | Location: Canada

Is there any list of which chips are supported?

I am not sure but ASUS website lists the Realtek audio driver version for my motherboard (P9X79 Pro) as 5.10.0.6499&6.0.1.64.

Would I be able to install these drivers?
Why is realtek version number (R2.70) different from the one on the ASUS website?
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.