Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - AMD - ATI Drivers Section
Videocards - AMD - ATI Drivers Section In this section you can discuss everything Catalyst related. AMD Catalyst drivers are for all AMD ATI based graphics cards. This is also the place to discuss modified Catalyst drivers.


Reply
 
Thread Tools Display Modes
AMD Catalyst 13.3 BETA 2 (12.100.17.0 March 14)
Old
  (#1)
asder00
Don Di Driver
 
asder00's Avatar
 
Videocard: R9 290 4GB @ 1100/1400
Processor: i7 3770k @ 4.7GHz
Mainboard: ASUS P8Z77-V PRO
Memory: 8GB G.Skill @ 2133Mhz CL9
Soundcard: X-FI Xtreme Music
PSU: CoolerMaster 850W
Talking AMD Catalyst 13.3 BETA 2 (12.100.17.0 March 14) - 03-15-2013, 20:20 | posts: 1,031 | Location: iTALY

Enjoy!
Follow me on Twitter! @asder00

> Download < (Win Vista/7/8 x86/x64)

FEATURE HIGHLIGHTS OF CATALYST 13.3 BETA:
  • Improves performance in Far Cry 3 up to 5 percent
  • Improve performance in Sim City 5 up to 16 percent
  • Improves latency performance issues seen in Tomb Raider and Hitman Absolution
  • Resolves slight corruption seen in Tomb Raider with TressFX enabled for CrossFire and single GPU configurations
Build Info:
12.10.17-130314a-154593E-ATI
DriverVer=03/14/2013, 12.100.17.0000
Catalyst: 13.3
CCC: 2013.0314.1701.28699
D3D: 9.14.10.0968
OGL: 6.14.10.12172
OCL: 10.0.1124.2

Supported Cards:
 Click to show spoiler


Last edited by asder00; 03-19-2013 at 21:21.
   
Reply With Quote
 
Old
  (#2)
Leon_Bassel
Member Guru
 
Leon_Bassel's Avatar
 
Videocard: AMD 5650/6500 M
Processor: Intel Core i5 480 M
Mainboard: Ibex Peak-M HM57
Memory: 4GB DDRIII
Soundcard: SRS Premium Sound™
PSU: DELL / 6 Cell Lithium-Ion
Default 03-15-2013, 20:28 | posts: 50 | Location: SYRIA

thx asder00

downloading it now
   
Reply With Quote
Old
  (#3)
stigbeater
Member Guru
 
stigbeater's Avatar
 
Videocard: GTX 980
Processor: FX 8350 oc'd 4.7Ghz
Mainboard: ASUS sabertooth 990fx
Memory: ddr3 16gb
Soundcard:
PSU: thermaltake 775w
Default 03-15-2013, 20:31 | posts: 45

thank asder
   
Reply With Quote
Old
  (#4)
Extraordinary
Ancient Guru
 
Extraordinary's Avatar
 
Videocard: EVGA GTX980 SC ACX2.0 4GB
Processor: FX-8350 @ 4.8GHz / H100i
Mainboard: ASUS Crosshair V Formula
Memory: 12GB 2133 G.Skill
Soundcard: 5.1 Surround
PSU: Corsair TX950
Default 03-15-2013, 20:41 | posts: 7,929 | Location: 127.0.0.1

Nice one, thanks asder00
   
Reply With Quote
 
Old
  (#5)
NvidiaFreak
Ancient Guru
 
NvidiaFreak's Avatar
 
Videocard: ATI Radeon HD 7660D
Processor: A10-5800K 4.2ghz Turbo
Mainboard: MSI FM2-A75MA-E35
Memory: 8GB DDR3 1600Mhz XMP
Soundcard: Z-5500 5.1
PSU: 380W
Default 03-15-2013, 20:44 | posts: 4,777 | Location: 〓ω〓

This is unacceptable, Ati should be a shame of there self. 13.3 driver better be worth it or else a ton of people are going to be very piss. i just don't get it, the best driver to date was 12.11 & ever since then a ton of people are having issue in games in the lastest build of Ati drivers. also why the beta is not in the http://sites.amd.com/us/game/downloa...n_win8-64.aspx page?
   
Reply With Quote
Old
  (#6)
Krteq
Member Guru
 
Videocard: R9 290 Tri-X OC
Processor: Core i5 2500K @4,8 GHz WC
Mainboard: MSI P67A-GD65 (B3)
Memory: 2x8GB DDR3 1600MHz
Soundcard: Prodigy 7.1 HiFi + HD515
PSU: Seasonic 620W
Default 03-15-2013, 20:48 | posts: 138 | Location: Czech Republic

What kind of problems do you talking about?

Drivers isn't there yet because asder has a "preliminary access" to those packages

//EDIT: BTW THX Asder
   
Reply With Quote
Old
  (#7)
Leito360
Newbie
 
Videocard: ASUS R9280X DirectCU II
Processor: AMD Phenom II 965 B.E. C3
Mainboard: ASUS CrosshairIII Formula
Memory: Ripjaws Z 4x4 @ 1600
Soundcard:
PSU: XFX B.E. 850W
Default 03-15-2013, 20:53 | posts: 39 | Location: Buenos Aires, Argentina

The nVidia dude is right... the last good drivers were 12.11 Beta 11, and, by definition, 13.1WHQL, AKA, 12.11 WHQL... anyway... I was having issues with the TR, let's see if this driver delivers.

THANKS ASDER!!!!!
   
Reply With Quote
Old
  (#8)
PrEzi
Member Guru
 
PrEzi's Avatar
 
Videocard: GB HD7950 WF3 @1100
Processor: AMD PII 955 @ 3.8GHz
Mainboard: GB MA790FXT-UD5P
Memory: 12 GB DDR1600
Soundcard: Logitech Z-5500, SB2
PSU: Chieftec 750W
Default 03-15-2013, 20:53 | posts: 78 | Location: Poland

Thx asder00 DL now.
   
Reply With Quote
Old
  (#9)
warlord
Master Guru
 
warlord's Avatar
 
Videocard: amd 7850 cf
Processor: i7 3770k @4.8 HT
Mainboard: Msi Mpower Z77
Memory: 32gb ddr3 geil evo
Soundcard: creative
PSU: ax1200i corsair
Default 03-15-2013, 20:54 | posts: 497

Quote:
Originally Posted by NvidiaFreak View Post
This is unacceptable, Ati should be a shame of there self. 13.3 driver better be worth it or else a ton of people are going to be very piss. i just don't get it, the best driver to date was 12.11 & ever since then a ton of people are having issue in games in the lastest build of Ati drivers. also why the beta is not in the http://sites.amd.com/us/game/downloa...n_win8-64.aspx page?
O.o wow 13.2 beta was the best to date and it used by tons of people 12.11 maybe used from 20-25 people mostly...lol!!! Keep clean the thread without this crying out loud shame on them, unacceptable etc...AMD goes the right road!!!

EDIT: thnx asder00 for the driver finding speed, it's even faster than lightning
   
Reply With Quote
Old
  (#10)
Ghosty
Ancient Guru
 
Ghosty's Avatar
 
Videocard: -
Processor: -
Mainboard: -
Memory: -
Soundcard: -
PSU: -
Default 03-15-2013, 21:06 | posts: 3,479 | Location: UK

Thanks.
   
Reply With Quote
 
Old
  (#11)
NvidiaFreak
Ancient Guru
 
NvidiaFreak's Avatar
 
Videocard: ATI Radeon HD 7660D
Processor: A10-5800K 4.2ghz Turbo
Mainboard: MSI FM2-A75MA-E35
Memory: 8GB DDR3 1600Mhz XMP
Soundcard: Z-5500 5.1
PSU: 380W
Default 03-15-2013, 21:10 | posts: 4,777 | Location: 〓ω〓

Quote:
Originally Posted by Krteq View Post
What kind of problems do you talking about?
Look at the post in the Ati driver forum, most of them are about the crashing in games, BSOD, driver stop working when using the internet browser like Firefox or Chrome, IE10 etc... let hope this driver is really a beta & not alpha build because 12.11 was very stable.

Quote:
Originally Posted by warlord View Post
Keep clean the thread without this crying out loud shame on them, unacceptable etc...AMD goes the right road!!!
Crying, what crying i'm saying like it is & you know it that i'm right. if there any issue people need to report it here because no one like a buggy driver that do more harm then good.

Last edited by NvidiaFreak; 03-15-2013 at 21:12.
   
Reply With Quote
Old
  (#12)
eclap
Ancient Guru
 
eclap's Avatar
 
Videocard: MSI Gaming 970 1450/7800
Processor: i5 2500k @4.5 1.2v
Mainboard: Asus P8Z77-V Pro
Memory: 8GB G-Skill RipjawsX 1600
Soundcard: Aune T1. AD700. DT880
PSU: XFX Black 750W 80+ Gold
Default 03-15-2013, 21:13 | posts: 26,885 | Location: Hampshire, UK

yess!!! more fps in SimCity!
   
Reply With Quote
Old
  (#13)
hulawafu77
Master Guru
 
Videocard: 7970M
Processor: 3610QM
Mainboard:
Memory:
Soundcard:
PSU: Clevo
Default 03-15-2013, 21:15 | posts: 191

Yay, still not what we've been waiting for 2 months now.
   
Reply With Quote
Old
  (#14)
NvidiaFreak
Ancient Guru
 
NvidiaFreak's Avatar
 
Videocard: ATI Radeon HD 7660D
Processor: A10-5800K 4.2ghz Turbo
Mainboard: MSI FM2-A75MA-E35
Memory: 8GB DDR3 1600Mhz XMP
Soundcard: Z-5500 5.1
PSU: 380W
Default 03-15-2013, 21:22 | posts: 4,777 | Location: 〓ω〓

Quote:
Originally Posted by eclap View Post
yess!!! more fps in SimCity!
LOL someone is happy he can play the game smooth now.
   
Reply With Quote
Old
  (#15)
redrumy3
Master Guru
 
redrumy3's Avatar
 
Videocard: Evga GTX 770 4GB
Processor: i5 4670K 4.5Ghz 1.26V
Mainboard: GIGABYTE GA-Z87X-UD4H
Memory: 8GB Vengeance Pro - 1600
Soundcard: Asus Xonar Essence STX
PSU: Evga 850w G2
Default 03-15-2013, 21:30 | posts: 391 | Location: New York

Awesome. Tomb Raider bug was annoying.
   
Reply With Quote
Old
  (#16)
TheOriginalTO
Master Guru
 
Videocard: ATI 5870m
Processor: Intel Core i7 Q720
Mainboard: ASUS G73JH
Memory: 6.00
Soundcard:
PSU: Rbbx05
Default 03-15-2013, 21:39 | posts: 284

Downloading now, will get back to you about any problems.
   
Reply With Quote
Old
  (#17)
Fox2232
Maha Guru
 
Videocard: Acc7970 XL2420T @120Hz
Processor: i5-2500k@4.5GHz NH-D14
Mainboard: MSI Z68A-GD80[g3]
Memory: 4x4GB 1600MHz 9,9,9,24
Soundcard: Essence ST / AKG K-701
PSU: FSP Gold series 750W
Default 03-15-2013, 21:43 | posts: 1,674 | Location: EU, CZ, Brno

Quote:
Originally Posted by Leito360 View Post
The nVidia dude is right... the last good drivers were 12.11 Beta 11, and, by definition, 13.1WHQL, AKA, 12.11 WHQL... anyway... I was having issues with the TR, let's see if this driver delivers.

THANKS ASDER!!!!!
Not rly, most people who had problems had problems with artifacting, because card got higher utilization with newer drivers (and proportionally higher fps).
So normal users got fps bump, while unreasonable OCers had to be lower clocks which is for some people's mentality unacceptable.

OpenCL performance is same as 12.11b4 which are best for OpenCL if I count performance/utilization ratio.
With 13.3b2 OpenCL utilization is few percent lower, therefore are scores, temperatures, power draw.

From Direct3D PoV I am pleased @120Hz as for now have not noticed any new broken features.

Last edited by Fox2232; 03-16-2013 at 07:10.
   
Reply With Quote
Old
  (#18)
Jobe
Newbie
 
Videocard: ATI HD7970m 2GB
Processor: Intel i7-3610QM
Mainboard: Alienware M17x-R4
Memory: 6.00 GB DDR3 (1600Mhz)
Soundcard: Sound Blaster Recon3DI
PSU: Alienware M17x-R4
Default 03-15-2013, 21:46 | posts: 11

Any Arma 3 Improvements ?
   
Reply With Quote
Old
  (#19)
Rich_Guy
Ancient Guru
 
Rich_Guy's Avatar
 
Videocard: MSi Gaming 290X 1080/1250
Processor: i7 5930K
Mainboard: ASUS X99-A
Memory: 16GB Corsair DDR4 2666MHz
Soundcard: ASUS Xonar DX
PSU: Corsair AX860w
Default 03-15-2013, 21:49 | posts: 9,612 | Location: UK

Oooh new drivers, cheers asder!

Quote:
Originally Posted by NvidiaFreak View Post
also why the beta is not in the http://sites.amd.com/us/game/downloa...n_win8-64.aspx page?
It is there

Last edited by Rich_Guy; 03-15-2013 at 21:53.
   
Reply With Quote
Old
  (#20)
Valagard
Maha Guru
 
Videocard: MSI GTX 980
Processor: i7 4770K 4.3Ghz
Mainboard: ASUS Z87-Pro
Memory: 16Gig Corsair Vengeance
Soundcard: Sound Blaster Z
PSU: Corsair TX750
Default 03-15-2013, 22:03 | posts: 1,104

Quote:
Originally Posted by NvidiaFreak View Post
Look at the post in the Ati driver forum, most of them are about the crashing in games, BSOD, driver stop working when using the internet browser like Firefox or Chrome, IE10 etc... let hope this driver is really a beta & not alpha build because 12.11 was very stable.



Crying, what crying i'm saying like it is & you know it that i'm right. if there any issue people need to report it here because no one like a buggy driver that do more harm then good.
I've used every 13.1 driver, and every 13.2 beta

I've had ONE issue, Planetside 2 sometimes has black squares.

That's it, all my other games run perfectly fine.

No crashes.

No lock ups.

No mega corruption.

No "Framerate hiccups" etc
   
Reply With Quote
Old
  (#21)
Ghosty
Ancient Guru
 
Ghosty's Avatar
 
Videocard: -
Processor: -
Mainboard: -
Memory: -
Soundcard: -
PSU: -
Default 03-15-2013, 22:07 | posts: 3,479 | Location: UK

Quote:
Originally Posted by Jobe View Post
Any Arma 3 Improvements ?
Considering Arma 3 is in Alpha state, you won't be getting drivers with optimizations for it anytime soon.

Last edited by Ghosty; 03-15-2013 at 22:10.
   
Reply With Quote
Old
  (#22)
PrEzi
Member Guru
 
PrEzi's Avatar
 
Videocard: GB HD7950 WF3 @1100
Processor: AMD PII 955 @ 3.8GHz
Mainboard: GB MA790FXT-UD5P
Memory: 12 GB DDR1600
Soundcard: Logitech Z-5500, SB2
PSU: Chieftec 750W
Default 03-15-2013, 22:18 | posts: 78 | Location: Poland

My initial benchmark results :
Config - as in my profile.

Cat 13.2 B7 :
Unigine Valley
Preset : Extreme HD
1693


Unigine Heaven
Preset : Extreme
1093

3Dmark 2013,
Fire Strike (non-extreme)
6286
Gpu : 7578
Phys : 5523

Tomb Raider, vsync off, Fscreen exclusive,
Quality : Ultimate
min 40,8
max 64,2
Avg 51,4

Cat 13.3 B2 :

Valley :
1701

Heaven :
1097

Fire Strike :
6300
GPU : 7589
Phys : 5571

Tomb Raider :
min 40,8
max 58,4
avg 49,9

One thing I've noticed -
actually now in TR benchmark I DO see corruption of hair (it does now occlude with the model of Lara, on earlier drivers the hair has flown 'around' the model, now sometimes it flows just 'through' the back of Lara's model).

But anyway - since I've not found any other issues - for me, for now - it's a keeper
   
Reply With Quote
Old
  (#23)
wazups2x
Member Guru
 
wazups2x's Avatar
 
Videocard: 7950w/boost 3GB
Processor: Intel i5 3570k
Mainboard:
Memory: 8G
Soundcard: On-board
PSU: Antec 750w
Default 03-15-2013, 22:21 | posts: 69 | Location: Utah

Quote:
Originally Posted by PrEzi View Post
One thing I've noticed -
actually now in TR benchmark I DO see corruption of hair (it does now occlude with the model of Lara, on earlier drivers the hair has flown 'around' the model, now sometimes it flows just 'through' the back of Lara's model).
Nothing to do with this driver. A patch was released for Tomb Raider that removed the invisible barrier that caused the hair to float in the air.

Patch notes: http://forums.eidosgames.com/showthread.php?t=134690

Edit: A new patch was just released for Tomb Raider. So if you were curious here's the second patch notes: http://forums.eidosgames.com/showthread.php?t=135416
   
Reply With Quote
Old
  (#24)
streakpt
Master Guru
 
Videocard: HIS 7970 3GB Xfire
Processor: Intel i7 920 @ 4.2Ghz
Mainboard: Foxconn Bloodrage GTI
Memory: 6GB Crucial Ballistix T.
Soundcard: X-Fi Titanium HD/SS5hV2
PSU: Corsair HX Modular 1000w
Default 03-15-2013, 22:25 | posts: 262 | Location: Portugal

Useless driver... at least for me... but its good that AMD keeps improving games performance.
   
Reply With Quote
Old
  (#25)
PrEzi
Member Guru
 
PrEzi's Avatar
 
Videocard: GB HD7950 WF3 @1100
Processor: AMD PII 955 @ 3.8GHz
Mainboard: GB MA790FXT-UD5P
Memory: 12 GB DDR1600
Soundcard: Logitech Z-5500, SB2
PSU: Chieftec 750W
Default 03-15-2013, 22:35 | posts: 78 | Location: Poland

Quote:
Originally Posted by wazups2x View Post
Nothing to do with this driver. A patch was released for Tomb Raider that removed the invisible barrier that caused the hair to float in the air.

Patch notes: http://forums.eidosgames.com/showthread.php?t=134690

Edit: A new patch was just released for Tomb Raider. So if you were curious here's the second patch notes: http://forums.eidosgames.com/showthread.php?t=135416
Hmm... interesting... I do have 718.4 but will now update to latest to see if it was fixed...
But on a sidenote - I've run on the exact same build just different Cat's and on earlier I haven't noticed the issue with hair, on newest - I did...
Something's fishy
   
Reply With Quote
Reply

Tags
@asder00

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.