Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - AMD - ATI Drivers Section
Videocards - AMD - ATI Drivers Section In this section you can discuss everything Catalyst related. AMD Catalyst drivers are for all AMD ATI based graphics cards. This is also the place to discuss modified Catalyst drivers.


Reply
 
Thread Tools Display Modes
Old
  (#776)
faptastic
Newbie
 
Videocard: PCS+ 7870 Myst@1235/6400
Processor: i5 760@4GHz
Mainboard: GA-P55A-UD3
Memory: 2 x 4GB XMS3 PC3-12800C9
Soundcard: SB Audigy SE
PSU: XFX 750 Pro Core Edition
Default 01-09-2013, 13:22 | posts: 10

F1 2010 when clicking on your agent to look at the contract menu the circle indicator flickers.
   
Reply With Quote
 
Old
  (#777)
IRQ Conflict
Newbie
 
Videocard: 2 Sapphire X1950 Pro's in CF
Processor: Core 2 Duo E6300@2.8Ghz
Mainboard: BadAxe 2
Memory: OCZ Gold XTC 3GB's PC2-6400
Soundcard: SB Audigy MP3+/Inspire 5.1
PSU: PC P&C Silencer 750 Quad
Default 01-14-2013, 11:29 | posts: 6 | Location: Canucksville

12.10's without CAP installed helped reduce this issue for me. Still there but not as much as it was with 12.11beta with CAP installed. Supreme Commander shows no signs of corruption for me.

If I had to guess, it is performance tweaks that are causing the issue.

Asus Matrix Platinum 7970. Stock clocks. 1100/1650

Edit: I guess I better update my specs lol. Been awhile.

Last edited by IRQ Conflict; 01-14-2013 at 11:32.
   
Reply With Quote
Old
  (#778)
Epic0098
Newbie
 
Videocard: MSI 7950 Twin Frozr III
Processor: Intel i5 2500k 4.5Ghz
Mainboard: Asus P8P67LE
Memory: DDR3 1600Mhz 8GB
Soundcard: HT Omega Striker 7.1
PSU: Corsair TX750 V2
Default 01-15-2013, 02:00 | posts: 9 | Location: Ontario, Canada

So last time I mentioned that the flickering had stopped for me in Skyrim. Well I was wrong. It's sort of less than before, but it's still there. When using mods like ENB, it's worse. This is really getting on my nerves now, as soon as I see a slight flicker I just turn off the game. Seems like I'll have to revert back to my 6950 to play Skyrim if the new drivers don't fix this issue.
   
Reply With Quote
Old
  (#779)
vejn
Master Guru
 
vejn's Avatar
 
Videocard: MSI 7870 TF3
Processor: Core i5 3350P
Mainboard: MSI B75 G41
Memory: 4 Gb DDR
Soundcard:
PSU: 500W
Default 01-15-2013, 08:18 | posts: 661

For me with new 7870 bsod and flicker is fixed.
I only have problem with Splinter cell conviction.
It won't start. Even doesn't go to Main menu.
   
Reply With Quote
 
Old
  (#780)
ToBbErT
Member Guru
 
Videocard: 2x sapphire 7870
Processor: i5 3570k
Mainboard: p8z77-v le plus
Memory: 16gb 2400mhz Kingston
Soundcard: integrated
PSU: xfx 850w be silver
Default 01-15-2013, 09:05 | posts: 146

The problem isnt fixed you just got lucky. The first months when i got the card it crashed alot. Then i didnt have a crash in like 2-3 months and this week i got a crash again. It happens so randomly.
   
Reply With Quote
Old
  (#781)
ClockClocker
Master Guru
 
Videocard: HD 7950 Powercolor
Processor: Core i5 2500k
Mainboard: Asrock z68 Pro3
Memory: 8GB DDR 1333 Kingston
Soundcard:
PSU: Straight Power E9 580W
Default 01-15-2013, 09:34 | posts: 312

Quote:
Originally Posted by vejn View Post
For me with new 7870 bsod and flicker is fixed.
I only have problem with Splinter cell conviction.
It won't start. Even doesn't go to Main menu.
well it still depends which games you'Re playing. Some are fixed some still flicker.
   
Reply With Quote
Old
  (#782)
Offler2
Master Guru
 
Videocard: Gigabyte HD 7970OC, 3gb
Processor: Intel xeon X3360
Mainboard: Asus Rampage Extreme 1
Memory: Adata XPG2 4x2gb
Soundcard: Creative Xfi
PSU: Corsair HX-650w
Default 01-15-2013, 11:02 | posts: 185

Cat 13.1 rumored to be released this Wednesday...
   
Reply With Quote
Old
  (#783)
Espionage724
Maha Guru
 
Espionage724's Avatar
 
Videocard: MSI R7850 PE 2GD5/OC
Processor: AMD Phenom II X4 @ 3.4GHz
Mainboard: ASRock 970 Extreme3
Memory: DDR3 1333 (PC3 10666) 8GB
Soundcard: ASUS Xonar DG
PSU: hec HP585D 585W ATX12V
Default 01-15-2013, 11:45 | posts: 1,139 | Location: Charleroi, PA

Quote:
Originally Posted by Offler2 View Post
Cat 13.1 rumored to be released this Wednesday...
Source?
   
Reply With Quote
Old
  (#784)
ClockClocker
Master Guru
 
Videocard: HD 7950 Powercolor
Processor: Core i5 2500k
Mainboard: Asrock z68 Pro3
Memory: 8GB DDR 1333 Kingston
Soundcard:
PSU: Straight Power E9 580W
Default 01-15-2013, 12:01 | posts: 312

Quote:
Originally Posted by Espionage724 View Post
Source?
Some twitter of a AMD-Dev here https://twitter.com/CatalystCreator
   
Reply With Quote
Old
  (#785)
GREGIX
Master Guru
 
GREGIX's Avatar
 
Videocard: C3D 7870 Tahiti LE
Processor: i2500k@4.5/4.2
Mainboard: asrock p67 pro3
Memory: 2x4gb kingston 1333 cl9
Soundcard: AsusDX+ML SOLO 7C
PSU: 550 ocz in Aerocool 3T
Default 01-15-2013, 12:15 | posts: 240 | Location: Poland

Good that new drivers coming out.
BTW I just bought 7870 club3d jockercard(tahiti based) and must say, can't c any flickers as shown on urs videos. So maybe im lucky.
Using latest betas (b4 i had 6850 MSI).
All I can see, that is shadows(but only) shadows small flickering in certain games, like WoT. Or on car in Farcry 3.
But no huge artifacting or flicker on half screen.

BTW doesn't this flickering with big black blocks on screen shows that cooling system is inefficient? That cards are overheated?
   
Reply With Quote
 
Old
  (#786)
Gaizokubanou
Maha Guru
 
Gaizokubanou's Avatar
 
Videocard: Sapphire HD 7970
Processor: i7 930 @ 3.8ghz 1.25v
Mainboard: Asus P6X56D-E
Memory: DDR3 6GB
Soundcard: ASUS Xonar DX
PSU: Corsair HX750W
Default 01-15-2013, 12:17 | posts: 1,207

Is the new driver going to be 12.11 beta dressed up with WHQL or is it actually going to be new?
   
Reply With Quote
Old
  (#787)
3dPlayer
Banned
 
Videocard: Have
Processor: a
Mainboard: good
Memory: day
Soundcard: or
PSU: not
Default 01-15-2013, 12:31 | posts: 1,824

With 12.11 i notice flickering on Dishonored and Chivalry, but i only have seen that very rarely when i stoped the movement.
   
Reply With Quote
Old
  (#788)
GREGIX
Master Guru
 
GREGIX's Avatar
 
Videocard: C3D 7870 Tahiti LE
Processor: i2500k@4.5/4.2
Mainboard: asrock p67 pro3
Memory: 2x4gb kingston 1333 cl9
Soundcard: AsusDX+ML SOLO 7C
PSU: 550 ocz in Aerocool 3T
Default 01-15-2013, 19:35 | posts: 240 | Location: Poland

Ok i just turned on Skyrim 4 a test and have some flicker, open grounds only, near rivers or so...bad...
   
Reply With Quote
Old
  (#789)
WiFry
Member Guru
 
WiFry's Avatar
 
Videocard: ASUS HD7870 Directcu II
Processor: Intel i5 2500K
Mainboard: ASUS P8Z68-V/GEN3
Memory: Corsair Vengeance DDR3
Soundcard: Infrasonic Quartet
PSU: Corsair HX650W
Default 01-16-2013, 01:19 | posts: 103 | Location: New Zealand

Quote:
Originally Posted by Offler2 View Post
Cat 13.1 rumored to be released this Wednesday...
Cataylst Creator says an Official WHQL will be released then but then says another BETA will be released a few weeks after.

I translate this as, the WHQL is going to have image corruption in certain games as well.
Since it takes time for drivers to get certified I'd say during that time AMD have made more progress with GCN architecture.
   
Reply With Quote
Old
  (#790)
Offler2
Master Guru
 
Videocard: Gigabyte HD 7970OC, 3gb
Processor: Intel xeon X3360
Mainboard: Asus Rampage Extreme 1
Memory: Adata XPG2 4x2gb
Soundcard: Creative Xfi
PSU: Corsair HX-650w
Default 01-16-2013, 16:08 | posts: 185

Each HD 7000 driver i tested had flickering issues of some sort, since windows 8 the official drivers were getting worse and worse. Beta 11 Fixed 50 percent of flickering. In some games completely, in some partially. The truth is that its present only in DX9 games (at least for me)...

The best driver I have tested from this point of view was 12.2 or 12.3 which almost did not contain issue - with exception of the most persistent flickers...

So I believe they can figure out whats causing it. At least they were successful in removing the issue in some certain games.

Edit:
Also one quite important thing for AMD driver to be released today. MS released its monthly patches yesterday... Quite a lot of patches for .net...

Last edited by Offler2; 01-16-2013 at 16:26.
   
Reply With Quote
Old
  (#791)
Morgemil
Member Guru
 
Videocard: ati 5770 Vapor x
Processor: athlon II x3 435
Mainboard: Biostar TA790gx A3+
Memory: 2x2 1333 Gskill ripjaws
Soundcard:
PSU: OCZ Stealthxstream 600 w
Default 01-17-2013, 00:28 | posts: 54 | Location: Argentina

Hi, I own a sapphire 7950 vapor x and Im getting this random flickering on windows desktop. Its a driver issue o should I ask for a replacement? Thanks.
   
Reply With Quote
Old
  (#792)
NiColaoS
Master Guru
 
NiColaoS's Avatar
 
Videocard: 7950 WindForce
Processor: i5 3570K
Mainboard: P8Z77-V Plus
Memory: 8GB
Soundcard: X-Fi FatalPro & Z5500 5.1
PSU: TPX-575M TOUGHPOWER XT
Default 01-17-2013, 00:54 | posts: 371 | Location: Macedonia, Greece

I want my collection of videos full, and I just got a very short video -Skyrim.

It was difficult to find the hotspot to get almost continuously flashing... On Skyrim it's mostly fast, isolated flashing, but not this time.

http://www.youtube.com/watch?v=JSI1tMlHXjU
   
Reply With Quote
Old
  (#793)
Epic0098
Newbie
 
Videocard: MSI 7950 Twin Frozr III
Processor: Intel i5 2500k 4.5Ghz
Mainboard: Asus P8P67LE
Memory: DDR3 1600Mhz 8GB
Soundcard: HT Omega Striker 7.1
PSU: Corsair TX750 V2
Default 01-17-2013, 01:35 | posts: 9 | Location: Ontario, Canada

Quote:
Originally Posted by NiColaoS View Post
I want my collection of videos full, and I just got a very short video -Skyrim.

It was difficult to find the hotspot to get almost continuously flashing... On Skyrim it's mostly fast, isolated flashing, but not this time.

http://www.youtube.com/watch?v=JSI1tMlHXjU
That is the exactly same issue I have. It happens in numerous places, just ruins the immersion.
   
Reply With Quote
Old
  (#794)
NiColaoS
Master Guru
 
NiColaoS's Avatar
 
Videocard: 7950 WindForce
Processor: i5 3570K
Mainboard: P8Z77-V Plus
Memory: 8GB
Soundcard: X-Fi FatalPro & Z5500 5.1
PSU: TPX-575M TOUGHPOWER XT
Default 01-17-2013, 02:07 | posts: 371 | Location: Macedonia, Greece

It's the problem we're talking about for so many months

It's general, all 7000 series card have it on many Dx9 games. Just it isn't easily reproducible on all of them.

Incidentally, I've an other problem, too, on Skyrim... Especially in dungeons, the game ain't as smooth as outside. It's like an annoying micro-stuttering when I'm looking around. But that's totally an other, unrelated story.
   
Reply With Quote
Old
  (#795)
3dPlayer
Banned
 
Videocard: Have
Processor: a
Mainboard: good
Memory: day
Soundcard: or
PSU: not
Default 01-17-2013, 02:25 | posts: 1,824

I bought mine on December, do you think i can send it back and ask my money back or replace it with an nvidia card?
   
Reply With Quote
Old
  (#796)
NiColaoS
Master Guru
 
NiColaoS's Avatar
 
Videocard: 7950 WindForce
Processor: i5 3570K
Mainboard: P8Z77-V Plus
Memory: 8GB
Soundcard: X-Fi FatalPro & Z5500 5.1
PSU: TPX-575M TOUGHPOWER XT
Default 01-17-2013, 02:29 | posts: 371 | Location: Macedonia, Greece

Personally, I sent my first card back when I discovered the issue, a few months after the initial purchase. They sent me new, but of course, the problem remained intact.

After the 13.1 version, I'll send it back again ( since I'm pretty sure, nothing will be fixed ), but this time I'll ask to send me 670GTX or the money back. We'll see what is going to happen.

I guess, you certainly can do that. You got a defective card. Explain them what is going on, and if you can, send 1-2 short videos.
   
Reply With Quote
Old
  (#797)
3dPlayer
Banned
 
Videocard: Have
Processor: a
Mainboard: good
Memory: day
Soundcard: or
PSU: not
Default 01-17-2013, 02:34 | posts: 1,824

The problem is i got FC3 included which i sold.How much will they deduct from what i paid?

After 13.1 i will sell it and get an Nvidia if it does not fix the problem.
   
Reply With Quote
Old
  (#798)
WiFry
Member Guru
 
WiFry's Avatar
 
Videocard: ASUS HD7870 Directcu II
Processor: Intel i5 2500K
Mainboard: ASUS P8Z68-V/GEN3
Memory: Corsair Vengeance DDR3
Soundcard: Infrasonic Quartet
PSU: Corsair HX650W
Default 01-17-2013, 03:59 | posts: 103 | Location: New Zealand

Unfortunately I feel this issue will take quite a while to fix.
AMD is sticking with GCN for their next series so I would assume they have no choice but to work on this long outstanding problem.
   
Reply With Quote
Old
  (#799)
IRQ Conflict
Newbie
 
Videocard: 2 Sapphire X1950 Pro's in CF
Processor: Core 2 Duo E6300@2.8Ghz
Mainboard: BadAxe 2
Memory: OCZ Gold XTC 3GB's PC2-6400
Soundcard: SB Audigy MP3+/Inspire 5.1
PSU: PC P&C Silencer 750 Quad
Default 01-17-2013, 06:36 | posts: 6 | Location: Canucksville

I don't have Skyrim to test But I did find this "flashing" in the Unigine Heaven benchmark. Turns out is was a missing texture (the ship) disappeared entirely for one tenth of a second.

Sometimes on of the houses will it as well. AMD have had what? A year to fix these issues? They more concerned with beating nVidia at the benchmarks than quality?

Last edited by IRQ Conflict; 01-17-2013 at 06:42.
   
Reply With Quote
Old
  (#800)
Gaizokubanou
Maha Guru
 
Gaizokubanou's Avatar
 
Videocard: Sapphire HD 7970
Processor: i7 930 @ 3.8ghz 1.25v
Mainboard: Asus P6X56D-E
Memory: DDR3 6GB
Soundcard: ASUS Xonar DX
PSU: Corsair HX750W
Default 01-17-2013, 06:50 | posts: 1,207

Quote:
Originally Posted by NiColaoS View Post
I want my collection of videos full, and I just got a very short video -Skyrim.

It was difficult to find the hotspot to get almost continuously flashing... On Skyrim it's mostly fast, isolated flashing, but not this time.

http://www.youtube.com/watch?v=JSI1tMlHXjU
I've seen that on DX11 games like Far Cry 3 as well.

But I never seen it that frequently. It was very rare on my end so I was able to ignore it for the most part.
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.