Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - AMD - ATI Drivers Section
Videocards - AMD - ATI Drivers Section In this section you can discuss everything Catalyst related. AMD Catalyst drivers are for all AMD ATI based graphics cards. This is also the place to discuss modified Catalyst drivers.


Reply
 
Thread Tools Display Modes
Old
  (#276)
ipredator
Master Guru
 
Videocard: GTX 680M @980/2400
Processor: Intel i7 980 @4Ghz
Mainboard: Intel X58
Memory: 24GB Corsair 1600Mhz
Soundcard: Inbuilt
PSU: 300W
Default 04-15-2012, 14:13 | posts: 497

Weird, cured my CCC everytimes I did it. Well, messed up drivers.
   
Reply With Quote
 
Old
  (#277)
bygbyron3
Newbie
 
Videocard: PowerColor PCS+ HD5850
Processor: AMD Phenom II X4 955
Mainboard: ASUS M4A87TD/USB3
Memory: DDR3 1600 4GB (2 x 2GB)
Soundcard: Klipsch iFi RSX3-RCX3 5.1
PSU: Antec BP550 Plus 550W
Default 04-16-2012, 04:00 | posts: 3

Upgrade from 11.12, which was the last OpenCL driver, on my 5850 and have had no issues. 12.1, 12.2, and 12.3 all glitched textures in Skyrim for me, these 12.4 drivers do not. Solid drivers on a 5850 in my experience.
   
Reply With Quote
Old
  (#278)
Raiga
Maha Guru
 
Videocard: GPU
Processor: CPU
Mainboard: Chipset
Memory: RAM
Soundcard:
PSU: PSU
Default 04-16-2012, 16:05 | posts: 1,054

How to add MLAA 2.0 support for my AMD 6950 card with this drivers?.
   
Reply With Quote
Old
  (#279)
SicKlown
Newbie
 
Videocard: Sapphire 7970 Dual-X
Processor: AMD Phenom II X6 4.1Ghz
Mainboard: Asus M4A79 Deluxe
Memory: 8 GB DDR-2 @ 1066Mhz
Soundcard: Asus Xonar D1
PSU: Silverstone Strider+ 750W
Default 04-17-2012, 02:42 | posts: 8 | Location: Texas

Quote:
Originally Posted by Raiga View Post
How to add MLAA 2.0 support for my AMD 6950 card with this drivers?.
You don't need to do anything other than install the drivers since the code for it is built in. As long as your card has DirectCompute support, you'll get the new MLAA algorithm.
   
Reply With Quote
 
Old
  (#280)
Pill Monster
Ancient Guru
 
Pill Monster's Avatar
 
Videocard: 7950 Vapor-X 1175/1550
Processor: AMD FX-8320 @4.8
Mainboard: ASUS Sabertooth 990FX R2
Memory: 8GB Kingston HyperX 2400
Soundcard: X-Fi Fatal1ty
PSU: AcBel M8 750
Default 04-17-2012, 03:01 | posts: 24,227 | Location: NZ

I thought MLAA 2.0 was only for 7xxx cards...?
   
Reply With Quote
Old
  (#281)
SicKlown
Newbie
 
Videocard: Sapphire 7970 Dual-X
Processor: AMD Phenom II X6 4.1Ghz
Mainboard: Asus M4A79 Deluxe
Memory: 8 GB DDR-2 @ 1066Mhz
Soundcard: Asus Xonar D1
PSU: Silverstone Strider+ 750W
Default 04-17-2012, 03:07 | posts: 8 | Location: Texas

It would make no sense for AMD to have two different MLAA algorithms in the driver, so any supported card should get 2.0.

I believe adaptive AA on DX10/11 is limited to 7xxx as of now, but that should eventually be pushed down to 6xxx and 5xxx series. Seeing as how Nvidia is pushing all their new features(adaptive v-sync) to all cards it would make AMD look bad to not do the same.
   
Reply With Quote
Older cards and 12.4's
Old
  (#282)
Irocing
Master Guru
 
Videocard: Sapphire 7970 OC Edition
Processor: Intel I7 930@4.51
Mainboard: ASUS P6X58D-E
Memory: Dominator 6 gig 1600@1743
Soundcard: Bose 2.1 CL XF Titanium
PSU: CM 850W Gold Modular
Default Older cards and 12.4's - 04-17-2012, 03:27 | posts: 168 | Location: AZ

Just wondering if anyone with the older cards, 57-58-59 series cards
have tried the latest 12.4 drivers and how do they work.

Had to roll back to the 11.8 drivers to cure a problem as to the drivers dropping out from time to time and shutdowns.
No problems with the 11.8,s and seems like the 12 series and the coding are messing up my cards.
Run CF 5770,s for another couple weeks until the new cards get sorted out
as to pricing and features.
Then back to a single Big card for awhile.

Later
   
Reply With Quote
Old
  (#283)
Raiga
Maha Guru
 
Videocard: GPU
Processor: CPU
Mainboard: Chipset
Memory: RAM
Soundcard:
PSU: PSU
Default 04-17-2012, 06:12 | posts: 1,054

Quote:
Originally Posted by Irocing View Post
Just wondering if anyone with the older cards, 57-58-59 series cards
have tried the latest 12.4 drivers and how do they work.

Had to roll back to the 11.8 drivers to cure a problem as to the drivers dropping out from time to time and shutdowns.
No problems with the 11.8,s and seems like the 12 series and the coding are messing up my cards.
Run CF 5770,s for another couple weeks until the new cards get sorted out
as to pricing and features.
Then back to a single Big card for awhile.

Later
I thought 11.11c were the best drivers, yet* for non 7xxx series cards.
   
Reply With Quote
Old
  (#284)
Dekaohtoura
Member Guru
 
Dekaohtoura's Avatar
 
Videocard: Sapphire 7950 VaporX 3GB
Processor: FX8320@4.7GHz...going up.
Mainboard: ASUS Sabertooth 990FXR2.0
Memory: 2x8GB KingstonBeast@1600
Soundcard:
PSU: Seasonic X-850
Default 04-17-2012, 06:51 | posts: 46

Quote:
Originally Posted by Irocing View Post
Just wondering if anyone with the older cards, 57-58-59 series cards
have tried the latest 12.4 drivers and how do they work.

Had to roll back to the 11.8 drivers to cure a problem as to the drivers dropping out from time to time and shutdowns.
No problems with the 11.8,s and seems like the 12 series and the coding are messing up my cards.
Run CF 5770,s for another couple weeks until the new cards get sorted out
as to pricing and features.
Then back to a single Big card for awhile.

Later
Same CF setup here (though not nearly as OC'ed as yours) and 12.4 run almost perfectly for me.

I say (write) almost because I had to uninstall/clear/reinstall them 4 days ago, after 15 days of BF3 testing them (for 4-7h/day), when for no good reason they were constantly giving BSOD in 3d mode.

After that, I BF3 tested them again, without any problems.
   
Reply With Quote
Old
  (#285)
Irocing
Master Guru
 
Videocard: Sapphire 7970 OC Edition
Processor: Intel I7 930@4.51
Mainboard: ASUS P6X58D-E
Memory: Dominator 6 gig 1600@1743
Soundcard: Bose 2.1 CL XF Titanium
PSU: CM 850W Gold Modular
Default 04-17-2012, 20:05 | posts: 168 | Location: AZ

Quote:
Originally Posted by Raiga View Post
I thought 11.11c were the best drivers, yet* for non 7xxx series cards.
Never tried the 11.11c drivers as from 11.8 went straight to the 12.1,s.

Was going to go to the 680 4gig card shortly but not with the 256 bit bus.

May wait for a little while now and wait for these cards to get sorted out
in the Non-Ref area.
5770's still kick A--, Just not at the highest setting and a very few
games that don't work with CF.

Later
   
Reply With Quote
 
Old
  (#286)
Xzibit
Banned
 
Videocard: 7970 Windforce
Processor: i5 3570K/H70
Mainboard: ASUS Z77VLX
Memory: 8Gb 2,2GHz, 1.5V
Soundcard: Creative X-Fi
PSU: Thermaltake 850W
Default 04-17-2012, 21:40 | posts: 4,383 | Location: Europe

1 month without new drivers, even that guy who leaks early betas has nothing
   
Reply With Quote
Old
  (#287)
ipredator
Master Guru
 
Videocard: GTX 680M @980/2400
Processor: Intel i7 980 @4Ghz
Mainboard: Intel X58
Memory: 24GB Corsair 1600Mhz
Soundcard: Inbuilt
PSU: 300W
Default 04-17-2012, 21:51 | posts: 497

I'm starting to shake... must... test... new drivers
   
Reply With Quote
Old
  (#288)
TheOriginalTO
Master Guru
 
Videocard: ATI 5870m
Processor: Intel Core i7 Q720
Mainboard: ASUS G73JH
Memory: 6.00
Soundcard:
PSU: Rbbx05
Default 04-17-2012, 21:53 | posts: 284

Quote:
Originally Posted by TheOriginalTO View Post
So if I install these, what do I need to leave out in order for that whole amd installer to not pop up at every startup?
Any thoughts on this matter guys?? I have an ATI 5870m. When I had these drivers installed a AMD black box would install something on every startup. Due to the positive reviews i've seen about these drivers I'd really like to jump on board, but I would love to hear a fix for this problem first. -Thanks
   
Reply With Quote
Old
  (#289)
SamuelMaki
Newbie
 
Videocard: AMD Radeon HD 5650 1GB
Processor: AMD Phemon II N930 Quad 2
Mainboard:
Memory:
Soundcard:
PSU: HP 19V 4.74A 90W
Default 04-17-2012, 21:58 | posts: 36 | Location: Espoo, Finland

Quote:
Originally Posted by TheOriginalTO View Post
Any thoughts on this matter guys?? I have an ATI 5870m. When I had these drivers installed a AMD black box would install something on every startup. Due to the positive reviews i've seen about these drivers I'd really like to jump on board, but I would love to hear a fix for this problem first. -Thanks
I did have that cmd with some other beta-driver, but I donīt have it anymore... I didnīt however get any problems with those beta-drivers that gives that cmd, so I quess you are fine with it and donīt worry...

And I liked to get new drivers too
   
Reply With Quote
Old
  (#290)
thatguy91
Ancient Guru
 
Videocard: HIS R9-280x Iceq X2 Turbo
Processor: i5-3570K
Mainboard: Asrock Z77 Extreme6
Memory: DDR3-2400 2x8GB
Soundcard: ALC898 + Microlab FC-730
PSU: Enermax Platimax 750W
Default 04-17-2012, 22:15 | posts: 4,036 | Location: Australia

A new embedded driver was released a few days ago:
http://www2.ati.com/drivers/embedded...EDG_Direct.zip

Although it seemingly appears the same as the driver this thread if about... (going by the date and the 8.96).
   
Reply With Quote
Old
  (#291)
ipredator
Master Guru
 
Videocard: GTX 680M @980/2400
Processor: Intel i7 980 @4Ghz
Mainboard: Intel X58
Memory: 24GB Corsair 1600Mhz
Soundcard: Inbuilt
PSU: 300W
Default 04-17-2012, 22:28 | posts: 497

It is pretty much the same, I installed it when it was posted.
Looking for something new
   
Reply With Quote
Old
  (#292)
Yxskaft
Master Guru
 
Videocard: 5770
Processor: Intel Core i7
Mainboard:
Memory: 8GB DDR3
Soundcard: Integrated
PSU: 650w
Default 04-17-2012, 22:31 | posts: 647

Quote:
Originally Posted by Xzibit View Post
1 month without new drivers, even that guy who leaks early betas has nothing
Perhaps AMD has taken one week extra and somehow unlocked 100% better performance in all games on all their Radeon HD series!
   
Reply With Quote
Old
  (#293)
bodean
Master Guru
 
Videocard: Sapphire 7970
Processor: Intel Core i7-2600K
Mainboard: Gigabyte Z77-UD3H
Memory: G.SKILL Ripjaws Z 16GB
Soundcard: ASUS XONAR DX
PSU: Antec 850-Watt TR
Default 04-18-2012, 13:43 | posts: 780 | Location: Chicago, IL

Quote:
Originally Posted by Yxskaft View Post
Perhaps AMD has taken one week extra and somehow unlocked 100% better performance in all games on all their Radeon HD series!
Totally agree. AMD lay people off or something?
   
Reply With Quote
Old
  (#294)
Pestul
Member Guru
 
Videocard: Xfire 5850s @875/1125
Processor: Core i7 920 @4.2GHz
Mainboard: ASUS P6T SE
Memory: 12GB DDR3
Soundcard:
PSU: Antec TP 750
Default 04-18-2012, 14:07 | posts: 76

Quote:
Originally Posted by Irocing View Post
Just wondering if anyone with the older cards, 57-58-59 series cards
have tried the latest 12.4 drivers and how do they work.

Had to roll back to the 11.8 drivers to cure a problem as to the drivers dropping out from time to time and shutdowns.
No problems with the 11.8,s and seems like the 12 series and the coding are messing up my cards.
Run CF 5770,s for another couple weeks until the new cards get sorted out
as to pricing and features.
Then back to a single Big card for awhile.

Later
I'm using the 12.4 betas with a CF 5850 setup. I really like them. If you want to get rid of the slow CCC startup, just install the 12.1s and then the 12.4s right over them.
   
Reply With Quote
Old
  (#295)
AMDX1325
Newbie
 
Videocard: Diamond HD7970 3GB GDDR5
Processor: AMD Phenom II X4 965
Mainboard: Asus M4A785TD-M-EVO
Memory: Kingstom HyperX 8gb DDR3
Soundcard: Asus Xonar DX
PSU: OCZ 700watt
Default 04-19-2012, 03:28 | posts: 43 | Location: NYC

Quote:
Originally Posted by Xzibit View Post
1 month without new drivers, even that guy who leaks early betas has nothing
My exact feeling too
   
Reply With Quote
Old
  (#296)
GhostXL
Ancient Guru
 
GhostXL's Avatar
 
Videocard: ZOTAC GTX 980 @ 1510/7800
Processor: i7 4790K @ 4.8ghz on H90
Mainboard: ASUS Maximus VII HERO Z97
Memory: G.Skill Trident DDR3 2667
Soundcard: Sound Blaster Z
PSU: CORSAIR AX1200 watt
Default 04-22-2012, 00:40 | posts: 5,673 | Location: PA, USA

I'm in no serious rush for new drivers I guess. The 12.4 beta's work great. I just want AMD to improve even more on the next set. So if they take their time and get it done that's fine with me.
   
Reply With Quote
Old
  (#297)
Pill Monster
Ancient Guru
 
Pill Monster's Avatar
 
Videocard: 7950 Vapor-X 1175/1550
Processor: AMD FX-8320 @4.8
Mainboard: ASUS Sabertooth 990FX R2
Memory: 8GB Kingston HyperX 2400
Soundcard: X-Fi Fatal1ty
PSU: AcBel M8 750
Default 04-22-2012, 00:44 | posts: 24,227 | Location: NZ

Quote:
Originally Posted by GhostXL View Post
I'm in no serious rush for new drivers I guess. The 12.4 beta's work great. I just want AMD to improve even more on the next set. So if they take their time and get it done that's fine with me.
Yeah these are the best drivers I've used in age, especially since I'm using the modded set. lol
   
Reply With Quote
Old
  (#298)
The Mac
Maha Guru
 
Videocard: Sapphire R9-290 Vapor-X
Processor: i7-4970K
Mainboard: Asus Z97-A
Memory: Corsair Vengence Pro 16GB
Soundcard: X-Fi Titianum HD
PSU: Corasir AX750
Default 04-22-2012, 04:32 | posts: 2,406 | Location: USA

ditto...these things are ultra-stable...
   
Reply With Quote
Old
  (#299)
Athlonite
Maha Guru
 
Athlonite's Avatar
 
Videocard: 2 HD7850 1GHz/1300MHz
Processor: FX8320 / 3700MHz
Mainboard: ASUS Crosshair V Formula
Memory: DDR3 Corsair Vengence LP
Soundcard: SB XFi Audio PCIe
PSU: SilverStone ST75F-P 750W
Default 04-22-2012, 06:11 | posts: 861 | Location: Hawkes Bay

Quote:
Originally Posted by Irocing View Post
Just wondering if anyone with the older cards, 57-58-59 series cards
have tried the latest 12.4 drivers and how do they work.

Had to roll back to the 11.8 drivers to cure a problem as to the drivers dropping out from time to time and shutdowns.
No problems with the 11.8,s and seems like the 12 series and the coding are messing up my cards.
Run CF 5770,s for another couple weeks until the new cards get sorted out
as to pricing and features.
Then back to a single Big card for awhile.

Later
same CF setup as yours so far I've found them stable and faster than 12.1's I play alot of skyrim and with these drivers I have been able to really crank up the settings to ultra or highest without loss of FPS indoors or out at 1920x1080 and MLAA 2.0 works great too


   
Reply With Quote
Old
  (#300)
AATT
Member Guru
 
Videocard: 7950 PCS+
Processor: Q9505s
Mainboard: Asus P5QD Turbo
Memory: GSkill 4x2Gb DDR2 1200
Soundcard: onboard VIA
PSU: 550W
Default 04-22-2012, 19:23 | posts: 64

how can i adjust the max render ahead limit without ati tray tools?
there was some tool u can load with a .dll file and textfile where u can set it up, i forgot the name
tool was about forcing tripple buffer in d3d i think

and is there any registry value for this maybe?
sry dont want to start a new thread about it
   
Reply With Quote
Reply

Tags
amd drivers still suck

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.