Go Back Forums > Videocards > Videocards - NVIDIA GeForce Drivers Section
Videocards - NVIDIA GeForce Drivers Section In this section you can discuss everything GeForce driver related. GeForce ForceWare and GeForce Exerience drivers are for NVIDIA Quadro and all GeForce based videocards.

Thread Tools Display Modes
Vsync Issue
Videocard: EVGA GTX 570 @ 900/1800
Processor: i7 2600K @ 4.5/1.33v
Mainboard: Asus P8P67 Deluxe
Memory: 8GB (2x4) G.Skill 2133Mhz
Soundcard: On-board Realtek ALC889
Default Vsync Issue - 02-25-2012, 01:38 | posts: 9

If I set a game to use vsync or even force vsync and set my Hz to 60 in windows and set it to 60 in games if the option is there It is still giving me 120FPS in games as if the monitor is set to 120Hz.. How come I cant get it down to 60Hz/60FPS?

If your wondering why I want it lower than 120Hz its because I want to have it at 60Hz/60FPS for Battlefield as my card cant not display 120 FPS to Match my monitors 120Hz. If I have vsync off I notice tearing and I just cant handle that.

Now in windows im pretty sure the 60Hz is working but I can notice the difference with mouse movements over a white screen. on 60Hz there is a slight trail behind the mouse and on 120Hz there is no trail.

In game I know its going back up to 120FPS because I have an on screen display that displays my FPS.. it goes to 120 and caps at 120. It should be capping at 60.. What is going on?
Reply With Quote
Videocard: ASUS GTX 970
Processor: Intel i5 4690K
Mainboard: Gigabyte Z97X-SLI
Memory: 12gb
PSU: Corsair 550W
Default 02-25-2012, 10:27 | posts: 9 | Location: Finland

Try to make a new resolution, if your display is 1080p, make a new resolution with 1920x1079 and put the refresh rate to 60hz, ingame then change to this resolution, should force the 60hz.
Reply With Quote
Videocard: MSI HD 6770
Processor: FX-4100 4.0Ghz
Mainboard: MSI 970A-G46
Memory: HuperX 2x4GB PC12800
Soundcard: Realtek Onboard
PSU: LC-Power 600W
Default 02-25-2012, 12:16 | posts: 932 | Location: Serbia

yes, create custom resolution with RR 60Hz, chances are, most likely that it will not work in games..., it's some sort of bug with windows or nvidia drivers (or both). You can also try some older drivers for that, but again, i don't know if GTX 570 is supported by drivers that can change it. Anyways, in Win 7, after SP1, i was unable to force custom resolutions in games. If you have a copy of Win XP, you can install it (64-bit edition for you) and use reforce or other 3rd party programs that will work perfect.

Maybe we should point that out towards nvidia, but i doubt they will bother with it. It would be nice to have a option to disable all resolutions except custom, and force driver to use only custom resolutions on games and desktop.
Reply With Quote
Master Guru
Videocard: eVGA gtx 980 sli
Processor: Intel Core i5 3570k @ 4.7
Mainboard: Asus P8Z77-V PRO
Memory: Corsair 8GB DDR3 2133
Soundcard: onboard / Logitec Z5500
PSU: Thermaltake TPX-1275M
Default 02-25-2012, 13:37 | posts: 349 | Location: HOMELESS

If that doesn't work you could always try using the frame limiter function in EVGA precisions. Lock the frame rate to 60 fps but force Vsync through the drivers. Dunno if that will still tear though...
Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBulletin®
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
vBulletin Skin developed by:
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.