Guru3D.com Forums

Go Back   Guru3D.com Forums > Affiliates > MSI AfterBurner Overclock Application Discussion forum
MSI AfterBurner Overclock Application Discussion forum This forum is intended for MSI customers for questions on the AfterBurner Overclock Utility based off Rivatuner. In this section the users help each other out with answers as well as support staff from MSI.


Reply
 
Thread Tools Display Modes
Wake from sleep issues
Old
  (#1)
KillaGramm
Newbie
 
Videocard: Sapphire Radeon HD 5970
Processor: Intel Core i7 960 @ 4 Ghz
Mainboard:
Memory:
Soundcard:
PSU: Revolution 1050 W
Exclamation Wake from sleep issues - 08-12-2011, 00:20 | posts: 2

Hello all,

I've been using AfterBurner for quite some time now and have always had this problem, but could never find a solution. I have a Radeon HD 5970 OC'd with AfterBurner to 1.162/850/1102. Everything runs fine during normal operation and extended gaming use. However, if I put the computer to sleep or hibernate, after waking, if I try to launch a 3D application the graphics card freezes. Sometimes it recovers, and sometimes I get a BSoD as well. I've done a lot of searching and tried different things. One person suggested manually changing the ATI Control Center profile to increase the idle frequencies of the GPUs. Nothing has worked so far. However, after sleep, if I manually change to the default profile in AfterBurner, then switch back to the OC profile, the problem seems to be prevented.

I believe the problem may have to do with the voltage increase not being applied after wake. I think this because if I disable AfterBurner and apply the same OC settings in ATI OverDrive, I get the same freezing behaviour (and the voltage is the only thing that is, seemingly, different).

Does anyone have similar issues or know if the voltage is, in fact, the problem? If so, any solutions for this?

Thanks,

Graham
   
Reply With Quote
 
Workaround
Old
  (#2)
burgoburgo
Newbie
 
Videocard: MSI HD6850 @ 1030/1233
Processor: I5 2500K @ 4.6
Mainboard: Asrock P67 something
Memory: 8GB DDR3
Soundcard: Onboard linked to 5.1 AMP
PSU: OCZ Fatality 700W
Default Workaround - 08-26-2011, 11:44 | posts: 2 | Location: Aus

Hi.
I was looking for a solution to this problem and found this thread.

I've had this problem for a while (running Win7 and a HD6850) and usually just restart afterburner.

When I couldn't find a better solution, I automated this restart using task scheduler.

Details:

I made a batch file that contains the following
c:
tskill MSIafterburner
start /B /D "c:\Program Files (x86)\MSI Afterburner" MSIAfterburner.exe
exit


Then using Task Scheduler I created a new task within Event Viewer Tasks.
In the Trigger tab I added these details (obtained from event viewer)
Log: System
Source: Power-Troubleshooter
Event ID: 1

Then add the batch file from the Action tab.

This should work out well as I often forget to restart Afterburner after a resume.
   
Reply With Quote
Old
  (#3)
Unwinder
Moderator
 
Videocard:
Processor:
Mainboard:
Memory:
Soundcard:
PSU:
Default 08-26-2011, 11:52 | posts: 11,389 | Location: Taganrog, Russia

There is built-in workaround in Afterburner and it was already documented before, setting RestoreAfterSuspendedMode entry to 1 in configuration file will cause Afterburner to save current settings to a temporary profile before the system is entering suspended mode and restore this profile after waking up.


Alexey Nicolaychuk aka Unwinder, RivaTuner creator
   
Reply With Quote
Old
  (#4)
burgoburgo
Newbie
 
Videocard: MSI HD6850 @ 1030/1233
Processor: I5 2500K @ 4.6
Mainboard: Asrock P67 something
Memory: 8GB DDR3
Soundcard: Onboard linked to 5.1 AMP
PSU: OCZ Fatality 700W
Default 08-26-2011, 11:56 | posts: 2 | Location: Aus

ha! excellent, cheers.
   
Reply With Quote
 
Old
  (#5)
Unwinder
Moderator
 
Videocard:
Processor:
Mainboard:
Memory:
Soundcard:
PSU:
Default 08-26-2011, 12:07 | posts: 11,389 | Location: Taganrog, Russia

No problem. BTW, If I were trying to implement task scheduler based workaround like you did, there is more optimal way:

Just save desired settings to a profile slot then simply launch the following command after resume:

MSIAfterburner.exe -profile<index> (e.g. MSIAfterburner.exe -profile1)

This is much faster and eliminates the need of terminating the previous instanse of application.


Alexey Nicolaychuk aka Unwinder, RivaTuner creator
   
Reply With Quote
Old
  (#6)
KillaGramm
Newbie
 
Videocard: Sapphire Radeon HD 5970
Processor: Intel Core i7 960 @ 4 Ghz
Mainboard:
Memory:
Soundcard:
PSU: Revolution 1050 W
Default 08-26-2011, 17:04 | posts: 2

Thanks to both of you for the responses! I will try the configuration file edit for AfterBurner. From the sounds of it, it will solve the problem!

Cheers.
   
Reply With Quote
Reply

Tags
5970, issue, overclock, sleep

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.