Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - AMD - ATI Drivers Section
Videocards - AMD - ATI Drivers Section In this section you can discuss everything Catalyst related. AMD Catalyst drivers are for all AMD ATI based graphics cards. This is also the place to discuss modified Catalyst drivers.


Reply
 
Thread Tools Display Modes
Tried to update my graphics card drivers and now Opengl doesn't work, need advice
Old
  (#1)
resbot
Newbie
 
Videocard: ATI RadeonHD5870 1024MB
Processor: Intel Core i7
Mainboard:
Memory:
Soundcard:
PSU: not sure
Default Tried to update my graphics card drivers and now Opengl doesn't work, need advice - 06-18-2011, 12:24 | posts: 1

I have a Radeon HD 5870, windows 7 64bit. I have been experiencing a crash in the game Minecraft when I play with the 'fancy' graphics setting. I wanted to try to fix this, and someone suggested I update my graphics card driver.

I went to the site for downloading Radeon standalone drivers and downloaded the installer "11-6_vista64_win7_64_dd.exe" and ran the installer. It blue-screened halfway through, and my computer rebooted.
The display driver was borked so I tried downloading the full Catalyst installer next "11-6_vista64_win7_64_dd_ccc_ocl.exe", and ran that exe. It extracted to my C drive but never continued the installation. SO I navigated to the folder on C that it had extracted to and tried running "Setup.exe" there.

I got this Error: "C:\ATI\Support\11-6_vista64_win7_64_dd_ccc_ocl\Setup.exe has failed to start because its side-by-side configuration is incorrect."

So then I followed the instructions to completely remove the ATI drivers, and restarted, but the Setup.exe in the exe installer still didn't run, still gave the same "side-by-side" configuration error.

I emailed AMD's tech support, they just said "use the old drivers, maybe there will be a new driver next week" (REAL helpful) so I dug out my old graphics card instal cd and ran the old installer. Which worked EXCEPT now when I try to run Minecraft it says it can't "find an Opengl accelerated card" or something.

So reverting to the old driver works except for Opengl which I need to play Minecraft which was the whole point of running the updater in the first place.

TL;DR: So basically I tried to update my driver and it completely broke Opengl.

Any ideas on what I can do to get OpenGL working again?
I tried titaniumgl.tk, it mangled Minecrafts graphics into garbage, so that doesn't work.

I can't even try to run the ATI installer again because it always says "side-by-side configuration" error.

Any advice on what I can do?


Update: I uninstalled using the ATI uninstaller, then I used Driver Sweeper, and reinstalled and it seems to be fine now.

Last edited by resbot; 06-18-2011 at 22:01.
   
Reply With Quote
 
Old
  (#2)
MIXXX
Master Guru
 
Videocard: SAPPHIRE ATI RADEON™ 3850
Processor: P4 @ 3.06 MHZ NORTHWOOD
Mainboard: INTEL 850e
Memory: 2048 RDRAM 800MHZ
Soundcard: KLIPSCH 2.1 W/SUB
PSU: Antec true power 430 DX 9
Default 06-22-2011, 17:02 | posts: 151 | Location: Big Easy

If Open GL seems broke,

I would delete the config file for the game first and let the game engine rebuild another one.

save your old copy just in case.

Also try to set settings in CCC to application selection and try to adjust the Catalyst AI setting

PEACE

Last edited by MIXXX; 06-22-2011 at 17:05.
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.