Guru3D.com Forums

Go Back   Guru3D.com Forums > Affiliates > ATI Tray Tools > ATI Tray Tools Generic Discussion > ATI Tray Tools Public Beta Section
ATI Tray Tools Public Beta Section In here only the ATT beta development of this tool is and may be discussed.


Reply
 
Thread Tools Display Modes
ATT crashes two (possibly more) unrelated applications: Skype and Itunes
Old
  (#1)
personblue
Newbie
 
Videocard: ATI Mobility X1300
Processor: Intel Core 2 Duo
Mainboard:
Memory:
Soundcard:
PSU: N/A
Default ATT crashes two (possibly more) unrelated applications: Skype and Itunes - 11-24-2010, 07:51 | posts: 4

This is weird.

I'm pretty sure this started happening with the last few builds of ATI Tray tools, since it has happened twice already.

The first time, I reformatted windows 7 then installed the beta sp1. Not using skype or itunes at all, I installed ati tray tools. Restarted, and for some reason (did not know it was related to ati tray tools) both skype AND itunes (Actually, the newest versions of skype and itunes; skype 5, itunes 10.1) could not run. I tested skype 4 after (and before i reformatted) and profoundly it worked. I thought it was sp1 (even though 'minimal' changes were made), so i uninstalled sp1, and still, the problem kept occurring. So, i decided to reformat again (this time a slipstreamed version of sp1).

Fast forward to today, when i realized i did not install ati tray tools (this was because i have had no time to play any games until now ). Installing ati tray tools, Skype DID NOT crash (it was in background). I start fiddling with the overclock, which crashes the driver (since i'm not careful enough).

First time (display driver crashed): Skype did not crash, nor did i see any errors (other than the display driver crashing).

(after messing up again)

Second time: Skype crashed. I thought that was really weird, since if it would crash, it wouldn't be the second attempt at failing, it'll be the first.

I restarted the computer and right when i get on the desktop, windows gives an application error about Skype and asks to send error info to microsoft. I realized this might be the exact same thing that happened to me before. Seeing if this was, in fact, the exact same problem, i opened itunes, and amazingly this also crashed. (This is around the time i realized att must be the problem). I closed att, and miraculously, both skype AND itunes suddenly started working.

WHY does ATT crash (seemly unrelated) applications (btw i googled it and this seems to be isolated)?

The answer is probably related to some setting (that i will need to turn off), and if so:
How come this only started occurring in the last few builds?
How come older versions of applications work while new ones don't (since skype 4 worked and skype 5 did not)?

The graphics card probably is irrevelant, but the card is Mobility Radeon X1300 (yes a really old card; still plays the games i want though )

THANKS FOR HELPING

Edit: Actually these two threads collaborate with this (incidently the top ones... which goes to show that this is a new problem)

http://forums.guru3d.com/showthread.php?t=331037
http://forums.guru3d.com/showthread.php?t=332021

Now that i remember, does directx runtime have anything to do with this? I remember that steam games did not run becuase of some problem, and that you needed to install the runtime in order to play. Hmmm it doesn't make sense since skype or itunes do not require any directx (if it was, say, counter strike, then it would make sense).

Last edited by personblue; 11-24-2010 at 08:02.
   
Reply With Quote
 
Old
  (#2)
Ray Adams
Ancient Guru
 
Ray Adams's Avatar
 
Videocard: ATI HD6950
Processor: Intel C2Q Q9550 (3.4GHz)
Mainboard: ASUS P5E
Memory: 8Gb Patriot Viper
Soundcard: internal
PSU: 900W
Default 11-24-2010, 07:59 | posts: 4,942

I use both Skype and iTunes. So far no crashes at all on both my computers with W7 32 and W7 64.

After reformatting W7 did you install last DirectX update?
   
Reply With Quote
Old
  (#3)
personblue
Newbie
 
Videocard: ATI Mobility X1300
Processor: Intel Core 2 Duo
Mainboard:
Memory:
Soundcard:
PSU: N/A
Default 11-24-2010, 08:03 | posts: 4

I guess i'll install it now, just to check

Edit: ...and it works!

Interesting. I guess its because att depends on directx 'optional' components, and those were removed in windows 7 (by default).

Still, i don't see how skype and itunes (non directx usage applications) are effected with att.

But, Thanks for helping, Ray!

Last edited by personblue; 11-24-2010 at 08:22.
   
Reply With Quote
Old
  (#4)
Ray Adams
Ancient Guru
 
Ray Adams's Avatar
 
Videocard: ATI HD6950
Processor: Intel C2Q Q9550 (3.4GHz)
Mainboard: ASUS P5E
Memory: 8Gb Patriot Viper
Soundcard: internal
PSU: 900W
Default 11-24-2010, 17:07 | posts: 4,942

Quote:
Interesting. I guess its because att depends on directx 'optional' components, and those were removed in windows 7 (by default).
They were not removed, just never exist DirectX must be updated after any Windows installations. That's why all games automatically install DirectX
   
Reply With Quote
 
Old
  (#5)
personblue
Newbie
 
Videocard: ATI Mobility X1300
Processor: Intel Core 2 Duo
Mainboard:
Memory:
Soundcard:
PSU: N/A
Default 11-24-2010, 19:22 | posts: 4

I could have sworn that I remember seeing that windows 7 does not include some directx9 components (that were there in vista/xp), but i can't find any source (other than some other forum threads).

I also realized that skype and itunes uses a custom user interface, hence the requirement for directx9 (does this make sense?).
   
Reply With Quote
Old
  (#6)
VisionOne
Newbie
 
Videocard: MSI HD 3870 OC
Processor: Intel Q6600 QuadCore
Mainboard: MSI P35 NEO2 FIR
Memory: MDT & MUSHKIN each 4GB
Soundcard: Onboard
PSU: Be Quiet Dark Power 550W
Default 04-05-2011, 09:07 | posts: 1 | Location: Germany

Hi there,

I am new here. So I want to say "Hi to all of you". I am from Germany. So please excuse my english.

I had those Problems with ATT and iTunes and Steam....
Just after I got my SSD - Ive installed Windows 7 SP1 64.
Ive installed the AMD/ATi drivers for my "old" HD3870: iTunes and Steam still worked...
Then I installed ATT and made it running by task on StartUp...

After that iTunes and Steam crashed once the were started....
I stopped ATT and started iTunes again...everything fine....

I will try to reinstall DirectX later and hope ATT and iTunes will work together...

VisionOne
   
Reply With Quote
Old
  (#7)
personblue
Newbie
 
Videocard: ATI Mobility X1300
Processor: Intel Core 2 Duo
Mainboard:
Memory:
Soundcard:
PSU: N/A
Default 04-09-2011, 09:28 | posts: 4

Make sure you download everything for directx, including the optional components. Then, you should be fine.
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.