Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - AMD - ATI Drivers Section
Videocards - AMD - ATI Drivers Section In this section you can discuss everything Catalyst related. AMD Catalyst drivers are for all AMD ATI based graphics cards. This is also the place to discuss modified Catalyst drivers.


Reply
 
Thread Tools Display Modes
How nice of you ATI, new cards, but no new drivers! Im off to nvidia
Old
  (#1)
RazerBlue
Newbie
 
Videocard: e-Geforce 8800 GT Superclocked
Processor: Kentsfield GO @ 3400Mhz
Mainboard: ASUS P5K
Memory: G.SKILL 2GBx2 4GB@1100Mhz
Soundcard: Revo
PSU: Thermaltake ToughPower 700w Modular
Thumbs down How nice of you ATI, new cards, but no new drivers! Im off to nvidia - 11-15-2007, 22:31 | posts: 20 | Location: Chicago

Im done with ATI , with their junk drivers and problems after problem,,
   
Reply With Quote
 
Old
  (#2)
scoutingwraith
Ancient Guru
 
scoutingwraith's Avatar
 
Videocard: eVGA 670 FTW/ Intel4400
Processor: i5-3570K 4.0/i7-4500U 2.4
Mainboard: ASRock Z77Ex4/Haswell-ULT
Memory: 16GB 1600 / 8GB 1600
Soundcard: Realtek HD / Realtek HD
PSU: Corsair HX750W / 9 Cell
Default 11-15-2007, 23:00 | posts: 9,449 | Location: Sector ZZ9 Plural Z Alpha

Care to elaborate on your statement and what exactly is your problem?

Most users here are only whining without giving any information at all so if you need to vent off some steam play a shooter or go outside and play sports.
   
Reply With Quote
Old
  (#3)
Thunderball
Member Guru
 
Videocard: HD5870+Twinturbo Pro
Processor: Phenom II X4 965 C3 @ 4,0
Mainboard: Gigabyte GA-MA790FXT-UD5P
Memory: 8GB DDR3 1600Mhz G.Skill
Soundcard: Soundblaster Audigy 2 ZS
PSU: BE Quiet! Dark Power 850
Default 11-15-2007, 23:09 | posts: 135 | Location: @home

My guess is he is using an AGP card with the 7.10 drivers
   
Reply With Quote
Old
  (#4)
RazerBlue
Newbie
 
Videocard: e-Geforce 8800 GT Superclocked
Processor: Kentsfield GO @ 3400Mhz
Mainboard: ASUS P5K
Memory: G.SKILL 2GBx2 4GB@1100Mhz
Soundcard: Revo
PSU: Thermaltake ToughPower 700w Modular
Default 11-16-2007, 00:52 | posts: 20 | Location: Chicago

Yes sorry guys, Im on AGP x800 , with 7.7 drivers ,, anything higher D3D doesnt work,,, sighs
   
Reply With Quote
 
Old
  (#5)
Mad Cow
Maha Guru
 
Videocard: Sapphire+HIS X1950 PRO Crossfire+OC
Processor: Athlon 64 X2 4400+ @2.6
Mainboard: DFI Lanparty UT CFX3200
Memory: 2048 mb. PC3200 DDR
Soundcard: X-FI OEM, Logitech Z-640
PSU: Nikao Cool Power 500W (34A@12v)
Default 11-16-2007, 02:19 | posts: 1,097 | Location: Canada

You don't need to go higher with those cards. All the optimizations and bugfixes have already been done to death.
   
Reply With Quote
Old
  (#6)
danylati
Member Guru
 
Videocard: Ati HD 2900XT Saphire 512Mb
Processor: Core 2 Duo E8400 @ 3.6 ghz
Mainboard: Gigabyte P35-DS3L
Memory: 4gb DDR2 @ 966 Dual OCZ Reaper
Soundcard: X-FI Fatal1ty Pro + Altec 4.1
PSU: 600w Coolermaster igreen SLI
Default 11-16-2007, 04:11 | posts: 126 | Location: Mexico City

Ati You Sucks !!!!!!
   
Reply With Quote
Old
  (#7)
MaxBlade
Master Guru
 
MaxBlade's Avatar
 
Videocard: 970/GT770/7970/+ more
Processor: I7, I5 @4.8
Mainboard: Z97x Gigabyte/msi/Asus
Memory: 16g
Soundcard: To many :)
PSU: 1000
Default 11-16-2007, 04:16 | posts: 690

Quote:
Originally Posted by danylati View Post
Ati You Sucks !!!!!!
Lol well theres really nothing to say to that is there. I'm sure from where ATI or Nvidia for that matter would just sit back and laugh to that.
   
Reply With Quote
Old
  (#8)
Saabjock
Master Guru
 
Saabjock's Avatar
 
Videocard: PNY GTX 670 XLR8 2GB
Processor: Intel I7-3820@4GHz
Mainboard: Biostar TP-X79
Memory: Patriot Series7/16GB
Soundcard: Realtek ALC898
PSU: PCP&C Silencer 750_XF
Default 11-16-2007, 04:38 | posts: 218 | Location: California

Don't feel too bad about not having the latest drivers...at least you got your card to install. My friend bought a newly released Diamond HD2600 Pro four week ago from the local Fry's Electronics. His card had a rebate, so he (in trying to beat the deadline) cut the UPC out of the packaging, before I had a chance to install it. The factory supplied drivers on the original cd did n't work so now he's 'stuck' with a videocard he can't return. His only option is if he goes through the additional expense of packaging it up and shipping it back to Diamond Multimedia direct. I've been looking for four weeks for a driver that will work...to make things worst Diamond's website does n't even have a driver posted for their own card and none of ATI's or the modded ones I've found work. How's that for bad? He paid for a product four weeks ago and can't use it due to something beyond his control.

Last edited by Saabjock; 11-17-2007 at 12:26.
   
Reply With Quote
Old
  (#9)
Saabjock
Master Guru
 
Saabjock's Avatar
 
Videocard: PNY GTX 670 XLR8 2GB
Processor: Intel I7-3820@4GHz
Mainboard: Biostar TP-X79
Memory: Patriot Series7/16GB
Soundcard: Realtek ALC898
PSU: PCP&C Silencer 750_XF
Question 11-16-2007, 04:42 | posts: 218 | Location: California

Has anybody got a solution for installing the modded Omega drivers for AGP cards? When ever I try, It appears to go smoothly. All components appear to installs (i.e driver, CCC, MultiRes etc...) but when I am asked to reboot, the found new hardware wizard comes up. If I point to the ATI folder from the Device Manager's update option, it installs the driver and I can then change resolutions, adjust as normal...but then on the following restart....it crashes. I then have to select safemode to get to the desktop wherein my next restart will be normal. Then the cycle starts all over again.

Last edited by Saabjock; 11-16-2007 at 14:16.
   
Reply With Quote
Old
  (#10)
Laykun
Ancient Guru
 
Laykun's Avatar
 
Videocard: 2 x EVGA GTX670 4GB
Processor: i7 980X
Mainboard: Gigabyte GA-X58A-UD7
Memory: 18GB DDR3 1600
Soundcard: Xonar DX / Denon AH-D7000
PSU: 850W CM Silent Pro M850
Default 11-16-2007, 04:57 | posts: 3,221 | Location: New Zealand

   
Reply With Quote
 
Old
  (#11)
squirrel007
Master Guru
 
squirrel007's Avatar
 
Videocard: Gigabyte R9 280X
Processor: Phenom II 1100T
Mainboard: AsRock 990fx Extreme4
Memory: G.SKILL Sniper 8GB 1600
Soundcard: X-Fi Fatality Pro
PSU: Silverstone DA1000 1000W
Default 11-16-2007, 05:23 | posts: 405 | Location: Wisconsin

Am I the only one who has never really had any problems with ATI? I guess I should count my blessings.
   
Reply With Quote
Old
  (#12)
danylati
Member Guru
 
Videocard: Ati HD 2900XT Saphire 512Mb
Processor: Core 2 Duo E8400 @ 3.6 ghz
Mainboard: Gigabyte P35-DS3L
Memory: 4gb DDR2 @ 966 Dual OCZ Reaper
Soundcard: X-FI Fatal1ty Pro + Altec 4.1
PSU: 600w Coolermaster igreen SLI
Default 11-16-2007, 06:52 | posts: 126 | Location: Mexico City

Quote:
Originally Posted by squirrel007 View Post
Am I the only one who has never really had any problems with ATI? I guess I should count my blessings.
Install crysis or any recent game
   
Reply With Quote
Old
  (#13)
Stop It RAWR
Master Guru
 
Stop It RAWR's Avatar
 
Videocard: XFX Radeon HD7850 BE
Processor: Intel i5 2500k @4600Mhz
Mainboard: ASRock P67 Extreme4
Memory: 8GB Corsair XMS3 1600Mhz
Soundcard: X-Fi XtremeGamer
PSU: OCZ Fatality 550W
Default 11-16-2007, 06:59 | posts: 208 | Location: Biggleswade, UK

Quote:
Originally Posted by RazerBlue View Post
Im done with ATI , with their junk drivers and problems after problem,,
You have a 2 generation old card, the 7.7 Cats are more than adaquate for it, stop complaining about something that frankly isn't something to complain about.

Quote:
Originally Posted by danylati View Post
Ati You Sucks !!!!!!
You can just shut up, troll.
   
Reply With Quote
Old
  (#14)
danylati
Member Guru
 
Videocard: Ati HD 2900XT Saphire 512Mb
Processor: Core 2 Duo E8400 @ 3.6 ghz
Mainboard: Gigabyte P35-DS3L
Memory: 4gb DDR2 @ 966 Dual OCZ Reaper
Soundcard: X-FI Fatal1ty Pro + Altec 4.1
PSU: 600w Coolermaster igreen SLI
Default 11-16-2007, 07:05 | posts: 126 | Location: Mexico City

Quote:
Originally Posted by Stop It RAWR View Post
You have a 2 generation old card, the 7.7 Cats are more than adaquate for it, stop complaining about something that frankly isn't something to complain about.



You can just shut up, troll.
NO !!
   
Reply With Quote
Old
  (#15)
Stop It RAWR
Master Guru
 
Stop It RAWR's Avatar
 
Videocard: XFX Radeon HD7850 BE
Processor: Intel i5 2500k @4600Mhz
Mainboard: ASRock P67 Extreme4
Memory: 8GB Corsair XMS3 1600Mhz
Soundcard: X-Fi XtremeGamer
PSU: OCZ Fatality 550W
Default 11-16-2007, 07:20 | posts: 208 | Location: Biggleswade, UK

Quote:
Originally Posted by danylati View Post
NO !!
Look, we've already established from your pathetic whining thread that your blind fanboyism caused you to be in the situation you're in now, how about looking at it objectively rather than tying to blame everyone else for your mistakes?
   
Reply With Quote
Old
  (#16)
serbicu
Maha Guru
 
serbicu's Avatar
 
Videocard: ASUS GTX780 DCU2OC
Processor: I7-2700K|4.8Ghz|H80
Mainboard: Sabertooth Z77
Memory: 8G Corsair Vengeance
Soundcard: X-FI Titanium Fatal1ty
PSU: Corsair HX850W
Default 11-16-2007, 07:34 | posts: 1,270 | Location: Romania

Quote:
Originally Posted by danylati View Post
Ati You Sucks !!!!!!
dude please do us a favor and just sell your card and buy something from nvidia and go brag about it on nvidia threads...
   
Reply With Quote
Old
  (#17)
Sash
Ancient Guru
 
Videocard: video
Processor: cpu
Mainboard:
Memory:
Soundcard:
PSU: psu
Default 11-16-2007, 08:14 | posts: 7,004

i also dont like the driver support ati offers, espacially for notebooks i can only use the 7.4 on mine, since the higher ones are locked to special manufacturers and mobilitty modder messes up some games, for ex i was using the modded 7.10 cats modded for notebook and Sup Com Forged Aliance had artifacts and ran at 1 fps lol
   
Reply With Quote
Old
  (#18)
Jonnyboy
Ancient Guru
 
Jonnyboy's Avatar
 
Videocard: Asus R280 3GB GDDR5
Processor: i5-750(oc'd 3.7 Ghz)
Mainboard: Gigabyte P55-USB3
Memory: 4 GB of GSkill DDR3 1333
Soundcard: SoundBlaster XFi Titanium
PSU: Corsair TX850
Default 11-16-2007, 08:26 | posts: 3,445 | Location: Florida

Quote:
Originally Posted by danylati View Post
Install crysis or any recent game
I play CoD4 with on high with no problems on 1440*900 70Hertz,and AAx4.the only small issue I can see is in single player when there are more then 20 enemy troops and 10 of your guys crowed in one area along with a slight freez but not bad enough to bother me.
   
Reply With Quote
Old
  (#19)
isidore
Ancient Guru
 
isidore's Avatar
 
Videocard: nVidia GTX670M
Processor: i7-3610QM @ 3.2Ghz
Mainboard: Asus RoG
Memory: Asus 8Gb
Soundcard: Asus G75VW
PSU: Asus RoG
Default 11-16-2007, 08:49 | posts: 5,677 | Location: Timisoara, Romania

Quote:
Originally Posted by RazerBlue View Post
Im done with ATI , with their junk drivers and problems after problem,,
ok...so why are you telling us this!!!..sell you're card, buy whatever you want..and give us a break with this stupid threads...why do you have to tell everybody that you don't like ati no more and you're going to buy a nvidia card...just do it bro and spare us the time of watching stupid threads like this one..
   
Reply With Quote
Old
  (#20)
DeluxeTNT
Newbie
 
Videocard:
Processor:
Mainboard:
Memory:
Soundcard:
PSU:
Default 11-16-2007, 09:18 | posts: 2

I had same problems with a AGP X800XL card.

Only catalyst 7.7 and 7.8 were working with D3D. But Gears of war needs 7.9 at least (it worked with 7.7 but textures were wrong sometimes) but i got errors on Dxdiag with D3D, same with official 7.10
So i found a trick on the AMD forums. The trick is to install 7.7 then copy the atiduag.dll somewhere, then install 7.10 and replace the 7.10's atiduag.dll with the one you copied from 7.7.

So with this trick:
Gears of War: 100% ok
Hellgate: Working but some low FPS
Call of duty 4: 100% ok
NFS Pro Street: untested.
Crysis: working but with bugs and graphics are horribles

But there is an easier way to do. Omega drivers 7.10 are said to be fully compatible with AGP.

With Omega drivers 7.10
Gears of War: 100% ok
Hellgate London: 100% ok
Call of duty 4: 100% ok
NFS pro street: lots of stuttering even at 60 FPS+
Crysis: not tested yet

My advice is to test these omega drivers 7.10. If results are not good try then the trick i got from the amd forums...

Ps: Sorry for my bad english speaking skills
   
Reply With Quote
Old
  (#21)
Laykun
Ancient Guru
 
Laykun's Avatar
 
Videocard: 2 x EVGA GTX670 4GB
Processor: i7 980X
Mainboard: Gigabyte GA-X58A-UD7
Memory: 18GB DDR3 1600
Soundcard: Xonar DX / Denon AH-D7000
PSU: 850W CM Silent Pro M850
Default 11-16-2007, 10:15 | posts: 3,221 | Location: New Zealand

You realise Omega drivers don't actually change any driver code what so ever? They're just novelty drivers with a few performance tweaks which degrade IQ ( although it's quite subtle ).
   
Reply With Quote
Old
  (#22)
DeluxeTNT
Newbie
 
Videocard:
Processor:
Mainboard:
Memory:
Soundcard:
PSU:
Default 11-16-2007, 12:14 | posts: 2

Quote:
Originally Posted by Laykun View Post
You realise Omega drivers don't actually change any driver code what so ever?
Of course!
But then, do you realise that it doesn't install the same files as the official ati drivers? When installing omega 7.10 after an official 7.7 drivers, I got a message saying that I'm installing a file older that what I have on my pc.

From what I heard/understand from the amd forums, 7.10 can work on AGP cards but the install procedure of the official 7.10 only works with PCI cards .
Check on official ati/amd forums how many people with AGP cards are stucked with 7.7 drivers (hundreds?) especially nforce2 motherboards users. Some of them found tricks to install 7.10 without using the standard install procedure to have D3D working on AGP. I didn't want to go this way, being afraid of completely messing my computer stability.

Then looking for a soluce (Catalyst 7.9 or 7.10 are required by Gears of War) I saw that on the omega drivers site:
Quote:
They are based on the Official ATI Catalyst 7.10 drivers, but unlike them, these will work with AGP cards just fine, plus added support for a lot of other cards that where not present in my drivers before (like the x1950 AGP, Mobility HD2600 and many more).
That's why I tried them.
I don't know what the omega guys exactly did on their driver, but with them Dxdiag don't give me errors on D3D tests. And that's all I wanted, and that's all the OP wanted so I gave him that advice.

I'm not a graphic card expert and I don't have a great knowlegde on this matter (using Nvidia cards on my main pc). But I'm not the kind of guy that say "oh it doesn't work, ATI U SUCK!". I had exactly same problems as OP, anything higher than 7.7 (or 7.8 in my case) didn't work with D3D. I found something to make it work, I'm sharing my experience. Wether I realise or not the way a driver is made is not the subject.


Again sorry for my english, don't bother answering me, this was my second and last message on these forums...
Good luck OP with your X800 AGP card

Last edited by DeluxeTNT; 11-16-2007 at 12:20.
   
Reply With Quote
Old
  (#23)
Lahomer
Master Guru
 
Lahomer's Avatar
 
Videocard: GTX280 SLI 680/1463/1215
Processor: Intel Core i7 920 @ 4 Ghz
Mainboard: GigaByte GA-EX58-UD4P
Memory: Dominator DDR1600 6GB
Soundcard: X-Fi Titanium Fatal1ty
PSU: Rocksolid Series 1200W
Default 11-16-2007, 13:26 | posts: 429 | Location: Netherlands

bloody kids
   
Reply With Quote
Old
  (#24)
GenClaymore
Ancient Guru
 
GenClaymore's Avatar
 
Videocard: Evga 780 Dual 1202/3305
Processor: I5 3570k @4.5Ghz SA SB-E
Mainboard: Gigabyte Z77X-UD3H
Memory: 30nm 2x 4GB DDR3-1600
Soundcard: X1>Frost Uber>LDMKII>T90
PSU: Cosair 850watt RM850
Default 11-16-2007, 13:57 | posts: 5,433 | Location: Michigan,usa

Quote:
Originally Posted by danylati View Post
Install crysis or any recent game
I played crysis demo and timeshift and I dont have any problems with my ati card. just because you do. do not mean every one does.
   
Reply With Quote
Old
  (#25)
Terrorizor
Maha Guru
 
Videocard: EVGA GTX260 SC
Processor: Q9650/GTZ
Mainboard: GIGABYTE EP45-UD3R
Memory: 4gb ReaperX-800/4-4-3
Soundcard: X-Fi Fatal1ty
PSU: PC P&C Silencer 750
Default 11-16-2007, 15:49 | posts: 1,897 | Location: United States

Quote:
Originally Posted by GenClaymore View Post
I played crysis demo and timeshift and I dont have any problems with my ati card. just because you do. do not mean every one does.
exactly, too many people these days build pc's and combine parts when they have a quarter of the clue they think they do, and when the end result is foobared its everyone elses fault, but thier own. it could be nvidia, ati or creative or whatever in this threads place, its just that this guy happens to have something ancient from ati.

more than half of all pc issues somewhere down the line its the user's fault more times than nvidia,ati or creative combined. like the fact your even on an agp machine,... your fault, not ati's or nvidias,... yours. because i promise you anyone can find something to bitch about from any piece of hardware from any company.


you just unaware of agp's status er what? its not like the death of agp is just "all of a sudden". take a hint ffs. wanna hold onto your dingy agp board forever and then bitch and moan when you feel left behind,.....duh, you are, and have been for years. suck it up and be wiser on your next pc purchases. ati didnt make you buy an agp version.especially since that card was released you could buy a cheap pci-e motherboard and the pci-e version for very little over the cost of the agp model or make it easier to everyone having to read your posts, and just buy a dell or an HP and then youll have someone else to bitch at that wont completely laugh in your face for acting like a noob-nutz.
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.