Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards vs General Purpose - NVIDIA Ageia PhysX, GPGPU etc.
Videocards vs General Purpose - NVIDIA Ageia PhysX, GPGPU etc. In this section you can discuss general purpose application that run over your GPU, like transcoding, Physics simulation etc.


Reply
 
Thread Tools Display Modes
Physx9.11.1107 and UT3 GPU-physx broken
Old
  (#1)
ati666
Master Guru
 
Videocard: Gigabyte GTX 470
Processor: e8500
Mainboard: abit aw9d-max (i975x)
Memory: 8 GB ram 800mhz(2gbx4)
Soundcard: X-Fi Xtreme
PSU: Corsair HX1000W
Default Physx9.11.1107 and UT3 GPU-physx broken - 11-13-2011, 06:11 | posts: 463

hi

i just installed physx 9.11.1107 with quadro 270.51 x64 drivers.

i know UT3 has GPU-physx support, in the past it used to work. but now physx i always stuck on cpu. whats going on?

how can i force enable GPU-physx in UT3 againg with quadro270.51 win7x64 and physx software 9.11.1107?

thanks

Last edited by ati666; 11-13-2011 at 06:27.
   
Reply With Quote
 
Old
  (#2)
TheHunter
Banned
 
Videocard: MSi N570GTX TFIII [OC|PE]
Processor: Intel C2Q 9450 @ 3.576GHZ
Mainboard: Gigabyte GA-X48-DS5 [F8H]
Memory: Corsair D. 2x2GB @1073MHZ
Soundcard: XFi Fatality Pro [SB046A]
PSU: Tagan Piperock 600W [48A]
Default 11-13-2011, 14:25 | posts: 13,425 | Location: √╥²

chose your gpu instead of auto detect?

Or chose manually in UT3 profile..


Also you might want to repair Physx installer (right-click on installer and chose repair).
   
Reply With Quote
Old
  (#3)
ati666
Master Guru
 
Videocard: Gigabyte GTX 470
Processor: e8500
Mainboard: abit aw9d-max (i975x)
Memory: 8 GB ram 800mhz(2gbx4)
Soundcard: X-Fi Xtreme
PSU: Corsair HX1000W
Default 11-13-2011, 15:36 | posts: 463

none of it works.
what hould i do now?
   
Reply With Quote
Old
  (#4)
TheHunter
Banned
 
Videocard: MSi N570GTX TFIII [OC|PE]
Processor: Intel C2Q 9450 @ 3.576GHZ
Mainboard: Gigabyte GA-X48-DS5 [F8H]
Memory: Corsair D. 2x2GB @1073MHZ
Soundcard: XFi Fatality Pro [SB046A]
PSU: Tagan Piperock 600W [48A]
Default 11-13-2011, 16:00 | posts: 13,425 | Location: √╥²

Then it really is physx compatibility issue with older drivers..


either update to 285.xx (if 285.62 causes trouble then try either 285.58Q or 285.67 parallel Insight) or downgrade physx to PhysX_9.11.0621_SystemSoftware
   
Reply With Quote
 
Old
  (#5)
GenClaymore
Ancient Guru
 
GenClaymore's Avatar
 
Videocard: Evga 780 Dual 1202/3305
Processor: I5 3570k @4.5Ghz SA SB-E
Mainboard: Gigabyte Z77X-UD3H
Memory: 30nm 2x 4GB DDR3-1600
Soundcard: BiFrost Uber>LDMKII>T90
PSU: Cosair 850watt RM850
Default 11-13-2011, 16:33 | posts: 5,410 | Location: Michigan,usa

It only works with the physX map pack that Epic had released, The rest of the maps that comes with the game does it with the cpu.
   
Reply With Quote
Old
  (#6)
ati666
Master Guru
 
Videocard: Gigabyte GTX 470
Processor: e8500
Mainboard: abit aw9d-max (i975x)
Memory: 8 GB ram 800mhz(2gbx4)
Soundcard: X-Fi Xtreme
PSU: Corsair HX1000W
Default 11-14-2011, 13:56 | posts: 463

problem solved, looks like physx9.11.1107 has a serious bug which cripples gpu-physx in games.

after reverting back to physx 9.11.0621, the gpu-physx came back in ut3 and metro2033.

so, i highly recommend any one not to install physx9.11.1107, since it has a bug which will disable your gpu-physx and you will be stuck on cpu-physx all the time no matter what you do.
   
Reply With Quote
Old
  (#7)
Spets
Maha Guru
 
Spets's Avatar
 
Videocard: GTX780Ti+GTX750Ti+G-Sync
Processor: Intel Core i7 2600k @ 4.5
Mainboard: GA-Z68X-UD7-B3
Memory: G.Skill Ripjaws 16gb 2133
Soundcard:
PSU: EVGA SuperNOVA
Default 11-15-2011, 07:53 | posts: 2,021

Quote:
Originally Posted by ati666 View Post
problem solved, looks like physx9.11.1107 has a serious bug which cripples gpu-physx in games.

after reverting back to physx 9.11.0621, the gpu-physx came back in ut3 and metro2033.

so, i highly recommend any one not to install physx9.11.1107, since it has a bug which will disable your gpu-physx and you will be stuck on cpu-physx all the time no matter what you do.
It didn't work because as TheHunter stated, 9.11.1107 isn't compatible with older drivers. Same thing happened to me so I went back to using the latest beta.
   
Reply With Quote
Old
  (#8)
ati666
Master Guru
 
Videocard: Gigabyte GTX 470
Processor: e8500
Mainboard: abit aw9d-max (i975x)
Memory: 8 GB ram 800mhz(2gbx4)
Soundcard: X-Fi Xtreme
PSU: Corsair HX1000W
Default 11-15-2011, 11:49 | posts: 463

Quote:
Originally Posted by Spets View Post
It didn't work because as TheHunter stated, 9.11.1107 isn't compatible with older drivers. Same thing happened to me so I went back to using the latest beta.
which beta are you using?
   
Reply With Quote
Old
  (#9)
Spets
Maha Guru
 
Spets's Avatar
 
Videocard: GTX780Ti+GTX750Ti+G-Sync
Processor: Intel Core i7 2600k @ 4.5
Mainboard: GA-Z68X-UD7-B3
Memory: G.Skill Ripjaws 16gb 2133
Soundcard:
PSU: EVGA SuperNOVA
Default 11-15-2011, 11:58 | posts: 2,021

285.79, it's working great for me so far
   
Reply With Quote
Old
  (#10)
applejack
Master Guru
 
applejack's Avatar
 
Videocard: MSI GTX 780 Gaming OC
Processor: Intel® Core™ i7-4930K
Mainboard: GIGABYTE GA-X79-UP4
Memory: G.Skill 4x4GB 2133mhz cl9
Soundcard: Creative Sound Blaster Z
PSU: Seasonic G-650
Default 12-13-2011, 20:04 | posts: 451 | Location: Israel

I'm using PhysX 9.11.1107 alongside geforce driver 290.39 beta,

my problem is with Batman Arkham City, when setting GPU PhysX in game (Medium or High) and running its benchmark - game crashes right after a couple of seconds ingame.
no problems with physx OFF.

I know Batman AC use Unreal Engine as well... so I'm going to try the previous physx driver

Edit: confirmed, changing back to PhysX 9.11.0621 solved crashing for Batman AC with GPU PhysX.

Last edited by applejack; 12-14-2011 at 00:54.
   
Reply With Quote
 
Old
  (#11)
yosef019
Maha Guru
 
yosef019's Avatar
 
Videocard: GTX770 4gb @1250mhz
Processor: i5 3570k 4.6 1.2v NH-D14
Mainboard: P8Z68-V
Memory: 8GB 2133 ARES CL9 2T
Soundcard: SB Recon3D Pro Fatality
PSU: TX 650W
Default 01-07-2012, 04:27 | posts: 1,728 | Location: Israel - Haifa

i dont know my gpu handle high physx in batman alham city
im on 290.56
No single problem that i noticed in this driver or games
   
Reply With Quote
Old
  (#12)
applejack
Master Guru
 
applejack's Avatar
 
Videocard: MSI GTX 780 Gaming OC
Processor: Intel® Core™ i7-4930K
Mainboard: GIGABYTE GA-X79-UP4
Memory: G.Skill 4x4GB 2133mhz cl9
Soundcard: Creative Sound Blaster Z
PSU: Seasonic G-650
Default 01-07-2012, 11:34 | posts: 451 | Location: Israel

right, I forgot to update my previous post. installing 290.56 did solve the problem, works fine now w/ latest physx system software.

Last edited by applejack; 01-07-2012 at 11:36.
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.