Guru3D.com Forums

Guru3D.com Forums (http://forums.guru3d.com/index.php)
-   Videocards - AMD - ATI Drivers Section (http://forums.guru3d.com/forumdisplay.php?f=46)
-   -   Disable ULPS and Powerplay (http://forums.guru3d.com/showthread.php?t=334535)

Valagard 12-15-2010 09:17

Disable ULPS and Powerplay
 
Brought this up in the 69XX review thread, but I have to ask here

Is there -ANY- way to disable Power Play and Ultra Low Power Saving?

You know what I am talking about

First is ULPS, I own two monitors, when I hook both up, my card clocks itself to 157/300, and I get both screens tearing like mad whenever I move around windows, or even scroll windows to view this forum.

There is no way to disable this, nor is there an option in drivers to disable this.

And at last, Power Play

This is hands down the most absurd bullcrap option I've ever had forced in my face by a videocard maker.

What I am talking about is when I play a video, -ANY- video, the card clocks itself to 400/900 and refuses to budge no matter -WHAT- I load until I stop the video

So if say I want to watch a movie on monitor two, while farming in a MMO on Monitor one, it locks it at 400/900 and my framerate is TERRIBLE

And there is -NO WAY- to disable this! I've searched high and low and nothing

Even MSI Afterburner doesn't help, cause as soon as I run a video, the videocard FORCES it to 400/900, and because of the conflict with afterburner, I get a "Display has stopped responding and has recovered" error while it crashes my movie player

The -ONLY- way I've heard to disable these two options is with BIOS hacks, which is freaking obscene of all things, I don't have a floppy drive, so I'm keen on booting into DOS to do a bios flash, not to mention I am using a 64 bit OS so even then I can't get the bios file off my videocard

Short of a bios flash, is there -ANY- way I can disable these options?

EDIT1: I just found a way to disable ULPS by editing the profile settings file, then after its set up, you have to select it -TWICE- and then it keeps your clocks to whatever you set, and the voltage

That said, I still need to find out of there is a way to disable Power Play from kicking in with my videos, I just tried a 1080P video, and boom, it kicked into 400/900 instantly. The upside though is after the profiles thing when I stopped the video it went to 725/1000 without skipping a beat, so its stopped my monitor tearing

hunuok 12-15-2010 10:01

It's been a while since I used dual 5970s OR ATI. So am going off memory....

To change powerplay:

1 Open CCC and choose Overdrive tab, unlock (by clicking on the " Gold Key" icon)
2 Go top options, profile and choose profile manager.
3 In the composition tab, choose "The following settings" and in the "ATI Radeon HD 58xx/57xx series "make sure only ATI overdrive is checked.
Then enter a profile name,then save and close it (Do not activate).
4 Go to C:\Users\Your UserName\AppData\Local\ATI\ACE\Profiles (It's hidden so make sure you unlock hidden files and folders)

<Feature name="CoreClockTarget_0">
<Property name="Want_0" value="15700" />

<Feature name="MemoryClockTarget_0">
<Property name="Want_0" value="30000" />

By changing these 2, your idle 2D clocks changes. Make sure to activate the profile in CCC when you make changes.

To change ULPS:

1 Go to regedit (start>search programs and files>"regedit")
2 In drop down menu: find file>type "eneableulps"
3 For ALL instances (keep pressing F3) change the "1" value to a "0".
4 Reboot.

Good luck.

Altra001 12-15-2010 15:26

Hello Val

Funny you should ask about Ultra Low Power Savings.

I just posted one today and fond the answer.
Much what Hunuok said.

Read my thread:
http://forums.guru3d.com/showthread.php?t=334513

Hope it helps.

Valagard 12-15-2010 15:36

I tried both, I can stop the screen flickering, but I can't stop the card from downclocking when playing Video's still too 400/900

jskyg 12-15-2010 18:13

I'm having issues with powerplay also, only with the newest drivers though, these are the latest correctly working drivers I've found.

http://forums.guru3d.com/showthread.php?t=334207

Choppazilla 12-15-2010 23:25

hey,

i could it fix on this way...

http://www.youtube.com/watch?v=y4l61...eature=related

Valagard 12-16-2010 14:18

Like I said I fixed my monitors flickering all the time, but I still can't keep powerplay from kicking in whenever I play videos and setting itself to 400/900

slamdunk1973 12-16-2010 14:59

i have had to successes with stopping my card downclocking

(1) Use MSI Afterburner to apply a small overclock to the card and tick the box to set this from windows start.
(2) I modded the BIOS for my card using a combination of GPUZ (to capture bios, please save for backup purposes), the RBE and flash tools from the Techpowerup website.

Save your bios using GPUZ, then open this saved file with RBE.
Using RBE you can then set the min and max clock rates for all the various downclocking options(careful not to set anything other than the highest your card runs)
Save this new bios, with a different file name.
Flash the card using one of the flash tools on the techpowerup site. reboot and check

this is all done from windows so its easy enough. if the modded bios is flakey, just reflash with the default bios that you have saved.

felang 12-16-2010 21:03

I think some of the mods that Von makes to drivers have to do with disabling these features...

http://forums.guru3d.com/showthread.php?t=332395

heroxoot 10-29-2012 21:48

see I dont have the same flicker as you guys. I see distortion and messed up textures when OC due to power play. It only happens when clocks keep changing during a 3d game. I wish I could explain it more, but it kind of looks like the dvi cable on the gpu is being jiggled as I play, and the screen kind of distorts in different areas. Running stock clocks for games that do this fixes the issue, but the issue does not happen in heaven benchmark, 3dmark11, BF3, borderlands 2, and some other assorted games. It only happens when my clocks do not stay stable, and switch between 500 - 1200OC.

Espionage724 10-30-2012 04:27

Quote:

Originally Posted by Valagard (Post 3810896)
That said, I still need to find out of there is a way to disable Power Play from kicking in with my videos, I just tried a 1080P video, and boom, it kicked into 400/900 instantly. The upside though is after the profiles thing when I stopped the video it went to 725/1000 without skipping a beat, so its stopped my monitor tearing

I fixed this on my 5570 by simply editing my BIOS file to only have the highest clocks, on all 3 clock states. So technically, PowerPlay was still active, but the clocks didn't change.

tweakpower 10-30-2012 16:13

Quote:

Originally Posted by Espionage724 (Post 4442919)
I fixed this on my 5570 by simply editing my BIOS file to only have the highest clocks, on all 3 clock states. So technically, PowerPlay was still active, but the clocks didn't change.

I think i will trash powerplay also, will look for program to edit BIOS, last time i did it on nV card with nBitor.

The worst move by AMD/ATI. They could simply put clocks at half for 2D and save users of problems... i have problems with flash, not as drastic...but they are.


All times are GMT +1. The time now is 01:09.

Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.