Guru3D.com Forums

Guru3D.com Forums (http://forums.guru3d.com/index.php)
-   Games, Gaming & Game-demos (http://forums.guru3d.com/forumdisplay.php?f=13)
-   -   Dolphin emulator running slowly (http://forums.guru3d.com/showthread.php?t=327292)

weston 08-18-2010 05:13

Dolphin emulator running slowly
 
On several games, this emulator is having problems keeping stable framerates. sometimes dipping into the low 20's while others having a good 60fps. any tips on how to run it so it speeds up, or does it just take too much processing power to emulate a wii/gamecube? Games like smash bros work fine, but even the new mario wii (not galaxy 2) is horrible.


any ideas or is this common? thx!

UnrealGaming 08-18-2010 06:03

I only played Resident Evil Remake, Resident Evil Zero and Zelda TP. All three run @ full speed. Which is 25 fps for PAL games and 30FPS for NTSC gamecube games.
Not sure how Wii or other gamecube games run on Dolphin.

And with latest versions of Dolphin i only get 30-40% CPU usage. So, it doesn't seem to need that much power.

IPlayNaked 08-18-2010 06:25

Which video plugin?

Mkilbride 08-18-2010 06:29

It has to do with your Phenom sadly, it's optimized for Intel. I can run most games on it at max speed.

That said, alot of games just aren't optimized / work correctly.

http://code.google.com/p/dolphin-emu/issues/list

crushilista 08-18-2010 06:56

It works fine for me. Of course this, and PSX2, are crafted towards Intel.

IPlayNaked 08-18-2010 15:19

Personally, I can play most PS2 games and all Dolphin games at max. I don't think it's a phenom thing. I mean, you do need an overclock though, there's no way around that.

avivoni 08-18-2010 15:27

Many games run slow even on the most powerfull PC. You must wait for newer releases of dolphin and hope they get it fixed. If you read on their official forum people are getting good frames and you are not, then try to find what settings they are using. D3d is always faster than opengl. and ive found that in some games setting max FPS to AUTO is fine, and in others I set to 120 wich is max and also disable the audio throttle in the DSP plugin settings. always use EFB copy to texture as its the fastest.

new super mario bros wii runs perfect on my system and on a friends with dual core.

and mario galaxy 2 almost perfect getting slow downs at begining of levels.

and now read the first 2 sentences of my reply again.

Extraordinary 08-18-2010 15:36

I was getting slo-mo for my games in dolphin so went through every setting until I found the reason

You might try changing to this setting

http://img819.imageshack.us/img819/9254/captureml.jpg


All times are GMT +1. The time now is 10:51.

Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.